Bug 69550 - [UX] [a11y] Style keyboard shortcuts are undiscoverable
Summary: [UX] [a11y] Style keyboard shortcuts are undiscoverable
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval
Depends on:
Blocks: Shortcuts-Accelerators a11y
  Show dependency treegraph
 
Reported: 2013-09-18 20:48 UTC by Tin Man
Modified: 2016-09-17 20:41 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tin Man 2013-09-18 20:48:05 UTC
Style keyboard shortcuts are undiscoverable.

I'd suggest showing them to the right of the style name in the style combo box in a lighter color, similarly to how keyboard shortcuts are shown in menus.
Comment 1 Cor Nouws 2013-09-19 16:45:55 UTC
Hi Mirek,

(In reply to comment #0)
> Style keyboard shortcuts are undiscoverable.

F1, landing page > link to shortcuts ..

> I'd suggest showing them to the right of the style name in the style combo
> box in a lighter color, similarly to how keyboard shortcuts are shown in
> menus.

thanks - Idea looks fine.

But do we have a metabug, or a overall project to create a plan before (suggesting to) impelment(ing) separate ideas?

Cor
Comment 2 Tin Man 2013-09-19 16:57:08 UTC
(In reply to comment #1)
> Hi Mirek,
> 
> (In reply to comment #0)
> > Style keyboard shortcuts are undiscoverable.
> 
> F1, landing page > link to shortcuts ..
> 
> > I'd suggest showing them to the right of the style name in the style combo
> > box in a lighter color, similarly to how keyboard shortcuts are shown in
> > menus.
> 
> thanks - Idea looks fine.
> 
> But do we have a metabug, or a overall project to create a plan before
> (suggesting to) impelment(ing) separate ideas?

No.
Given that there's very little developer interest in working on UX bugs, I see bitesized bugs as the only chance for getting anything solved.

Do you have any suggestions on ways to get UX bugs solved?
Comment 3 V Stuart Foote 2013-09-22 05:21:31 UTC
Undiscoverable because they are not assigned.

Beleive the Styles & Formatting probably should have an SytleCommand.xcu created, or at the least appropriate stanzas added to the GenericCommands.xcu configuration.

In addition to UX issue this is a major Accessibility and keyboard navigation issue.

Impacts the <F11> Sytles & Formatting Frame, as well as its rendering in the Sidebar.

In an Accessibility context, "lighter color" is not a viable UX implementation, and is too far removed from the underlining used for accelerators assigned to Menus.
Comment 4 Robinson Tryon (qubit) 2013-10-23 17:24:52 UTC Comment hidden (obsolete)
Comment 5 V Stuart Foote 2014-02-03 15:21:25 UTC
The native accessibility bridges expose the lists of the 'Styles and Fomatting' <F11>  pop-up panel when navigated with <TAB> and Cursor keys (U,D,L,R). But as noted there have never been 'accelerators' associated with any component of this toolbar panel.

For accessibility it would be helpful if a consistent set of accelerators could be assigned to at least the major headings--e.g. the Paragraph, Character, Frame, Page and List styles.

Also, it would probably be most functional if the 'accelerator' for each of these place active focus onto the panel list item of the currently active document cursor.

Besides helping to encourage use of Style rather than Direct formatting in documents, this would greatly improve the work flow for keyboard users, notably folks needing Assistive Technology tool support.  I.e. directly navigating onto the correct list item with a single keystroke, rather than multiple <TAB> and cursor movements listening for the right location.
Comment 6 Cor Nouws 2014-02-03 17:22:53 UTC
Hi V Stuart,

I just was about to close (mid air collision ;) ) this as duplicate of bug 62081

This since we discussed at the UX hackfest that keyboard shortcurts can be properly shown in split menus ..

What do you think?
Comment 7 Joel Madero 2014-02-27 23:38:06 UTC
In order to limit the confusion between ProposedEasyHack and EasyHack and to make queries much easier we are changing ProposedEasyHack to NeedsDevEval.

Thank you and apologies for the noise
Comment 8 Yousuf Philips (jay) (retired) 2015-12-12 15:05:41 UTC
(In reply to Tin Man from comment #0)
> Style keyboard shortcuts are undiscoverable.

They are now discoverable with the introduction of the Style menu in 5.1.

> I'd suggest showing them to the right of the style name in the style combo
> box in a lighter color, similarly to how keyboard shortcuts are shown in
> menus.

I dont think it would be a good idea to do this, as the combobox isnt a menu and we have introduced a submenu to entries.

I propose closing this.
Comment 9 V Stuart Foote 2015-12-12 17:53:32 UTC
Jay, *

(In reply to Yousuf (Jay) Philips from comment #8)
> (In reply to Tin Man from comment #0)
> > Style keyboard shortcuts are undiscoverable.
> 
> They are now discoverable with the introduction of the Style menu in 5.1.
> 

...

> 
> I propose closing this.

Having the Styles menu for Writer is a definite improvement (thanks Jay!). But the menu in Writer is only assigning Paragraph and Character styles with .uno:StyleApply actions. We can not style Frames, Pages or Lists from menu or by short-cut/accelerator. 

Otherwise keyboard navigation does not seem to be fully resolved. Yes menu elements have been done for Writer with additions to WriterCommands.xcu -- but no similar menu with keyboard short-cuts/accelerators have been provided for styling paragraphs/characters in Draw/Impress text blocks, nor in Calc cells. The Format -> Styles in Calc is un populated. And the Format menu entries in Draw/Impress do direct formatting of the drawing objects. 

Also, we've done nothing for Keyboard navigation in the Sidebar Styles & Formatting (F11) deck, nor in the Sytles dropdown content panel of the Properties deck.   In general for navigating the Sidebar we remain bound to F10, F6 and a muddled mix of cursor and Tab movements. The very thing direct short-cuts/accelerators would simplify.

So, IMHO don't see this as ready to close. Although it probably needs more design and discussion of how best to provide full keyboard navigation for Assistive Technology support.  

Stuart

=-ref-=
http://cgit.freedesktop.org/libreoffice/core/commit/?id=6c189a1eb90012789692344aa7dc418c7ec7f032

http://cgit.freedesktop.org/libreoffice/core/commit/?id=66a7292f2faf51cc0ba018771a5ab25e8d7b5929


As a suggestion for all interested--when assessing completeness of the UI please try to navigate using just the keyboard (no mouse)--or better turn off the display with reliance on just ORCA or NVDA or JAWS to sound your session navigation. If you can't create useful documents without peeking we're not meeting the needs of our Accessibility Tools dependent users. Likewise if navigation is not clear consistent and concise across the modules.
Comment 10 Robinson Tryon (qubit) 2015-12-13 11:21:25 UTC Comment hidden (obsolete)
Comment 11 Yousuf Philips (jay) (retired) 2016-09-04 22:55:49 UTC
(In reply to V Stuart Foote from comment #9)
> Having the Styles menu for Writer is a definite improvement (thanks Jay!).
> But the menu in Writer is only assigning Paragraph and Character styles with
> .uno:StyleApply actions. We can not style Frames, Pages or Lists from menu
> or by short-cut/accelerator. 

Filed a bug for this (bug 101896).

> Otherwise keyboard navigation does not seem to be fully resolved. Yes menu
> elements have been done for Writer with additions to WriterCommands.xcu --
> but no similar menu with keyboard short-cuts/accelerators have been provided
> for styling paragraphs/characters in Draw/Impress text blocks, nor in Calc
> cells. The Format -> Styles in Calc is un populated. And the Format menu
> entries in Draw/Impress do direct formatting of the drawing objects. 

Didnt add any entries in Calc, as presently we dont have any useful cell styles, but i could add the current 5 cell styles to the menu. Not possible to do the same for impress/draw.

> Also, we've done nothing for Keyboard navigation in the Sidebar Styles &
> Formatting (F11) deck, nor in the Sytles dropdown content panel of the
> Properties deck.   In general for navigating the Sidebar we remain bound to
> F10, F6 and a muddled mix of cursor and Tab movements. The very thing direct
> short-cuts/accelerators would simplify.

True, but that doesnt seem to be the issue of this bug report.
Comment 12 Heiko Tietze 2016-09-05 07:03:23 UTC
(In reply to Yousuf Philips (jay) from comment #11)
> Filed a bug for this (bug 101896).

I vote for closing this ticket as FIXED as the basic shortcuts are easily accessible now.
Comment 13 V Stuart Foote 2016-09-05 11:27:06 UTC
This is nowhere near resolved. As in comment 5 still need to instrument the <F11>/Styles and Formatting Sidebar deck for keyboard shortcuts.

There remains no direct accelerator/shortcut movement to the respective type of style on the content panel list: i.e. Paragraph, Character, Frame, Page, List, Table in Writer.  

Such that entering <F11>+<"shortcut">--maybe Alt+P, Alt+C, Alt+F, Alt+P, Alt+L, Alt+T--directly opens the content panel list sounding the active/selected style.

That at a minimum would move us beyond the present cyclical use of <F6>, Tab and arrow cursor movements to navigate by keyboard only.
Comment 14 Yousuf Philips (jay) (retired) 2016-09-13 02:43:09 UTC
(In reply to V Stuart Foote from comment #13)
> This is nowhere near resolved. As in comment 5 still need to instrument the
> <F11>/Styles and Formatting Sidebar deck for keyboard shortcuts.

Comment 5 goes beyond the scope of this bug report which isnt what the bug description was opened for.

> There remains no direct accelerator/shortcut movement to the respective type
> of style on the content panel list: i.e. Paragraph, Character, Frame, Page,
> List, Table in Writer.  

The OP talked about the paragraph style combobox and you are suggesting improvements to the styles sidebar, so this should be in another bug report.

> Such that entering <F11>+<"shortcut">--maybe Alt+P, Alt+C, Alt+F, Alt+P,
> Alt+L, Alt+T--directly opens the content panel list sounding the
> active/selected style.

Only modifiers like alt, shift and ctrl can be used with Fn keys, so F11+Alt+P wouldnt work.