Bug Hunting Session
Bug 69734 - UI: UI DropDown Menu appears in other tables
Summary: UI: UI DropDown Menu appears in other tables
Status: RESOLVED DUPLICATE of bug 61623
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Cell-Validity
  Show dependency treegraph
 
Reported: 2013-09-23 20:29 UTC by soren.jentzsch
Modified: 2018-01-17 17:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document for reproducing the bug + Slideshow showing the misbehavior (58.24 KB, application/zip)
2013-09-23 20:29 UTC, soren.jentzsch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description soren.jentzsch 2013-09-23 20:29:54 UTC
Created attachment 86419 [details]
Sample document for reproducing the bug + Slideshow showing the misbehavior

Problem description:
When I create a dropdown menu (via data/validity, referencing to a certain cell area) in one table, the icon for that dropdown menu appears in all the other tables. Clicking on the fake icon in the other tables, it lists the cells in the same row in that table. However, when I select another cell, the icon and also the underlying functionality disappears.
Moreover, when I select another cell in the table I created the drop down menu, the dropdown-icon also disappears (which it shouldn't I suppose).
The attachment contains a slideshow and a sample document of this misbehavior.

Steps to reproduce:
Just open the small sample document in the attachment.

Current behavior:
- described above -

Expected behavior:
1) Dropdown-Menu-Icon in all the other tables (except the one where I created it) should neither be drawn nor having a misbehaving functionality
2) Icon for the drop down menu in the table i created it should never disappear, whatever cell I select.
Operating System: Windows 7
Version: 4.1.1.2 release
Comment 1 Dominique Boutry 2013-10-16 17:41:22 UTC
With LibO 4.0.5.2 on Win7

Partially reproduced : when clicking on the fake icon, it lists an erratic area (not always the same row).

I disagree with your second part : when you are in the table where you have created drop-down menu(s), there is one dropdown menu per cell selected/marked at the data > validity setting, and only the dropdown menu icon of the selected cell (if it has some) is shown. For me, this is the correct behavior.
Comment 2 soren.jentzsch 2013-10-17 05:27:01 UTC
(In reply to comment #1)
> With LibO 4.0.5.2 on Win7
> 
> Partially reproduced : when clicking on the fake icon, it lists an erratic
> area (not always the same row).
> 
> I disagree with your second part : when you are in the table where you have
> created drop-down menu(s), there is one dropdown menu per cell
> selected/marked at the data > validity setting, and only the dropdown menu
> icon of the selected cell (if it has some) is shown. For me, this is the
> correct behavior.

Thanks Dominique first of all for investigating into this issue.

Yes, the false icon should definitely disappear when changing the tables.

Concerning the second issue: In the past experience of Open Office etc., the dropdown icon never disappers in the table you created a dropdown menu, whatever cell selected. Selecting any cell should not result in removal of all other icons (I really mean the icons, not the menue functionality itself!).
In our business, when filling out a formula, with the current behavior each time you have to first select the cell with the dropdown menu, then select the drop down icon. Why not show valid drop down icons all the time? I consider this as being a bug, am I wrong?
Comment 3 Dominique Boutry 2013-10-17 13:24:28 UTC
Why not show valid drop down icons all the time ?

To my knowledge, no other spreadsheet software found it valuable (I can't remember for earlier versions of OOo, but AOO 4.0 don't do it). Probably because it will definitivly hide part of the content of all cells right to icon-showing ones ; and perhaps because it could lead to a huge number of visible icons (hugely overloaded screen).
Comment 4 Jean-Baptiste Faure 2013-11-23 16:56:09 UTC
I do not reproduce with version 4.1.4.0.0+ under Ubuntu 13.10 x86-64. No fake icon for me.

Please could you upgrade your installation to the current stable version (4.1.3) and try again?

Best regards. JBF
Comment 5 QA Administrators 2014-06-01 21:30:43 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2014-07-08 17:18:30 UTC Comment hidden (obsolete)
Comment 7 rtaft 2017-02-01 18:56:53 UTC
I just witnessed this in 5.1.3 and in 5.3.0.3 after upgrading.
Create multitabbed spreadsheet with data including a cell that has a dropdown.
Select the cell with the dropdown so the dropdown arrow appears.
Change to a different tab, the dropdown arrow is still visible.
Select the dropdown arrow, and the dropdown is populated with values from the same column.

Linux Mint 18.0
Comment 8 Roman Kuznetsov 2017-12-10 19:37:31 UTC
Xisco, is this duplicate 61623?
Comment 9 Xisco Faulí 2018-01-17 17:30:49 UTC
(In reply to kompilainenn from comment #8)
> Xisco, is this duplicate 61623?

Yep, it looks so. Thanks

*** This bug has been marked as a duplicate of bug 61623 ***