Bug 69774 - EDITING: Pasting more than one cell brings up the Text Import dialogue
Summary: EDITING: Pasting more than one cell brings up the Text Import dialogue
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA NeedKDE
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-24 21:18 UTC by Mike Bianchi
Modified: 2015-12-22 01:31 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
What pops up when Pasting multiple lines. (115.32 KB, image/png)
2013-09-24 21:18 UTC, Mike Bianchi
Details
screen shots -- the last one illustrates one form of the problem (496.44 KB, application/x-compressed-tar)
2013-12-30 02:36 UTC, Mike Bianchi
Details
Help -> About (65.07 KB, image/png)
2013-12-30 02:42 UTC, Mike Bianchi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Bianchi 2013-09-24 21:18:13 UTC
Created attachment 86485 [details]
What pops up when Pasting multiple lines.

This is reported at length at         
http://ask.libreoffice.org/en/question/1926/paste-loses-cell-format-in-calc-and-other-pasting-issues/?sort=latest#sort-top

This is definitely not fixed as of LibreOffice 4.1.0.4 410m0(Build:4) on Debian Wheezy.

It is easy to reproduce. select a line by clicking the line number.
 Copy it.
 Try to paste it by clicking another line number.
 It does not work. (once upon a time ...)

 Copy the line again.
 Paste into the first cell of a line.
 THAT works.

 Now select a column of first cells and Paste into them.
 You get the Text Import dialog!
Operating System: Debian
Version: 4.1.0.4 release
Comment 1 tommy27 2013-09-29 06:57:18 UTC
I do not see this issue in 4.1.1.2 under Win7 64bit.
did you try upgrading from 4.1.0? if issue persist must some Linux specific bug.

would you please provide a test file where you constantly reproduce the bug?
Comment 2 Mike Bianchi 2013-09-30 12:09:13 UTC
I strongly suspect the bug is Linux related.

Can someone try it on a recent Linux release?
Comment 3 Joel Madero 2013-11-15 22:12:32 UTC
These directions aren't very useful to be honest - 

 Copy it.
 Try to paste it by clicking another line number.
 It does not work. (once upon a time ...)

So I took that as this:
Select row 1 by clicking on the 1 on the left side of the window
Copy using ctrl + c
Select row 5 by clicking on the 5 on the left side of the window
paste using ctrl + v

This works fine for me

 Copy the line again.
 Paste into the first cell of a line.
 THAT works.

So I took that as this:
Select row 1 by clicking on the 1 on the left side of the window
Copy using ctrl + c
Select cell A5
paste using ctrl + v


Now select a column of first cells and Paste into them.
 You get the Text Import dialog!


This: - no clue what "select a column of first cells" means (do you mean select column A and try to paste the row 1 into it?")

Marking as NEEDINFO as I just don't know what I'm trying to reproduce. Also the first "issue" in this bug (please keep issues 1 per bug report, here there are 2 I suppose), I cannot reproduce, I can paste just fine using 4.1.1.2 on Ubuntu 13.04

Once you explain the last blurb a bit better please set to UNCONFIRMED and I will try again to reproduce this second issue
Comment 4 Mike Bianchi 2013-11-22 16:57:43 UTC
I apologize for not responding to Joel's questions.
I have a workaround (that involves a 2008 copy of OpenOffice) that let's me
get my work done, and I have been _very_ busy.

I hope to attach screen shots shortly of the problems I am seeing to make the issue clearer.

Before I do that, I will attempt to load a more recent version of LibreOffice.

Mike
Comment 5 Mike Bianchi 2013-12-30 02:36:43 UTC
Created attachment 91310 [details]
screen shots -- the last one illustrates one form of the problem
Comment 6 Mike Bianchi 2013-12-30 02:42:51 UTC
Created attachment 91311 [details]
Help -> About
Comment 7 Mike Bianchi 2013-12-30 02:44:04 UTC
See added attachments:
 screen shots -- the last one illustrates one form of the problem
 Help -> About
Comment 8 Mike Bianchi 2013-12-30 02:48:40 UTC
With image files:  calc[1-9]

calc1  select a line by clicking the line number.
calc2  Copy it.
calc3  Try to paste it by clicking another line number.
calc4  It does not work. (once upon a time ...)

calc5  Copy the line again.
calc6  Paste into the first cell of a line.
calc7  THAT works.

calc8  Now select a column of first cells and Paste into them.
calc9  You get the Text Import dialog!
Comment 9 Mike Bianchi 2013-12-30 03:15:11 UTC
I just installed ...

   Version: 4.1.4.2
   Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72

The bug is still present, excactly as described.
Comment 10 Mike Bianchi 2014-01-01 15:26:39 UTC
/usr/bin/libreoffice now identifies itself as
  Version: 4.1.2.3
  Build ID: 410m0(Build:3)

I've discovered that the bug I am observing seems to be associated with KDE.
  kdesudo -v
    Qt: 4.8.2
    KDE Development Platform: 4.8.4 (4.8.4)
    KdeSudo: 3.4.2.3


When I attempt to reproduce it on GNOME or LXFCE on 
  uname -a
    Linux foveal5 3.2.0-4-amd64 #1 SMP Debian 3.2.51-1 x86_64 GNU/Linux
I get the traditional, correct behaviour.

Synaptic tells me that  kde5  is available, but I am concerned that
attempting to upgrade to it may break other things.
Does anyone have any advice on upgrading to kde5?
Comment 11 Maxim Monastirsky 2014-01-01 18:45:09 UTC
@Mike: Could you shutdown Klipper (it's the scissors icon in the system tray), and report us if it solves your problem?
Comment 12 Mike Bianchi 2014-01-01 19:29:44 UTC
(In reply to comment #11)
> @Mike: Could you shutdown Klipper (it's the scissors icon in the system
> tray), and report us if it solves your problem?

Yes!  I does!  At least for the most basic test example I use.

OH Thank You!

I don't depend on the Klipper that much, so not starting it is not much of a burden.
Comment 13 Robinson Tryon (qubit) 2015-12-22 01:31:57 UTC
Removing comma from Whiteboard (please use a space to delimit values in this field)
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Whiteboard#Getting_Started
[NinjaEdit]