Download it now!
Bug 69873 - REPORTBUILDER: Labels are not shown when generating reports on spreadsheets
Summary: REPORTBUILDER: Labels are not shown when generating reports on spreadsheets
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.1.1.1 rc
Hardware: Other All
: medium normal
Assignee: Lionel Elie Mamane
URL:
Whiteboard: BSA target:4.3.0 target:4.2.1 target:...
Keywords: regression
: 71266 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-09-27 07:47 UTC by aironmail
Modified: 2014-02-05 09:17 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Simple db file with a report in spreadsheet mode to reproduce the described problem. (6.99 KB, application/vnd.sun.xml.base)
2013-09-27 07:47 UTC, aironmail
Details

Note You need to log in before you can comment on or make changes to this bug.
Description aironmail 2013-09-27 07:47:23 UTC
Created attachment 86708 [details]
Simple db file with a report in spreadsheet mode to reproduce the described problem.

Problem description: 

Steps to reproduce:
1. Create a report that includes some labels, choosen spreadsheet as output
2. Run the report
3. The data is displayed, but the labels are missing

Current behavior:
The labels are not visible on the report, only the data.

Expected behavior:
Data and labels should be visible on the output document.

That's something that was working properly on the past. I don't know exactly when the problem appeared, but I can confirm that it exists on all versions since 4.1.1.2 up to the last rc version 4.1.2.2.

The thing is that the problem only happens if we choose spreadsheet as output. If we switch to a writer file as output then it does it correctly.

I attach a file to repreduce the issue.
Operating System: Windows 7
Version: 4.1.1.2 release
Comment 1 Robert Großkopf 2013-09-28 18:09:44 UTC
Can confirm this behavior for Linux 64bit rpm. The labels were shown up to LO 4.1.0.4 and LO 4.0.3.3. Beginning with LO 4.1.1.1 and 4.0.5.2 I can't see the labels. 
In LO 4.0.4.2 there was a bug so reports couldn't be opened there and I couldn't see, if it would work in this version ...
Comment 2 frofa 2013-09-29 22:44:23 UTC
I can confirm this behaviour on Mac OS 10.6.8 using LO 4.0.5.2
Comment 3 Robert Großkopf 2013-11-08 16:36:56 UTC
*** Bug 71266 has been marked as a duplicate of this bug. ***
Comment 4 Michael Stahl (CIB) 2014-02-04 22:50:04 UTC
indeed regression in 4.1.1 release, from:

commit be945e8e54a93921a12597c7b3a5b012951600ac
Author:     Lionel Elie Mamane <lionel@mamane.lu>
AuthorDate: Tue Jul 23 19:14:04 2013 +0200

    fdo#67186 switch reporbuilder to null date == 1899-12-30
Comment 5 Commit Notification 2014-02-05 06:44:32 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7ce47d69b3565cbb9e80294127e00648c24955dc

fdo#69873 FixedText (label) is implemented as no value



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Lionel Elie Mamane 2014-02-05 07:10:55 UTC
Thanks for the pointer.

On Tue, Feb 04, 2014 at 10:50:04PM +0000, bugzilla-daemon@freedesktop.org wrote:
> https://bugs.freedesktop.org/show_bug.cgi?id=69873
> 
> Michael Stahl <mstahl@redhat.com> changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                  CC|                            |lionel@mamane.lu,
>                    |                            |mstahl@redhat.com
> 
> --- Comment #4 from Michael Stahl <mstahl@redhat.com> ---
> indeed regression in 4.1.1 release, from:
> 
> commit be945e8e54a93921a12597c7b3a5b012951600ac
> Author:     Lionel Elie Mamane <lionel@mamane.lu>
> AuthorDate: Tue Jul 23 19:14:04 2013 +0200
> 
>     fdo#67186 switch reporbuilder to null date == 1899-12-30
>
Comment 7 Commit Notification 2014-02-05 09:15:57 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=65bf8fb6d5b6193d6d338fadba296dc10f6cd18e&h=libreoffice-4-2

fdo#69873 FixedText (label) is implemented as no value


It will be available in LibreOffice 4.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2014-02-05 09:17:22 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2dc383cd014bad144bdaa208fed309f48ad95ba7&h=libreoffice-4-1

fdo#69873 FixedText (label) is implemented as no value


It will be available in LibreOffice 4.1.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.