Bug 69993 - PRINTING: Option "view zero values" does not affect the page style option "print zero values"
Summary: PRINTING: Option "view zero values" does not affect the page style option "pr...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Page-Dialog Print-Dialog
  Show dependency treegraph
 
Reported: 2013-10-01 09:44 UTC by Eugen Colesnicov
Modified: 2017-12-07 12:54 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugen Colesnicov 2013-10-01 09:44:29 UTC
Problem description: 
In LibreOffice Calc, if formulas generated zero values, it possible to hide them on screen by disabling option "view zero values" from Options. But for the default, zero values printing. I should one more time to open Page Style window, and disable "print zero values" option.

It is no logical. These two options should be linked. If I change global view option "hide view zero values" - also option "print zero values" should be disable (but I can change print option manually).
Operating System: All
Version: 4.1.1.2 release
Comment 1 Cor Nouws 2013-10-01 10:41:51 UTC
Hi Eugen,

Thanks for writing your suggestion. 
On beforehand I would say that I do not agree with you. It's not for nothing that both are offered and work separate ..

You could start a discussion on the UX-list, if you like to see what others think.
Cheers,
Cor
Comment 2 Robinson Tryon (qubit) 2013-10-23 17:26:33 UTC Comment hidden (obsolete)
Comment 3 QA Administrators 2014-05-17 00:34:09 UTC
Dear Bug Submitter,

Please read the entire message before proceeding.

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 4 Stefan Knorr (astron) 2014-05-20 07:11:01 UTC
Can reproduce on LibreOffice 4.2.4.2 (from OpenSUSE), setting to NEW.

I do agree with Eugen to some extent: the setting in Tools > Options > LibreOffice Calc > View should also toggle the setting in Format > Page > Sheet _on new documents_ (or documents where the Page setting is unset in the XML format).
That way both options could stay mostly independent and the general user expectation of printing what is on screen would be met. If a user wants the display & print options to differ, they would have to set that once per document.
Comment 5 Cor Nouws 2014-06-22 14:42:10 UTC
One is in the VIEW settings and the other is in the TEMPLATE/document settings.
IMO this is a WONTFIX
Setting so in absence of any discussion on UX. 

Pls let's don't change old behaviour without very obvious reason or decent discussion :)
Comment 6 Stefan Knorr (astron) 2014-06-22 14:56:48 UTC
(In reply to comment #5)
> Pls let's don't change old behaviour without very obvious reason or decent
> discussion :)

If you are aiming for discussion, I don't get why you would be closing the bug (which generally is an attempt to shut down further discussion)...
Not reopening solely to avoid an open/close-war, but I think this should be reopened.
Comment 7 Cor Nouws 2014-06-22 15:21:48 UTC
Enough war without us adding some ;)
Will set to NEEDINFO then ..
Comment 8 Cor Nouws 2014-06-22 15:22:13 UTC
because that is what we need from a proper discussion IMO
Comment 9 QA Administrators 2015-01-02 18:47:56 UTC
Per new procedures, moving this to NEW and requesting ux-advice (Stefan, et. all). This should not be in NEEDINFO - it's a simple UX enhancement request that UX should decide how to move forward.
Comment 10 Robinson Tryon (qubit) 2016-08-25 04:21:35 UTC Comment hidden (obsolete)
Comment 11 Heiko Tietze 2017-11-27 10:40:17 UTC
Regina, is there any reason to hide zeros per workstation and not per document like it's done for printing?

(Added this topic to the agenda for the design meeting Nov/29 2017.)
Comment 12 Regina Henschel 2017-11-27 14:52:12 UTC
The property ShowZeroValues is per document. The setting in Tools > Options works on the current active document. For new documents it is always checked, in case you use the default document template.

There is no ODF property for ShowZeroValues, but it is saved in the settings.xml. Content of the setting items in the settings.xml file are not standardized. So if LibreOffice decides to change the behavior so, that it is per sheet, that would be possible without ODF problems.

For printing it is standardized in ODF. It is the attribute style:print in the element <style:page-layout-properties>.
Comment 13 csongor 2017-12-06 12:25:39 UTC
In the beginning it was not clear for me where to find these checkboxes so if somebody has the same problem then here is the precise location of them.

The Tools -> Options -> Libreoffice Calc -> View -> Display -> Zero values checkbox 
- is an application-wide setting and 
- determines whether the zeros are to be shown or hidden _on_the_screen_.
By contrast, the Format -> Page -> Sheet -> Print -> Zero values 
- is a setting with the scope of the current file and 
- refers to print or not to print zero values.
	
It is obvious that the current behaviour can be confusing if the printed content is different than the one on the screen. 
	
I personally cannot see the benefit of hiding all the zero values globally in all documents so I think the Tool -> ... -> Zero values is useless in its current shape, therefore, it should be removed.
	
On the other hand, the Format -> ... -> Zero values setting has its benefit but the location of this setting is not the best, nor the usability. 	
	
I think whether to display zero values or not, it should be a toggle switch under the View menu, for example: View -> Show Zero Values, similarly to the View -> Formatting Marks in Writer. The reason is that in most cases it is not a per-document setting. It is much rather a per-moment setting. I want to see the zeros _now_ and don't want to see them a minute later. This setting should not be saved into the document but its current value should impact both the screen and the printed versions.

If the user wants to have _saved_ settings for hiding/showing zero values then they should use conditional formatting on the appropriate cells (or all of the cells). Format -> Conditional formatting -> Condition -> "Cell value is equal to 0, Apply style -> Hidden". 
	
(The Hidden style should be defined at first with Apply Style -> New Style -> Organiser -> Name = "Hidden", Numbers -> Format Code = "")
Comment 14 Heiko Tietze 2017-12-06 20:37:24 UTC
We discussed the topic in the design meeting. The visualization option in tools > options is independent from the printing option under page > sheet, which could be improved by taking what is configured globally for newly created documents. But we expect to run into other trouble with this approach and concluded to accept the current behavior.

Btw, meanwhile cell styles and conditional formatting has improved significantly. Hiding zeros by white font color could be a good workaround.
Comment 15 Eike Rathke 2017-12-07 12:54:51 UTC
Conditional formatting style with white font is overkill (i.e. quite heavy if used a lot) in most situations and doesn't help when changing the cell background. Consider using a number format to suppress displaying and printing of 0 values, for example

0.00;-0.00;;

Note the empty code in the third (=0) condition.