Bug 70007 - Line cut in header text with small font size
Summary: Line cut in header text with small font size
Status: RESOLVED DUPLICATE of bug 117988
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: DOCX-Header-Footer
  Show dependency treegraph
 
Reported: 2013-10-01 15:09 UTC by bugzilla
Modified: 2018-07-26 08:39 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
text block as it looks in MS Office 2007 (and 2010) (9.79 KB, image/png)
2013-10-01 15:09 UTC, bugzilla
Details
text block as it looks in LibreOffice 4.1.1.2 (12.80 KB, image/png)
2013-10-01 15:09 UTC, bugzilla
Details
the docx test file (90.38 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-10-01 15:10 UTC, bugzilla
Details
Libreoffice 4.4.0.0.alpha1 (50.03 KB, image/jpeg)
2014-11-03 17:36 UTC, Xisco Faulí
Details
Minimised test file (9.63 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-12-05 07:49 UTC, Matthew Francis
Details
Screen capture highlighting the issue (122.54 KB, video/quicktime)
2014-12-05 07:51 UTC, Matthew Francis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugzilla 2013-10-01 15:09:00 UTC
Created attachment 86912 [details]
text block as it looks in MS Office 2007 (and 2010)

We opened testdocument.docx (see attachment) in LibreOffice 4.1.1.2. In MS Office 2007, the right header column on the right side of the document looks fine (see screenshot line-complete), whereas in LibreOffice the lowermost line is cut (see screenshot line-cut). Maybe this happens because the tab (encircled in screenshot line-cut) does not consider the font size of the surrounding text, and so the line is pushed partly out of the cell.
Comment 1 bugzilla 2013-10-01 15:09:42 UTC
Created attachment 86913 [details]
text block as it looks in LibreOffice 4.1.1.2
Comment 2 bugzilla 2013-10-01 15:10:34 UTC
Created attachment 86914 [details]
the docx test file
Comment 3 tommy27 2013-10-03 09:33:38 UTC
issue confirmed in LibO 4.1.1.2 under Win7 64bit. set status to NEW
Comment 4 tommy27 2014-11-02 09:05:42 UTC
tested under Win7x64 
still reproducible with 4.4.0.0.alpha1+
Build ID: 1baad070d8c2a38581cf33d803c5043f1974647f
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-01_00:15:06

reproducible as well with older versions like 4.0.4.2
not reproducible with version 3.6.7.2

hence it's a 4.0.x regreession
Comment 5 Xisco Faulí 2014-11-03 17:36:22 UTC
Created attachment 108855 [details]
Libreoffice 4.4.0.0.alpha1

It looks like line "YYYY: YY55 5555 5555 5555 5555 55" isn't cropped in Master (Version: 4.4.0.0.alpha1+
Build ID: d9473f25380c627966b4406cc4cdfaafcf44bc37) any longer. However, the line below ( YYY YYY: 555555555 ) shouldn't be displayed.
Comment 6 Matthew Francis 2014-12-05 07:37:20 UTC
Results from bibisect-43all:
(searching for the point at which the trailing tab became extra tall)


56de98328b5e6e28aae1f5a8574c4d6500abdf82 is the first bad commit
commit 56de98328b5e6e28aae1f5a8574c4d6500abdf82
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Mon Dec 10 14:11:19 2012 +0000

    source-hash-5f91f8a368343d8921a01edb7359cd300892f09d
    
    commit 5f91f8a368343d8921a01edb7359cd300892f09d
    Author:     Michael Stahl <mstahl@redhat.com>
    AuthorDate: Thu Sep 20 23:59:14 2012 +0200
    Commit:     Michael Stahl <mstahl@redhat.com>
    CommitDate: Fri Sep 21 18:05:02 2012 +0200
    
        fdo#48692: fix problems with large number of table cells:
    
        The SwTableSortBoxes is now a STL container which can have more than
        2^16 elements but unfortunately there are a lot of 16 bit integers used
        to index it all over the place, causing infinite loops and possibly
        worse problems; fix that to use size_t.
    
        Change-Id: I868ec9dd0629be4fbe4d6b8f294fb765e3d662ec

# bad: [c2069a369d738078124812312d51f21ea1ce2421] source-hash-f160e4935c474a5293b3d3c11b3d538efb4767a0
# good: [a71a4447320f177181c9cff9f7c6fd93802cbd8e] source-hash-9afb6e1e38c362a768e8e981f7b03cf8bcaf22cf
git bisect start 'last41onmaster' 'last36onmaster'
# skip: [7fa43e1a1b181ccdcb395c16788a66c591b63045] source-hash-41c2b0375773b2d2945d75e255ea6bb6c7fd378d
git bisect skip 7fa43e1a1b181ccdcb395c16788a66c591b63045
# good: [9ce5b0d85edd56bb90464833eb52c0b274449c32] source-hash-c8218367a0f52206591a5048848fa5292405b6c3
git bisect good 9ce5b0d85edd56bb90464833eb52c0b274449c32
# bad: [b9da5d7ef8baf81aa867fc44cb6d8ebb6036201b] source-hash-ec376c2934e77fd1b56da892cfe2c1393f4c8156
git bisect bad b9da5d7ef8baf81aa867fc44cb6d8ebb6036201b
# bad: [1e4f8bf8304c7ecaaf68f2d16f09ef2f97d10af7] source-hash-fe347327a44f2d8ed201f9fbc2ae4858f34962d8
git bisect bad 1e4f8bf8304c7ecaaf68f2d16f09ef2f97d10af7
# bad: [56de98328b5e6e28aae1f5a8574c4d6500abdf82] source-hash-5f91f8a368343d8921a01edb7359cd300892f09d
git bisect bad 56de98328b5e6e28aae1f5a8574c4d6500abdf82
# good: [cf8644ffc4c66e8567e9c4be706caac879032caf] source-hash-3cf91a21fc5089fb7f051bf8a04d2049da88179f
git bisect good cf8644ffc4c66e8567e9c4be706caac879032caf
# good: [977cf448a89278afffc3dd6ece1dea3d0d695345] source-hash-cbc44df67cfd13849f3de85edcdd39b5fec8b06c
git bisect good 977cf448a89278afffc3dd6ece1dea3d0d695345
# good: [3cb6dff0fc360cec02d4cbc0931fcbb4ad991667] source-hash-c7692ae82b4c81c2ea8a9e3ee496ee525c0d44f4
git bisect good 3cb6dff0fc360cec02d4cbc0931fcbb4ad991667
# good: [cca0c04dccc1fb2827c929ff2ced5bdb80f915bc] source-hash-179a6db61ee30cf776747802f06edeef45fec461
git bisect good cca0c04dccc1fb2827c929ff2ced5bdb80f915bc
# first bad commit: [56de98328b5e6e28aae1f5a8574c4d6500abdf82] source-hash-5f91f8a368343d8921a01edb7359cd300892f09d
Comment 7 Matthew Francis 2014-12-05 07:49:34 UTC
Created attachment 110480 [details]
Minimised test file
Comment 8 Matthew Francis 2014-12-05 07:51:26 UTC
Created attachment 110481 [details]
Screen capture highlighting the issue

Screen capture taken with current 4.5 master
Comment 9 Matthew Francis 2015-01-09 15:11:26 UTC
The behaviour seems to have changed at the below commit.

Adding Cc: to cedric.bosdonnat.ooo@free.fr. Could you possibly take a look at this? Thanks


commit 355d25eac764713f4d52eac801ade6e2ff1deab0
Author: Cédric Bosdonnat <cedric.bosdonnat.ooo@free.fr>
Date:   Wed Sep 19 16:19:37 2012 +0200

    n#779627: added quite some compat options from the ww8 filter on writerfilter
    
    Change-Id: I9e8dee39f63a08517eb654e33747bd8c95d84b59
Comment 10 Xisco Faulí 2015-11-23 12:19:57 UTC
This issue is still present in 

Version: 5.1.0.0.alpha1+
Build ID: e6fade1ce133039d28369751b77ac8faff6e40cb
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-16_00:12:42
Locale: es-ES (es_ES)

on Window 7
Comment 11 Robinson Tryon (qubit) 2015-12-10 01:18:35 UTC Comment hidden (obsolete)
Comment 12 Aron Budea 2016-08-16 02:36:25 UTC
Still occurs in 5.2.0.4.
Comment 13 Xisco Faulí 2016-09-26 15:21:17 UTC
Adding Cc: to Michael Stahl
Comment 14 QA Administrators 2018-07-02 02:35:58 UTC Comment hidden (obsolete, spam)
Comment 15 Justin L 2018-07-25 18:29:55 UTC
Wonder why no one attempted to fix this before.  Super-easy - just look for the most likely setting and undo them one by one until you stumble across the right one. @Xisco - looking to your testing tool to ensure this is not a regression in case this is just an odd-ball document.

*** This bug has been marked as a duplicate of bug 117988 ***
Comment 16 Xisco Faulí 2018-07-26 08:39:48 UTC
(In reply to Justin L from comment #15)
> Wonder why no one attempted to fix this before.  Super-easy - just look for
> the most likely setting and undo them one by one until you stumble across
> the right one. @Xisco - looking to your testing tool to ensure this is not a
> regression in case this is just an odd-ball document.
> 
> *** This bug has been marked as a duplicate of bug 117988 ***

Hi Justin,
Don't worry about that. if any of your changes ( btw, thank you very much for your work ) is affecting any document in the testing tool, I will report it.