Download it now!
Bug 70044 - Other: CTRL + mouse hold does not copy object in Writer, but it does in Draw
Summary: Other: CTRL + mouse hold does not copy object in Writer, but it does in Draw
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.5.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Writer-UX Cut-Copy
  Show dependency treegraph
 
Reported: 2013-10-02 17:54 UTC by grofaty
Modified: 2018-07-09 05:27 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
ctrl_plus_move.png (5.15 KB, image/png)
2013-10-02 17:54 UTC, grofaty
Details

Note You need to log in before you can comment on or make changes to this bug.
Description grofaty 2013-10-02 17:54:24 UTC
Created attachment 86980 [details]
ctrl_plus_move.png

1. Open new document in Writer.
2. Click on "Show Draw Functions" button from toolbar.
3. At the bottom of screen drawing toolbar is displayed. Click on Rectangle icon.
4. Draw rectangle on canvas.
5. Press and hold CTRL key, click and hold on rectangle (notice mouse icon is changed to "plus" icon (see attachment). Move mouse to some other location on canvas and release keyboard and mouse left button.
Expected: Rectangle is copied to new location.
What happens: No object is copied.

Compare above steps (except step 2) to Draw:
Expected: Rectangle is copied to new location. After mouse release two rectangles exists on canvas.
What happens: Exactly what is written above in "Expected".

So CTRL+move works fine in Draw, but it does not work in Writer.

It is funny that mouse icon does change in Writer indicating coping is going to perform after mouse release, but no icon is displayed in Draw despite coping working fine.
              
Operating System: Windows XP
Version: 4.0.5.2 release
Comment 1 Ljiljan 2013-10-03 05:21:22 UTC
The same problem appears to me on Ubuntu 13.04,  Libre Office 4.0.5.2. LO was installed using official LO PPA. However, bug existed when LibreOffice was installed from default package from Ubuntu repository. 

Bug only applies to LibreOffice Writer and not to LibreOFfice Impress and LibreOffice Draw.
Comment 2 dg1727 2014-02-02 08:05:31 UTC
This bug seems to be a duplicate of bug 33692.
Comment 3 Joel Madero 2015-05-02 15:44:34 UTC Comment hidden (obsolete)
Comment 4 grofaty 2015-05-02 16:18:27 UTC
@Comment 2: It does look like the same problem. I am not 100% sure, because there is no step-by-step instruction like in my bug report.



@Comment 3: Bug still appears as explained in bug description in LibreOffice 4.4.2.2 on Ubuntu 14.04.

The only difference in 4.4.2.2 from "Description" is that now in Writer the icon does not changes to "+" in step 5 as attachments indicated ctrl_plus_move.png. Now the icon is consistent with Draw, but actions is not. It still works correctly in Draw.
Comment 5 QA Administrators 2016-09-20 09:38:20 UTC Comment hidden (obsolete)
Comment 6 grofaty 2016-11-23 12:53:05 UTC
Hi,
retested on master and problem is exactly the same as in Comment 4 (so "+" icon does not appear any more, but main problem still exists).

So CTRL+mouse should copy the object. In Draw it copies the object, but in Writer it does nothing (the bug).

Tested on master on Windows 7.

==============
MASTER VERSION
==============
Version: 5.3.0.0.alpha1+
Build ID: f965a629fba10ecba7bad938a0c1c9c3db1e510d
CPU Threads: 3; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-11-23_00:13:10
Locale: sl-SI (sl_SI); Calc: group
Comment 7 QA Administrators 2018-07-08 02:40:07 UTC Comment hidden (obsolete)
Comment 8 grofaty 2018-07-09 05:27:43 UTC
In tested version it works exactly the same in Writer and in Draw. In my humble opinion it is fixed.

=== Help | About ===
Version: 6.0.5.2 (x64)
Build ID: 54c8cbb85f300ac59db32fe8a675ff7683cd5a16
CPU threads: 3; OS: Windows 6.1; UI render: default; 
Locale: sl-SI (sl_SI); Calc: group