Bug Hunting Session
Bug 70284 - EDITING: "Assigned to" of Names change to "$#REF!"
Summary: EDITING: "Assigned to" of Names change to "$#REF!"
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.6.1 rc
Hardware: Other All
: highest normal
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.2.0
Keywords:
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2013-10-08 14:22 UTC by yachiyo621
Modified: 2014-02-07 14:56 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Before (7.93 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-10-09 14:49 UTC, yachiyo621
Details
After file (6.59 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-10-09 14:49 UTC, yachiyo621
Details
attachment-30985-0.html (3.71 KB, text/html)
2013-10-09 14:53 UTC, yachiyo621
Details
attachment-30985-1.dat (1 bytes, multipart/alternative)
2013-10-09 14:53 UTC, yachiyo621
Details
After.ods (6.59 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-10-09 14:53 UTC, yachiyo621
Details
Before.ods (7.93 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-10-09 14:53 UTC, yachiyo621
Details
a before file with Define window capture (57.03 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-10-12 03:45 UTC, yachiyo621
Details
a file with Sheet copy. (49.85 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-10-12 03:46 UTC, yachiyo621
Details

Note You need to log in before you can comment on or make changes to this bug.
Description yachiyo621 2013-10-08 14:22:59 UTC
Problem description: 

Steps to reproduce:
1. Delete a sheet or copy a sheet to a new location (except last sheet)
2. Menus > Insert > Names > Define
3. The sheet name of reference of the selected area name limited one sheet was change "$#REF!".
And the position of the sheets slips off.

Current behavior:

Expected behavior:

              
Operating System: Mac OS X
Version: 4.1.1.2 release
Comment 1 m.a.riosv 2013-10-08 21:07:51 UTC
Please attach a sample file, where to verify the issue.
Comment 2 yachiyo621 2013-10-09 14:49:28 UTC
Created attachment 87342 [details]
Before
Comment 3 yachiyo621 2013-10-09 14:49:56 UTC
Created attachment 87343 [details]
After file
Comment 4 yachiyo621 2013-10-09 14:51:01 UTC
Please check two files, Before.ods and After.ods
Comment 5 yachiyo621 2013-10-09 14:53:18 UTC
Created attachment 87344 [details]
attachment-30985-0.html

Please check two files,Before.ods and After.ods


----- Original Message -----
>From: "bugzilla-daemon@freedesktop.org" <bugzilla-daemon@freedesktop.org>
>To: yachiyo621@yahoo.co.jp 
>Date: 2013/10/9, Wed 06:07
>Subject: [Bug 70284] EDITING: "Assinged to" of Names change to "$#REF!"
> 
>
> mariosv  changed bug 70284 
>
>What
>Removed
>Added
>Status UNCONFIRMED  NEEDINFO  
>CC    mariosv@miguelangel.mobi  
>Ever confirmed    1  
>Comment # 1 on bug 70284 from mariosv  
>Please attach a sample file, where to verify the issue.
>________________________________
> You are receiving this mail because: 
>	* You reported the bug.
>
>
Comment 6 yachiyo621 2013-10-09 14:53:19 UTC
Created attachment 87345 [details]
attachment-30985-1.dat
Comment 7 yachiyo621 2013-10-09 14:53:19 UTC
Created attachment 87346 [details]
After.ods
Comment 8 yachiyo621 2013-10-09 14:53:19 UTC
Created attachment 87347 [details]
Before.ods
Comment 9 m.a.riosv 2013-10-09 20:53:12 UTC
Hi yachiyo621.

Reproducible.
Win7x64Ultimate.
Version 4.0.6.1 (Build ID: 7168152d13aa529ba3718c9ae3700216a574137)
Version: 4.1.3.0.0+ Build ID: 952c5fe20d5975c8a2c9f5093d05472ca0fc78f

And a second issue undo delete sheet, doesn't recover the name range address.

Added to MAB 4.0
Comment 10 yachiyo621 2013-10-12 03:45:52 UTC
Created attachment 87499 [details]
a before file with Define window capture

This is a before file with Define window capture
Comment 11 yachiyo621 2013-10-12 03:46:33 UTC
Created attachment 87500 [details]
a file with Sheet copy.

I upload a file with Sheet copy.
Comment 12 yachiyo621 2013-10-12 03:52:51 UTC
I upload a file with Sheet copy. and upload a before file with Define window capture.

When the number of the seats increased and decreased, 
I think that the address of the seat slips off by the seat which I add it and deleted.
When I deleted a seat of the end or added a seat to the end, this phenomenon does not occur.
Comment 13 tommy27 2013-12-31 12:07:19 UTC
fixed typo in summary notes
Comment 14 Björn Michaelsen 2014-01-17 09:58:26 UTC
(This is an automated message.)

Setting priority to highest as this is a 4.0 MAB. This is part of an effort to make the importance of MAB reflected in priority too.
Comment 15 Kohei Yoshida 2014-02-07 14:40:22 UTC
I just tested this against the latest from the 4.2 branch, and I can no longer reproduce it.  I guess I have accidentally fixed this while reworking the handling of formula references during the 4.2 development cycle.