Download it now!
Bug 70415 - FILEOPEN Space characters missing in PPTX file
Summary: FILEOPEN Space characters missing in PPTX file
Status: RESOLVED DUPLICATE of bug 73860
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: Other All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard: target:5.5.0
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-10-13 01:45 UTC by Urmas
Modified: 2017-06-02 07:03 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Adapted from the original (104.34 KB, application/vnd.ms-powerpoint)
2013-10-13 01:45 UTC, Urmas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Urmas 2013-10-13 01:45:17 UTC
Created attachment 87542 [details]
Adapted from the original

Open attached file and find that the slide is missing some spaces between words ("Cпомощьюснифферарассмотрите").
Comment 1 Maxim Monastirsky 2013-10-16 13:28:14 UTC
Confirmed using 4.2.0.0.alpha0+ Build ID: cc2a405915e82c4b332dd25457f76704dc536d7f TinderBox: Win-x86@39, Branch:master, Time: 2013-10-15_15:51:52. Opens fine with 4.1.2.

In fact I saw this bug more than a month ago, but forgot to report. So we have a second test case: It's attachment 76439 [details] from bug 62260. There is also a screenshot of master build from 2013-09-01: attachment 85007 [details].

BTW PowerPoint 2010 SP2 reports that the file is corrupted, but I don't think it's related to this bug.
Comment 2 Maxim Monastirsky 2013-12-18 16:24:04 UTC
Still an issue with libreoffice-4-2 build (Build ID: f9171206e80b1ff3e3917e2f448ff2b2a43a0b2e), but fixed in master build (Build ID: 4c539fac018dfd44cd8db52161a8cb930c627da7).
Comment 3 Maxim Monastirsky 2014-01-27 21:45:28 UTC

*** This bug has been marked as a duplicate of bug 73860 ***
Comment 4 Commit Notification 2017-06-02 07:03:53 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d95f50689f915b92211714495e866e2f47909f11

tdf#70415 PPTX import: fix assert fail in importEmbeddedGraphics()

It will be available in 5.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.