Bug 70438 - VIEWING: Selected cell’s border in “Special Character” window isn’t drawn correctly
Summary: VIEWING: Selected cell’s border in “Special Character” window isn’t drawn cor...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval, topicUI
Depends on:
Blocks: Special-Character
  Show dependency treegraph
 
Reported: 2013-10-13 23:29 UTC by Adolfo Jayme
Modified: 2018-07-18 16:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of graphical bug (30.34 KB, image/png)
2013-10-13 23:29 UTC, Adolfo Jayme
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adolfo Jayme 2013-10-13 23:29:28 UTC
Created attachment 87574 [details]
Screenshot of graphical bug

Problem description: When you select a certain character in the “Special Character” grid, and this character is positioned near the limit of the grid, a calculation error happens and the 3D border is not rawn according to the cell’s size. See attached screenshot.

Steps to reproduce:
1. In Writer, go to Insert > Special Character...
2. Make sure focus is not in the character grid.
3. The first cell will be highlighted in gray.

What happens: The 3D border is not correctly positioned around the whole cell

What should happen: This 3D effect is drawn according to the cell’s whole size, or is absent altogether.
Operating System: All
Version: Inherited From OOo
Comment 1 Dominique Boutry 2013-10-14 09:54:11 UTC
Reproductible.

Cells are of different width (the first - the middle ones - the last), idem for height. Not very professionnal.
Attachment : the second note ("There's no border outside the whole character table") may be thought as of less importance than the first (the different sizes lead messy cell highlight).

Note for cell highlight : a 3D effect only when the table is not selected ; a basic flat raw blue effect when the table is selected ; Surprising...
Comment 2 Jorendc 2013-10-20 08:46:44 UTC
(In reply to comment #1)
> Reproductible.

So lets mark it as such. In Mac OSX there is no 3D effect (only a blue background if selected).

Priority: minor low. Doesn't block any functionality, just for the eye :).

Kind regards,
Joren
Comment 3 Adolfo Jayme 2014-08-07 22:50:09 UTC
FTR, the missing border around the character table is fixed with 519f4b75a5f089b6ef98260ff6265f5000fe4659 since April.
Comment 4 Robinson Tryon (qubit) 2015-12-13 11:24:09 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2017-01-03 19:46:31 UTC Comment hidden (obsolete, spam)
Comment 6 V Stuart Foote 2018-07-18 16:39:19 UTC
Seems correct for some time, and commit ref looks germane.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=519f4b75a5f089b6ef98260ff6265f5000fe4659