Bug Hunting Session
Bug 70455 - FILEOPEN: .xlsx formula expressions with range operator and functions that return ranges are corrupted; INDEX, INDIRECT, ...
Summary: FILEOPEN: .xlsx formula expressions with range operator and functions that re...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: high major
Assignee: Eike Rathke
URL:
Whiteboard: BSA target:4.4.0 target:4.3.0.0.beta2...
Keywords:
: 73210 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-10-14 15:12 UTC by Rory Nolan
Modified: 2014-09-01 09:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
NEEDINFO (23.53 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-11-16 16:04 UTC, Rory Nolan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rory Nolan 2013-10-14 15:12:40 UTC
Problem description: When I open an xlsx file with libre calc in Ubuntu that when I saved it with excel in windows had the value =SUM(N2:INDIRECT(ADDRESS(ROW()-1,COLUMN()))),
in libre in Ubuntu it has the value
=SUM(N2:N2(ADDRESS(ROW()-1,COLUMN())))
triggering error 509.
This has happened on two separate files (not both in cell N2).
              
Operating System: Ubuntu
Version: 4.1.1.2 release
Comment 1 Joel Madero 2013-11-15 03:03:53 UTC
Please attach a document that shows this error.

Marking as NEEDINFO - once you attach the document mark as UNCONFIRMED and we will attempt to reproduce. Thanks!
Comment 2 Rory Nolan 2013-11-16 16:04:58 UTC
Created attachment 89321 [details]
NEEDINFO

Cell H8 here is the key one. It works in excel on Windows 7 but not in libre on ubuntu (giving err 509).
Comment 3 Joel Madero 2013-11-16 20:40:35 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version Pre-Bibisect (at least 3.5.0 beta0
Platform: Ubuntu 13.04 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm this problem on an earlier release I am changing the version number as version is the earliest version that we can confirm the bug, we use comments to say that the bug exists in newer versions as well.

Marking as:

New (confirmed)
Major - loss of data
High


Note: It's weird because if you change the formula manually in LibreOffice then it works fine - so it's actually reading the entry in some very strange way.

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 4 Eike Rathke 2014-05-27 00:31:21 UTC
*** Bug 73210 has been marked as a duplicate of this bug. ***
Comment 5 Eike Rathke 2014-05-27 00:42:32 UTC
I'm taking this.
Comment 6 Commit Notification 2014-05-27 21:23:54 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ac8532ce26e79453b3a969b956ebb7823c455131

resolved fdo#70455 B1:SOMENAME is not a valid singleton reference



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2014-05-27 21:28:34 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2217cb71b762ffbc32ac6c4e5d613fd32f4fa05c&h=libreoffice-4-3

resolved fdo#70455 B1:SOMENAME is not a valid singleton reference


It will be available in LibreOffice 4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Eike Rathke 2014-05-27 21:40:09 UTC
Pending review
for 4-2 at https://gerrit.libreoffice.org/9515
for 4-2-5 at https://gerrit.libreoffice.org/9516
Comment 9 Commit Notification 2014-05-31 17:53:01 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=37d985d098cc44798ccaeba78bf6795409a5b5c1&h=libreoffice-4-2

resolved fdo#70455 B1:SOMENAME is not a valid singleton reference


It will be available in LibreOffice 4.2.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2014-06-12 08:23:32 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-2-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0a2ce4a24fadd2fa6358a83e7f6107c2f95a7260&h=libreoffice-4-2-5

resolved fdo#70455 B1:SOMENAME is not a valid singleton reference


It will be available already in LibreOffice 4.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 S S SEHAR 2014-09-01 06:00:58 UTC
Please solve the issue instantly i need it.
Comment 12 ign_christian 2014-09-01 09:21:38 UTC
(In reply to comment #11)
> Please solve the issue instantly i need it.
It's fixed since LO 4.2.5 & 4.3.0 (see the whiteboard)

Confirm fixed by LO 4.2.6.3 and 4.3.1.2 under Ubuntu 12.04 x86