Download it now!
Bug 70568 - UI: java add-on function inaccessible from Shortcuts Dialog
Summary: UI: java add-on function inaccessible from Shortcuts Dialog
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Customize-Dialog-Keyboard
  Show dependency treegraph
 
Reported: 2013-10-17 08:47 UTC by Yury
Modified: 2019-04-22 18:21 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yury 2013-10-17 08:47:06 UTC
Functions (well, class methods, actually) contained in Java add-ons (like DocLitManager, for example) can't be selected from Shortcuts Dialog (accessed by Tools->Customize->Keyboard tab).

These are, to all purposes, java macros, but there are no entries for these in the 'Libreoffice Macros' section of Category list. Also, there is no provision for making the custom entry for the shortcut action.

And so, operator is reduced to 1) modifying shortcut with something else (like HelloPython) and then 2) quitting LO and 3) text-editing registrymodifications.xcu in the ~/.config/libreoffice subdir (on Linux), where it is necessary to 
4) search the file for the string 
vnd.sun.star.script:hello1.py$HelloPython?language=Python&location=user
(this is what <value> XML tag contains)
and 
5) replace it with (in my case) org.openoffice.doclitmanager.doclitmanager:DocLitManager
6) save and restart, of course.

That's what I had to resort to set up a keyboard shortcut for the DocLitManager's dialog. Not for the average user, is it?
Comment 1 tommy27 2014-10-18 11:43:20 UTC
please do not set your own bugs status to NEW.
this has to be done only after an independent confirmation by another user.

please retest with current LibO 4.3.2.2 release than change status to UNCONFIRMED if the bug is still present or RESOLVED WORKSFORME if the bug is gone.
Comment 2 Yury 2014-11-04 09:41:41 UTC
(In reply to tommy27 from comment #1)
> please do not set your own bugs status to NEW.

This was accidental, the status is initialised and I forgot to change.

The issue is, of course, still there (to be expected, really, considering java isn't regarded as a part of distribution).

Re-checked with the same DocLitManager on 4.3.3.2 (linux x86_64). The extensions works, and can't be set up with keyboard shortcut by the usual means.
Comment 3 Buovjaga 2014-11-27 12:40:28 UTC
Should be UNCONFIRMED.
Comment 4 Robinson Tryon (qubit) 2014-12-22 03:23:21 UTC
For the UX Team.
Comment 5 Robinson Tryon (qubit) 2016-08-24 23:14:23 UTC Comment hidden (obsolete)
Comment 6 Heiko Tietze 2017-08-02 13:10:16 UTC
Don't think this is a UX question. Java shouldn't be different from Basic macros.