Download it now!
Bug 70751 - EPS image does not display in slideshow
Summary: EPS image does not display in slideshow
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-22 08:05 UTC by Frederic Parrenin
Modified: 2014-07-02 18:59 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
.odp file to reproduce the problem (33.13 KB, application/vnd.oasis.opendocument.presentation)
2013-10-22 08:05 UTC, Frederic Parrenin
Details
another .odp file which shows the problem (312.60 KB, application/vnd.oasis.opendocument.presentation)
2013-10-22 08:09 UTC, Frederic Parrenin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederic Parrenin 2013-10-22 08:05:12 UTC
Created attachment 87970 [details]
.odp file to reproduce the problem

The image present in this slide does not appear in slideshow
Comment 1 Frederic Parrenin 2013-10-22 08:09:37 UTC
Created attachment 87971 [details]
another .odp file which shows the problem
Comment 2 sophie 2013-10-22 08:31:42 UTC
Hi Frederic, your files contains graphics which are in metafile format, it's indicated in the status bar when you select the graphic. As a workaround, if you right click on it and select convert to bitmap, the graphic is shown in the slideshow. May be you can give us an indication on how you produced the graphics?
I confirm the issue with metafiles that are not shown in slideshows. Set as New - Sophie
Comment 3 Frederic Parrenin 2013-10-22 12:35:10 UTC
Thanks for the workaround.
Unfortunately I don't remember how I created those graphics.
Comment 4 Frederic Parrenin 2013-10-23 13:59:09 UTC
Actually, the conversion to bitmap fails on my version (ubuntu 13.04).
Comment 5 Frederic Parrenin 2013-10-23 15:13:47 UTC
These images have probably been created by inserting a .eps image.
Comment 6 sophie 2013-10-23 15:28:14 UTC
Frederic, you're right, the conversion fails with the 4.1.3 version on Ubuntu. Yesterday, I tested it with the future 4.2 version which will be available next year and it works there. Sorry about that. If I can help with the conversion of this specific file, just send it at my address directly, I'll convert it for you. Sophie
Comment 7 Björn Michaelsen 2013-10-24 01:00:34 UTC
This looks like a dupe of fdo#34836, see also:

http://ask.libreoffice.org/en/question/20188/how-to-export-pdf-with-eps-image-in-writer/

Could you please recheck, if you have the needed software installed?
Comment 8 Owen Genat (retired) 2013-11-17 10:45:36 UTC
(comment #2)
> May be you can give us an indication on how you produced the graphics?

(comment #3)
> Unfortunately I don't remember how I created those graphics.

$ unzip -l test.odp | grep Pictures
    65323  2013-10-22 08:01   Pictures/2000000200000137000001D80288184D.eps
$ unzip -e test.odp Pictures/2000000200000137000001D80288184D.eps
Archive:  test.odp
  inflating: Pictures/2000000200000137000001D80288184D.eps
$ file -b 2000000200000137000001D80288184D.eps 
PostScript document text conforming DSC level 3.0, type EPS, Level 2
$ grep -e Creator 2000000200000137000001D80288184D.eps 
%%Creator: LibreOffice 3.6

...as above for test2.odp:

$ grep -e Creator 20000002000002110000016D9D8318CC.eps 
%%Creator: Sun Microsystems, Inc.

The second one probably indicates OOo. Not a solution, but perhaps some useful information.
Comment 9 QA Administrators 2014-06-01 21:29:44 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 10 Frederic Parrenin 2014-06-02 13:15:54 UTC
I have checked that I have pstoedit installed on my computer.
This bug is still present on debian 7 with LO 4.2.4.
I think it is not matter to know how the eps file has been created, if it appears in the editor, it should appear in slide show too.
Comment 11 Jorendc 2014-06-14 19:52:40 UTC
I can't reproduce this anymore, tested using Mac OSX 10.9 with LibreOffice Version: 4.3.0.0.beta2
Build ID: a06aa316117a6ff0f05c697c82831c227812d810

@Frederic: can you please test again using LibreOffice 4.3 http://www.libreoffice.org/download/libreoffice-fresh/?version=4.3.0

Kind regards,
Joren
Comment 12 Jorendc 2014-06-14 20:13:08 UTC
Sorry my bad, still reproducible. Didn't start the slideshow (only in edit-mode). In edit mode it is visible. Ignore my comment.
Comment 13 Yousuf Philips (jay) (retired) 2014-06-14 20:34:51 UTC
Tested on Linux Mint and this is a regression in 4.0.6, 4.1.6, and 4.2.4. It works fine in 3.3.0, 3.6.7, 4.2.5, 4.2.6 and 4.3 beta 2 in the slideshow.
Comment 14 Owen Genat (retired) 2014-07-02 07:34:14 UTC
(In reply to comment #13)
> Tested on Linux Mint and this is a regression in 4.0.6, 4.1.6, and 4.2.4. It
> works fine in 3.3.0, 3.6.7, 4.2.5, 4.2.6 and 4.3 beta 2 in the slideshow.

I can confirm this behaviour for Debian 7 x86_64 running v4.1.6.2 (no display in slide show mode) and Crunchbang 11 x86_64 running v4.2.5.2 (does display in slide show mode). Summary amended for clarity.
Comment 15 Yousuf Philips (jay) (retired) 2014-07-02 18:59:54 UTC
As its a confirmed fix in 4.2.5, i'm closing it.