Download it now!
Bug 70871 - FORMATTING: Duplicates in numbered lists created in Word
Summary: FORMATTING: Duplicates in numbered lists created in Word
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Linux (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-25 18:22 UTC by proshka
Modified: 2015-11-06 14:55 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample of duplicated numbered list (12.38 KB, application/vnd.oasis.opendocument.text)
2013-10-25 18:22 UTC, proshka
Details
attachment-1439-0.html (3.43 KB, text/html)
2013-10-25 23:13 UTC, proshka
Details
attachment-1439-1.dat (1 bytes, multipart/alternative)
2013-10-25 23:13 UTC, proshka
Details
Sample.docx (24.74 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-10-25 23:13 UTC, proshka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description proshka 2013-10-25 18:22:44 UTC
Created attachment 88121 [details]
Sample of duplicated numbered list

Letters and numbers in numbered lists created in Word documents appear duplicated and in a different font size when opened in LO. The attached sample corresponds to a .docx document. 

I'm using Kubuntu 13.04.

              
Operating System: Linux (Other)
Version: 4.1.0.4 release
Comment 1 Julien Nabet 2013-10-25 22:55:14 UTC
proshka: could you provide the original WinWord file so we can try to reproduce the problem?
Comment 2 proshka 2013-10-25 23:13:40 UTC
Created attachment 88131 [details]
attachment-1439-0.html

Sure. I am sending you the original Word document I received. Just in case please make sure to keep the student's name confidential. 





El Viernes, 25 de octubre, 2013 3:55 P.M., "bugzilla-daemon@freedesktop.org" <bugzilla-daemon@freedesktop.org> escribió:
 
 
Julien Nabet  changed bug 70871 

What
Removed
Added
Status UNCONFIRMED  NEEDINFO  
CC    serval2412@yahoo.fr  
Ever confirmed    1  
Comment # 1 on bug 70871 from Julien Nabet  
proshka: could you provide the original WinWord file so we can try to reproduce
the problem?
________________________________
 You are receiving this mail because: 
	* You reported the bug.
Comment 3 proshka 2013-10-25 23:13:41 UTC
Created attachment 88132 [details]
attachment-1439-1.dat
Comment 4 proshka 2013-10-25 23:13:41 UTC
Created attachment 88133 [details]
Sample.docx
Comment 5 Julien Nabet 2013-10-25 23:22:36 UTC
proshka: please don't answer directly from your email but from bugzilla.
Either with :
https://bugs.freedesktop.org/show_bug.cgi?id=70871# (to just add a comment)
or with:
https://bugs.freedesktop.org/attachment.cgi?bugid=70871&action=enter
to attach a file + a comment

You must know that attachment are public only so you must remove confidential parts before to attach it. If you really need to remove it, you can follow advice given there:
https://bugs.freedesktop.org/show_bug.cgi?id=51597#c7
Comment 6 Julien Nabet 2013-10-25 23:24:03 UTC
Anyway, on pc Debian x86-64 with master sources updated today, I reproduced the pb.
I noticed these logs:
warn:legacy.osl:15795:1:oox/source/docprop/docprophandler.cxx:323: For now unexpected tags are ignored!
warn:legacy.osl:15795:1:writerfilter/source/dmapper/CellMarginHandler.cxx:64: cell margins work for absolute values, only
warn:sw.uno:15795:1:sw/source/core/unocore/unotext.cxx:2303: Exception when setting property: LeftBorder. Message: 
warn:sw.uno:15795:1:sw/source/core/unocore/unotext.cxx:2303: Exception when setting property: RightBorder. Message: 
warn:sw.uno:15795:1:sw/source/core/unocore/unotext.cxx:2303: Exception when setting property: TopBorder. Message: 
warn:legacy.osl:15795:1:oox/source/helper/storagebase.cxx:71: StorageBase::StorageBase - missing base input stream

Miklos: one for you?
Comment 7 proshka 2013-10-26 06:35:12 UTC
Ok, thanks for the information. I found the email in my inbox so I just replied to it. My apologies.

As to the second part of the message, my apologies again but I sent the original message as instructed:
 
What
Removed
Added
Status UNCONFIRMED  NEEDINFO  
CC    serval2412@yahoo.fr  
Ever confirmed    1  
Comment # 1 on bug 70871 from...  
proshka: could you provide the original WinWord file so we can try to reproduce
the problem?
So I did. Now, could you please kindly remove/delete the attachment? 


Thanks,

Omar



El Viernes, 25 de octubre, 2013 4:22 P.M., "bugzilla-daemon@freedesktop.org" <bugzilla-daemon@freedesktop.org> escribió:
 
 
Comment # 5 on bug 70871 from Julien Nabet  
proshka: please don't answer directly from your email but from bugzilla.
Either with : https://bugs.freedesktop.org/show_bug.cgi?id=70871# (to just add a comment)
or with: https://bugs.freedesktop.org/attachment.cgi?bugid=70871&action=enter to attach a file + a comment You must know that attachment are public only so you must remove confidential
parts before to attach it. If you really need to remove it, you can follow
advice given there: https://bugs.freedesktop.org/show_bug.cgi?id=51597#c7
________________________________
 You are receiving this mail because: 
	* You reported the bug.
Comment 8 proshka 2013-12-29 01:05:03 UTC
The issue I reported above for LO 4.1.0.4 is also in LO 4.1.4.2.
Comment 9 Björn Michaelsen 2014-01-17 09:51:44 UTC
(This is an automated message.)

Setting priority to highest as this is a 4.1 MAB. This is part of an effort to make the importance of MAB reflected in priority too.
Comment 10 tommy27 2014-05-02 13:59:46 UTC
@proshka
is the bug still reproducible with LibO 4.2.3.3

would you please also post a comparative screenshot of the original document opened in Word and LibO highlighting the bug in LibO?
Comment 11 Timur 2014-05-19 12:53:10 UTC
@Julien:
How did you reproduce the issue? Sample.docx opens wrongly also in MS Office 2010 and in Kingsoft Writer.
I'll remove this from MAB 4.1. Personally, this doesn't look like MAB but if confirmed it can be added to MAB 4.2.
Comment 12 Julien Nabet 2014-05-19 17:54:19 UTC
Timur: I don't have MSOffice, I just opened "Sample.docx" and saw there were dups.
Do you confirm there are also dups in MSOffice?
Comment 13 Björn Michaelsen 2014-07-12 20:18:11 UTC
Priority highest is reserved for MABs, please see: https://wiki.documentfoundation.org/MAB on when a bug qualifies for that.

Thus keeping this on priority high.
Comment 14 QA Administrators 2015-07-18 17:43:51 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-07-18
Comment 15 Buovjaga 2015-11-06 14:55:49 UTC
There are also duplicate numbers with MSO 2013. Closing as NOTABUG.

Win 8.1 32-bit
LibO Version: 5.1.0.0.alpha1+
Build ID: db6a928a420868b2a80ba11c8d46151d16c13624-GL
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-05_22:13:24
Locale: fi-FI (fi_FI)