Bug 70998 - Termchange: Graphic/Picture -> Image
Summary: Termchange: Graphic/Picture -> Image
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Tamsil Amani
URL:
Whiteboard: target:5.2.0 target:5.3.0 target:5.4.0
Keywords: difficultyBeginner, easyHack, topicCleanup
: 84401 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-10-29 13:39 UTC by Samuel Mehrbrodt (CIB)
Modified: 2018-03-12 08:37 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
Diff of Changes from Picture/Graphic to Image (542 bytes, patch)
2014-06-14 23:25 UTC, gat
Details
Diff of Changes from Picture/Graphic to Image (819 bytes, patch)
2014-06-14 23:26 UTC, gat
Details
Diff of Changes from Picture/Graphic to Image (686 bytes, patch)
2014-06-14 23:27 UTC, gat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Mehrbrodt (CIB) 2013-10-29 13:39:59 UTC
Currently, Images in LibreOffice are sometimes referred to as "Graphic", sometimes as "Picture".
"Image" is a more generic word which implies both other words.

So the task is to rename the user-visible Strings from "Graphic" and "Picture" to "Image".
This includes updating the help.

Any objections from UX-Advise?
Comment 1 Samuel Mehrbrodt (CIB) 2013-10-29 13:56:30 UTC
Adding UX-Advise to CC.
Comment 2 Commit Notification 2013-10-29 14:51:52 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fdf00229816f5d0f59f90b0266115d293060e2cc

fdo#70998 Term Change: Picture/Graphic -> Image



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Samuel Mehrbrodt (CIB) 2013-10-30 08:41:13 UTC
There are still places where this needs to be changed.

Opening this for others, just search http://opengrok.libreoffice.org/ for terms like "Picture", "Graphic", "Graphics" and change all user-visible Strings to "Image".
The help also needs updating (Select Project "help" in OpenGrok).
Comment 4 Sveinn í Felli 2013-10-30 09:25:55 UTC
(In reply to comment #0)
 
> Any objections from UX-Advise?

Just to mention; as a translator I have circumvented the issue, using mostly the same local expression for the two. 
OTOH concerning plural forms, to me "Graphics" would signify a broader range of images, symbols, clipart, etc. But I'm not native english speaker.
Comment 5 Commit Notification 2013-11-01 09:16:25 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=90ef8ac1b5d94c24ff0d5a26a8ca6b6769f225c1

fdo#70998 Termchange: Graphics->Image



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Stanislav Horacek 2013-11-01 10:29:16 UTC
I can't judge if this change is useful (and it would be nice if a native speaker could comment it), but I'm wondering why you use "Image" always capitalized, even in sentences like "Unknown Image format". Is there any reason for that?

Btw, if you have finished this, I can change the terms in help.
Comment 7 Samuel Mehrbrodt (CIB) 2013-11-01 11:13:19 UTC
(In reply to comment #6)
> I can't judge if this change is useful (and it would be nice if a native
> speaker could comment it), but I'm wondering why you use "Image" always
> capitalized, even in sentences like "Unknown Image format". Is there any
> reason for that?

It's Sentence Case (see https://wiki.documentfoundation.org/Development/WidgetLayout#Widgets_requiring_HIG_guidelines_review)

> Btw, if you have finished this, I can change the terms in help.

Thank's, I'll let you know.
Comment 8 Stanislav Horacek 2013-11-01 16:21:49 UTC
I'm confused now. In case of sentence capitalizing, there should be lowercase "i" if it is not the first word (https://developer.gnome.org/hig-book/3.2/design-text-labels.html.en#layout-capitalization) - or not?
Comment 9 Samuel Mehrbrodt (CIB) 2013-11-02 13:12:22 UTC
You are right, I meant Header Case. Thanks for the Link btw, I'll give more attention to that with the coming patches.
Comment 10 Christina Rossmanith 2013-11-02 18:27:20 UTC
Using Insert->Image->From File shows a dialog with title "Insert picture". I guess that should be "image" as well.

Version: 4.2.0.0.alpha0+
Build ID: 2c92030ff07aff9b10e49844343390925b81545c
Comment 11 Commit Notification 2013-11-04 14:08:21 UTC
Chr. Rossmanith committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c5abb32126d9b1e8c01fb2ea37e4244695428495

fdo#70998 Use "Insert Image" in dialog as well



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Adolfo Jayme 2013-11-05 20:26:24 UTC
Yeah, please take care of using the correct capitalization before LibreOffice 4.2 enters Pootle - otherwise many strings will have to be retranslated.
Comment 13 Christina Rossmanith 2013-11-09 16:48:11 UTC
What would be correct capitalization? I had a look at "Insert -> Movie and Sound" and thought image could be written with a capital "I" as well "Insert Image". Not only the menu entry of "Movie and Sound" is capitalized but the dialog title as well.
Comment 14 Stanislav Horacek 2014-05-03 17:00:16 UTC
When preparing help update I noticed that this term change has not been completed and the current state is much worse than the original one.
Now we have for instance the Picture dialog with Picture tab chosen by Format - Image. There is also a lot of incorrectly used singulars instead of plurals (see e.g. "Image" in Navigator). Incorrect capitalization was mentioned above and is only minor issue.

Unchanged items (random and not complete list):
context menu on an image: Change Picture, Save Graphics, Compress Graphics, Picture, Crop Picture
Picture dialog with Picture tab
Picture toolbar with Graphic Filter bar
Graphics option in dialog for creating index
Set Background Picture for Slide
Tools - Options - LO Writer - View: Graphics and objects
Tools - Options - LO Writer - Print: Pictures and objects
Comment 15 Stanislav Horacek 2014-05-03 17:00:49 UTC
Btw. link to help update:
https://gerrit.libreoffice.org/#/c/9244/
Comment 16 Commit Notification 2014-05-06 15:10:16 UTC
Stanislav Horacek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=a8572d0a8c380e9a04001e3ec638c13519d79d83

fdo#70998 change terms graphics/picture to image



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 18 gat 2014-06-14 23:26:33 UTC
Created attachment 101070 [details]
Diff of Changes from Picture/Graphic to Image

http://opengrok.libreoffice.org/xref/core/svx/inc/globlmn_tmpl.hrc
Comment 19 gat 2014-06-14 23:27:40 UTC
Created attachment 101071 [details]
Diff of Changes from Picture/Graphic to Image

http://opengrok.libreoffice.org/xref/core/sd/source/ui/app/menuids_tmpl.src
Comment 20 gat 2014-06-14 23:29:33 UTC
Found on Debian Jessie's Version: 4.2.4.2
I realize that some may not apply since Debian packages slightly older versions, usually.
Writer -> View -> Toolbars -> Picture

Writer -> Tools -> Options -> Libreoffice -> Memory -> Graphics cache
Writer -> Tools -> Options -> Libreoffice Writer -> View -> Graphics and objects
Writer -> Tools -> Options -> Libreoffice Writer -> Print -> Pictures and objects
Writer -> Tools -> Options -> Libreoffice Writer/Web -> View -> Graphics and objects
Writer -> Tools -> Options -> Libreoffice Writer/Web -> Print -> Pictures and objects
Writer -> Tools -> Customize -> Keyboard -> Functions -> Category -> Graphic
Writer -> Tools -> Customize -> Keyboard -> Functions -> Category -> Format || Function -> Graphics mode

(Right Click on Image in Writer) -> Picture...
(Right Click on Image in Writer) -> Save Graphic...
(Right Click on Image in Writer) -> Compress Graphic...

(Right Click on Image in Writer) -> Picture... -> Picture

Writer -> Side Bar -> Properties -> Graphic
Writer -> Side Bar -> Styles and Formatting -> Graphics

Writer -> Toolbar -> Apply Style -> Graphics ***Should be the same as the one above???
Writer -> Toolbar -> Apply Style -> Paragraphs Styles -> Default Styles -> Caption -> Illustration ???I'm not sure about this one.

Toolbars -> Graphic filter
Toolbars -> Picture
Comment 21 Commit Notification 2014-06-30 09:06:44 UTC
Stanislav Horacek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7fa690d1df4f79f129af28319381e1fd83e1b178

related fdo#70998 change names in Navigator to plural



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2014-09-28 21:11:38 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1a57c512c051cb8b1809f00e569a402ff6be5878

fdo#70998 Termchange: Picture->Image



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 23 A (Andy) 2014-09-28 21:59:58 UTC
*** Bug 84401 has been marked as a duplicate of this bug. ***
Comment 24 Yousuf Philips (jay) (retired) 2014-09-29 00:06:23 UTC
After skimming through < http://cgit.freedesktop.org/libreoffice/core/commit/?id=fdf00229816f5d0f59f90b0266115d293060e2cc > and < http://cgit.freedesktop.org/libreoffice/core/commit/?id=90ef8ac1b5d94c24ff0d5a26a8ca6b6769f225c1 > and noticed that you had capitalized instances of the word 'image' that shouldnt be capitalized, like for example - "Contains specialized data for internal Image filter.", "Contains information about a linked file, i.e. an Image file.", "Some OLE objects could only be saved as Images.". So it might be good to make sure all the replacements are suitable when in sentences.

Just my two cents. I think the word graphic is suitable when referring to both images, object shapes, etc, while picture or image are both suitable for an image from a file. Some people would call a picture something they take with their phone or draw on a paint canvas, while other would use the word image for those same to things.

= The Competition =

MS Word - Picture
WPS Writer - Picture
iWork Page - Photos
WordPerfect - Graphic/Picture
Abiword - Picture
Calligra Words - Image
Comment 25 Commit Notification 2014-09-29 10:27:32 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=145eda05e5a35f17118726e74b511cdd1f36a53a

fdo#70998 Fix capitalization



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 26 Commit Notification 2014-09-29 10:33:52 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d9632a6effabe8554c4e7e05ee24c16acd0f4f95

fdo#70998 Fix capitalization



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 27 Stanislav Horacek 2014-10-28 21:36:59 UTC
Updated list of remaining occurences of "Graphics" or "Pictures" from the comment above (in current master) - I don't know if all of them should be renamed:

Writer -> Tools -> Options -> Libreoffice -> Memory -> Graphics cache
Writer -> Tools -> Options -> Libreoffice Writer -> View -> Graphics and objects
Writer -> Tools -> Options -> Libreoffice Writer -> Print -> Pictures and objects
Writer -> Tools -> Options -> Libreoffice Writer/Web -> View -> Graphics and objects
Writer -> Tools -> Options -> Libreoffice Writer/Web -> Print -> Pictures and objects
Writer -> Tools -> Customize -> Keyboard -> Functions -> Category -> Graphic
Writer -> Tools -> Customize -> Keyboard -> Functions -> Category -> Format || Function -> Graphics mode

Writer -> Side Bar -> Properties -> Graphic
Writer -> Side Bar -> Styles and Formatting -> Graphics

Writer -> Toolbar -> Apply Style -> Graphics ***Should be the same as the one above???
Writer -> Toolbar -> Apply Style -> Paragraphs Styles -> Default Styles -> Caption -> Illustration ???I'm not sure about this one.

Toolbars -> Graphic filter
Comment 28 Yousuf Philips (jay) (retired) 2014-11-05 12:37:57 UTC
Some of the ones listed were already changed, so here are the ones i think can be changed.

(In reply to gat from comment #20)
> Writer -> Tools -> Options -> Libreoffice -> Memory -> Graphics cache
> Writer -> Side Bar -> Styles and Formatting -> Graphics

Should be changed if these are limited to just images.

> Writer -> Tools -> Options -> Libreoffice Writer -> View -> Graphics and
> objects
> Writer -> Tools -> Options -> Libreoffice Writer/Web -> View -> Graphics and
> objects

Disabling these hide images from view, so this should be changed

> Writer -> Tools -> Options -> Libreoffice Writer -> Print -> Pictures and
> objects
> Writer -> Tools -> Options -> Libreoffice Writer/Web -> Print -> Pictures
> and objects

Disabling this these images from print, so this should be changed.

> Toolbars -> Graphic filter

Where is this one locationed?
Comment 29 Stanislav Horacek 2014-11-05 13:15:13 UTC
> > Toolbars -> Graphic filter
> 
> Where is this one locationed?

It appears when you click the "Filter" icon on the Image bar and undock the toolbar which pops up.
Comment 30 Yousuf Philips (jay) (retired) 2014-11-16 20:11:32 UTC
(In reply to Stanislav Horacek from comment #29)
> It appears when you click the "Filter" icon on the Image bar and undock the
> toolbar which pops up.

Yep that should be changed and likely to 'Image Filters'.

I also noticed that 'Graphic' is a section name in the sidebar and this should be changed. The frame style 'Graphics' could be changed to 'Images' if this wont effect already created documents.
Comment 31 Commit Notification 2015-10-12 10:11:14 UTC
iremsendur committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=afabdef0e78b419da6788b644f47a06ba9ec0283

tdf#70998 - Termchange: Graphic/Picture -> Image

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 32 Robinson Tryon (qubit) 2015-12-14 07:03:20 UTC Comment hidden (obsolete)
Comment 33 Commit Notification 2016-02-02 12:42:13 UTC
akki95 committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a78f074a0b0be4577ffd9bbf4fe00cc7f06ee9bb

tdf#70998 Termchange: Graphic/Picture->Image

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 34 Yousuf Philips (jay) (retired) 2016-02-02 13:25:25 UTC
@Samuel: It would be good to double check whether 'Graphics Cache' used in the options dialog memory page means only images, as it may also include charts, etc.
Comment 35 Samuel Mehrbrodt (CIB) 2016-02-02 13:35:39 UTC
(In reply to Yousuf (Jay) Philips from comment #34)
> @Samuel: It would be good to double check whether 'Graphics Cache' used in
> the options dialog memory page means only images, as it may also include
> charts, etc.

Tomaz, can you comment on this?
Comment 36 Robinson Tryon (qubit) 2016-02-18 14:52:19 UTC Comment hidden (obsolete)
Comment 37 gat 2016-03-04 02:47:48 UTC
I realize that some of these may not apply since they have been changed, but Fedora doesn't have the latest version and at least one patch hasn't landed outside of master from reading the comments. Also, some may not want to be changed. I am pretty sure that some will want to be changed, though.

View → Toolbars → Image → Hover the mouse over the second item which is a drop-down menu → Graphics mode
http://opengrok.libreoffice.org/xref/core/sw/source/uibase/utlui/attrdesc.src
line 308


File → Print... Ctrl+P → LibreOffice Writer → Pictures and other graphic objects
http://opengrok.libreoffice.org/xref/core/sw/uiconfig/swriter/ui/printeroptions.ui
line 46


File → Printer settings… → Options… → Pictures and objects


Tools -> Customize... -> Keyboard -> Functions -> Category -> Graphic


Tools -> Customize... -> Keyboard -> Functions -> Category -> Format -> Graphics mode


Tools -> Customize... -> Toolbars -> Toolbar -> Graphic Filter


Tools → Options… → LibreOffice →  Accessibility → Allow animated graphics


Tools → Options… → Load/Save → HTML Compatibility → Copy local graphics to Internet


Tools → Options… → LibreOffice Writer → View → Graphics and objects


Tools → Options… → LibreOffice Writer → Print →  Pictures and objects


Tools → Options… → LibreOffice Writer/Web → View → Graphics and objects


Tools → Options… → LibreOffice Writer/Web → Print →  Pictures and objects

This is with Build ID 5.0.5.2-2.fc23 in LibreOffice Writer. Clearly, I became lazy about tracking the code.
Comment 38 gat 2016-03-04 03:35:27 UTC
I was able to confirm the presence of all of those from my last comment in OS X El Capitan with LibreOffice 5.1.0.3 except File → Printer settings… → Options… → Pictures and objects.

Of course LibreOffice -> Preferences -> would be used in the stead of Tools -> Options... ->. I'm sure that some of these will stay with graphic.
Comment 39 Commit Notification 2016-04-14 15:00:00 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=54bb5a76aea1eea378d24c7bca5a901b0aa932da

tdf#70998 Termchange Graphic/Bitmap -> Image

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 40 jani 2016-05-04 05:47:07 UTC
seems solved, if not it would be nice to describe what is missing.
Comment 41 Stanislav Horacek 2016-05-04 19:51:01 UTC
Not solved entirely; at least sidebar content panel title as described in comment #27 is still "Graphic" or "Grahpic Filter" has not been changed.
Comment 42 jani 2016-05-05 05:44:52 UTC
Seems solved
Comment 43 Stanislav Horacek 2016-05-05 18:59:59 UTC
Again: not solved yet. The explicit list of remaining occurrences (based on the lists above):

Writer -> Tools -> Customize -> Keyboard -> Functions -> Category -> Graphic
Writer -> Side Bar -> Properties -> Graphic
Writer -> Side Bar -> Styles and Formatting -> Graphics
File → Print... Ctrl+P → LibreOffice Writer → Pictures and other graphic objects
Tools -> Customize... -> Toolbars -> Toolbar -> Graphic Filter
Tools → Options… → LibreOffice →  Accessibility → Allow animated graphics
Tools → Options… → Load/Save → HTML Compatibility → Copy local graphics to Internet
Comment 44 Commit Notification 2016-05-06 10:22:51 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=46a05c224687c7942b3b0d92d1e0be32bfc9af43

tdf#70998 Termchange: Graphic->Image

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 45 Commit Notification 2016-05-06 12:30:03 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8e8b51cbe2e61c60da14b0a6bae72f76f36c2503

tdf#70998 Termchange: Graphic->Image

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 46 Samuel Mehrbrodt (CIB) 2016-05-06 12:33:29 UTC
I tried to fix the remaining instances, please report back if you find any more.
Comment 47 Commit Notification 2016-11-01 21:50:14 UTC
Stanislav Horacek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=68f7b9d1c6ffed02a241645868e49bf80aa45b53

tdf#70998 change term "Graphics" to "Images"
Comment 48 gat 2016-11-24 00:03:58 UTC
On Fedora 25 with LibreOffice 5.2.3.3 I still see File → Print... or Ctrl+P → LibreOffice Writer → Pictures and other graphic objects.
Comment 49 Tamsil Amani 2016-12-21 21:17:34 UTC
I've assigned this bug to myself.
Comment 50 Commit Notification 2016-12-23 18:27:54 UTC
Huzaifa Iftikhar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5c983bc2ab020b0dbbd8f58e66b9a6fd8508bfde

tdf#70998 Change word "Graphic(s)" to "Image(s)"

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 51 Commit Notification 2016-12-24 08:23:20 UTC
tamsil1amani3 committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a2a605d864417209f3bfacc858fe9107a1e48531

tdf#70998 Text change: graphics/picture to image

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 52 Commit Notification 2016-12-24 08:24:43 UTC
abdulwd committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1c6993e6d7d04c42c6bd48da6afb6305eb608c11

tdf#70998 Change from picture to image

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 53 jani 2017-01-09 08:55:22 UTC
Seems solved, if not, then it would be nice to know what is open
Comment 54 gat 2017-10-30 05:20:08 UTC
On Mac OS X with LibreOffice 5.4.2.2 I still see File → Print... or Cmd+P in  LibreOffice Writer → Pictures and other graphic objects. That seems to be the last remaining instance.
Comment 55 Xisco Faulí 2017-10-31 06:49:45 UTC
(In reply to gat from comment #54)
> On Mac OS X with LibreOffice 5.4.2.2 I still see File → Print... or Cmd+P in
> LibreOffice Writer → Pictures and other graphic objects. That seems to be
> the last remaining instance.

Dear gat,
This bug has been in RESOLVED FIXED status for more than 6 months.
If the issue is still reproducible with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/, please report a new issue in https://bugs.documentfoundation.org/enter_bug.cgi providing, if needed, the steps and documents to reproduce it.
Thanks for your understanding and collaboration.
Closing as RESOLVED FIXED