Bug 71234 - UI: GETPIVOTDATA function returns #REF error
Summary: UI: GETPIVOTDATA function returns #REF error
Status: RESOLVED DUPLICATE of bug 69518
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 72963 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-11-04 21:39 UTC by John Smith
Modified: 2013-12-22 12:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
An ODS spreadsheet demonstrating the issue described above. (93.25 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-11-04 21:39 UTC, John Smith
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Smith 2013-11-04 21:39:23 UTC
Created attachment 88656 [details]
An ODS spreadsheet demonstrating the issue described above.

Problem description: 
Using GETPIVOTDATA function with the second syntax variation, not that which is used in the Function Wizard, the function returns the #REF error.
Steps to reproduce:
1. Open the attached spreadsheet and examine the two formulae in cells A31 and A32.
2. The formula in cell A32 is entered using the second syntax style available for this function.


Current behavior:
Returns a #REF error.
Expected behavior:
It should return the same result as the formula entered in cel A31.


Also included in the spreadsheet is a screen-shot taken from Open Office for illustration purposes relating to the syntax.
              
Operating System: Windows XP
Version: 4.1.3.2 rc
Comment 1 m.a.riosv 2013-11-05 02:15:34 UTC
Hi John, thanks for reporting.

Reproducible:
Win7x64Ultimate
Version 4.0.6.2 (Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24)
Version: 4.1.4.0.0+ Build ID: d6ee64b75581cbeb92534271ee6f4e87f07aa5c
Version: 4.2.0.0.alpha0+ Build ID: 7c19dd02d9241e06ecfeeb9ba4ab2971cba7ef43

Not verified in 3.6
Last version working:
LibreOffice 3.5.7.2 Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b
Comment 2 Jacques Guilleron 2013-11-16 17:10:08 UTC
Hello,

Works too on LO 3.6.6.2 portable, Windows 7 Home Premium.

Jacques
Comment 3 pierre-yves samyn 2013-11-17 06:12:07 UTC

*** This bug has been marked as a duplicate of bug 69518 ***
Comment 4 m.a.riosv 2013-12-22 12:08:08 UTC
*** Bug 72963 has been marked as a duplicate of this bug. ***