Bug 71273 - Other: not responding correctly to ctrl alt right
Summary: Other: not responding correctly to ctrl alt right
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 71314 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-11-05 17:24 UTC by nelson
Modified: 2013-11-13 15:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nelson 2013-11-05 17:24:32 UTC
Problem description:

When using a form (created with the wizard) to enter data, the keyboard short cutshown,(ctrl alt right) to move to the next record rotates the form by 90 degrees instead      
Operating System: Windows 7
Version: 4.1.2.3 release
Comment 1 Robert Großkopf 2013-11-08 16:54:37 UTC
No problem here with openSUSE 12.3 64bit rpm-Linux. So I can't confirm.
Did you define such a shortcut for rotating anywhere else in Windows?
Comment 2 Robert Großkopf 2013-11-08 17:11:33 UTC
*** Bug 71314 has been marked as a duplicate of this bug. ***
Comment 3 nelson 2013-11-09 20:07:29 UTC
No, have not defined it as a keyboard function  elsewhere - but I am 
using a laptop with touchpad  in win7 64bit which allows a picture 
rotate by finger motions on the pad  could this be the cause?
My apology for double reporting - i'm new to the system!

But thanks for the info about the strange number of records behaviour- I 
understand the use now

Nelson Bowker
On 08/11/2013 16:54, bugzilla-daemon@freedesktop.org wrote:
> robert@familiegrosskopf.de <mailto:robert@familiegrosskopf.de> changed 
> bug 71273 <https://bugs.freedesktop.org/show_bug.cgi?id=71273>
> What 	Removed 	Added
> CC 		robert@familiegrosskopf.de
>
> *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=71273#c1> 
> on bug 71273 <https://bugs.freedesktop.org/show_bug.cgi?id=71273> from 
> robert@familiegrosskopf.de <mailto:robert@familiegrosskopf.de> *
> No problem here with openSUSE 12.3 64bit rpm-Linux. So I can't confirm.
> Did you define such a shortcut for rotating anywhere else in Windows?
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Comment 4 Robert Großkopf 2013-11-10 17:47:11 UTC
(In reply to comment #3)
> No, have not defined it as a keyboard function  elsewhere - but I am 
> using a laptop with touchpad  in win7 64bit which allows a picture 
> rotate by finger motions on the pad  could this be the cause?
> My apology for double reporting - i'm new to the system!

No problem - I have closed the other report.
Could it be your laptop works with this shortcut? Which laptop do you use?
> 
> But thanks for the info about the strange number of records behaviour- I 
> understand the use now

Should we close the other bug-report or should we change it to a wish for an enhancement?

Robert
Comment 5 nelson 2013-11-11 20:51:49 UTC
Yet another update - it IS a function of my laptop.
If I open any small window - such as a file list - the ctrl alt right  
combination rotates it- so there is something grabbing the screen before 
Libreoffice does!
Nelson Bowker

Will investigate and report further
On 08/11/2013 16:54, bugzilla-daemon@freedesktop.org wrote:
> robert@familiegrosskopf.de <mailto:robert@familiegrosskopf.de> changed 
> bug 71273 <https://bugs.freedesktop.org/show_bug.cgi?id=71273>
> What 	Removed 	Added
> CC 		robert@familiegrosskopf.de
>
> *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=71273#c1> 
> on bug 71273 <https://bugs.freedesktop.org/show_bug.cgi?id=71273> from 
> robert@familiegrosskopf.de <mailto:robert@familiegrosskopf.de> *
> No problem here with openSUSE 12.3 64bit rpm-Linux. So I can't confirm.
> Did you define such a shortcut for rotating anywhere else in Windows?
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Comment 6 Robert Großkopf 2013-11-12 18:36:27 UTC
(In reply to comment #5)
> Yet another update - it IS a function of my laptop.
> If I open any small window - such as a file list - the ctrl alt right  
> combination rotates it- so there is something grabbing the screen before 
> Libreoffice does!

So could we close this Bug (and Bug71509) as Notourbug?
Comment 7 nelson 2013-11-12 19:20:34 UTC
Yes I think you could - thanks for the prompt help though!

Further investigation by me shows that ctrl+alt+ a cursor key rotates 
the entire screen between portrait and landscape modes - useful if 
viewing an A4 document for instance, with the laptop on its side. My 
daughter has a similar facility on her lenovo she now tells me!

UNFORTUNATELY this is not mentioned in any of the documentation with the 
ASUS.....I have sent them an email asking how i can disable this 
feature, but if I get no joy I guess I need to put in a user defined key 
combination in my Libreoffice - so making it nonstandard if I pass 
anything on.  HoHum

I am a lot happier using the Libreoffice DB than using Access - it gives 
me help wizards for bits I need, but am unhappy with at first, and which 
I can then deal with properly later when I have a bit more experience. 
The import from a spreadsheet to a table with headings is a joy. I have 
several databases in an old (win3.1) program to convert via csv.   And, 
as  (very) retired computer science lecturer, I can see how I could have 
used it with novice students, both with Win and Linux


On 12/11/2013 18:36, bugzilla-daemon@freedesktop.org wrote:
>
> *Comment # 6 <https://bugs.freedesktop.org/show_bug.cgi?id=71273#c6> 
> on bug 71273 <https://bugs.freedesktop.org/show_bug.cgi?id=71273> from 
> robert@familiegrosskopf.de <mailto:robert@familiegrosskopf.de> *
> (In reply tocomment #5  <show_bug.cgi?id=71273#c5>)
> > Yet another update - it IS a function of my laptop.
> > If I open any small window - such as a file list - the ctrl alt right
> > combination rotates it- so there is something grabbing the screen before
> > Libreoffice does!
>
> So could we close this Bug (andBug71509  <show_bug.cgi?id=71509>) as Notourbug?
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Comment 8 Robert Großkopf 2013-11-12 19:36:51 UTC
(In reply to comment #7)
> Yes I think you could - thanks for the prompt help though!

So I close this Bug and Bug71509.
If you have more problems with Base you could also send me a mail directly and we could see, if we could solve it.

Regards

Robert
Comment 9 nelson 2013-11-13 15:52:25 UTC
/I have now identified the problem/
the Intel HD 3000 graphics driver commonly  used in laptops has the 
ctrl+alt+cursor key combination to effectively specify which edge of the 
screen is top!  I googled rotation problems to find this - asus still 
have not come back

One can get into the driver media control with Ctrl+alt + f12, and 
disable the hot keys.... I have done this and Libreoffice now works 
perfectly. /*If */I ever need to rotate my screen I can re-enable, but I 
wonder if a change of tack on the control codes for "next record" in 
Libreoffice might be considered down the line - I gather almost all 
laptops and win7 machines do have this graphics option built in as 
default.. shift or ctrl  + enter is what I have met with my old 
databases, which is intuitive

Thanks again for the help - even though i was not your fault

Nelson Bowker

On 12/11/2013 19:36, bugzilla-daemon@freedesktop.org wrote:
> robert@familiegrosskopf.de <mailto:robert@familiegrosskopf.de> changed 
> bug 71273 <https://bugs.freedesktop.org/show_bug.cgi?id=71273>
> What 	Removed 	Added
> Status 	UNCONFIRMED 	RESOLVED
> Resolution 	--- 	NOTOURBUG
>
> *Comment # 8 <https://bugs.freedesktop.org/show_bug.cgi?id=71273#c8> 
> on bug 71273 <https://bugs.freedesktop.org/show_bug.cgi?id=71273> from 
> robert@familiegrosskopf.de <mailto:robert@familiegrosskopf.de> *
> (In reply tocomment #7  <show_bug.cgi?id=71273#c7>)
> > Yes I think you could - thanks for the prompt help though!
>
> So I close this Bug andBug71509  <show_bug.cgi?id=71509>.
> If you have more problems with Base you could also send me a mail directly and
> we could see, if we could solve it.
>
> Regards
>
> Robert
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>