Bug 71349 - Add option to allow user to have more than 10 Most Recent Documents listed
Summary: Add option to allow user to have more than 10 Most Recent Documents listed
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-07 16:01 UTC by removed_user_0001
Modified: 2013-11-13 10:45 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description removed_user_0001 2013-11-07 16:01:20 UTC
Oh shit - that was fine and kind of dated even in Windoze 95 - and hard drives were like 20 Meg.

But in the foul year of our lord, 2013 when terror bite drives and multiples of the terrors and the drives are quite common - meaning thousands of files are in use, a recently used file list that is expandable in 100 file increments, is probably the NOW defacto standard.

But all the copy cat writers and developers of Libreoffice and Open Orifice, along with Microscoff, and Adobe and all the others, just don't get it - the LIMIT of the 10 most recently used file list - is so far back into the dark ages - it's just a retarded joke to have kept this idiot idea on life support for so long.....

I for one would like to see the total dumping of the 10 MRU file limit, and to have selectable multiples of 100's of files.

Please fix.

My cynacism makes me puke.
Comment 1 Urmas 2013-11-07 19:56:22 UTC
Please grow up and try again.
Comment 2 m.a.riosv 2013-11-08 00:33:47 UTC
If all was so easy, but I have just forgot how.
Comment 3 Robinson Tryon (qubit) 2013-11-10 23:03:13 UTC
I don't use the "Most Recently Used" file list that much; 5-10 seems plenty for my needs.

Sounds like an enhancement, so I'm marking it as such.
Comment 4 Rob Snelders 2013-11-10 23:07:05 UTC
Setting it to lowest as this doesn't annoy many people
Comment 5 removed_user_0001 2013-11-11 08:18:32 UTC
I think otherwise.
Comment 6 Joel Madero 2013-11-11 18:12:45 UTC
This is an enhancement, please don't change again as Qubit, mariosv and myself are all QA members. Upping the priority of your own bug (or in this case enhancement) just to try to get attention is a violation of the FDO policy. 

https://wiki.documentfoundation.org/QA/FreeDesktop_Rules_Procedures

This is most definitely an enhancement, currently LibreOffice works as designed and you are asking us to do something different - this by definition is an enhancement request. 

Marking as NEW as it's a valid request, also adding Astron and moving it to UX-Advice as we'll need their input.
Comment 7 Joel Madero 2013-11-11 18:16:57 UTC
@Astron - I guess what we need is the approval to increase the number and then a possible placement of where the option could go in option dialog. Furthermore, this is likely an easy hack - I may try myself but for now leaving it set to default for assignee :)
Comment 8 V Stuart Foote 2013-11-11 19:03:54 UTC
@Joel, 

Why would this enhancement not be immediately closed as duplicate of fdo#60743, or more completely fdo#61174, item 3(c)?

And then, I beleive that the start center GSOC work to use the recent documents list fdo#64088 has already expanded the list beyond 10.

Stuart
Comment 9 Joel Madero 2013-11-11 20:22:47 UTC
let's close it then ;) I just didn't know of those other reports :-D
Comment 10 V Stuart Foote 2013-11-11 20:29:51 UTC
Setting Resolved Duplicate of fdo# bug 61174, item 3(c).

@Jesús, you've still listed yourself as assigned for 61174. If the remainder of item 3 is outside your scope of interest--please back yourself out. Stuart

*** This bug has been marked as a duplicate of bug 61174 ***
Comment 11 Jan Holesovsky 2013-11-11 21:48:30 UTC
This has been actually fixed some time ago in master:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=96d97654611386eae3254ce184b9ad0944d37879
Comment 12 Robinson Tryon (qubit) 2013-11-11 22:09:15 UTC
Documentation on the Ask site (see cloph's answer):

http://ask.libreoffice.org/en/question/941/can-i-access-a-list-of-recent-documents-longer-than-10-entries/
Comment 13 removed_user_0001 2013-11-12 06:05:06 UTC
Just because you have a different opinion to me, about my perspective, doesn't make you wrong.

Some people want 2013 style thinking, to go with 2013 filing systems and 2013 hard drives, and the volumes of files that are run in 2013.

Some people think staying stuck in Windoze 95 with 1995 thinking is their way of doing things and that everyone else must abide by what they think, no matter how obstructive or inefficent this way of operating actually is.

I choose to improve, and I am not the least offended if you choose  think differently.

But the important priority stays, because it is important and because I say so.

It's my idea and I have been pushing for it for like 7 years now.

There is nothing wrong with being difficult, obstructive, living in the past or aggrandising your own ideas over those of the others.

Progressive ideas, well just because every body in every peicce of software, by every producer is still stuck in the Windoze 95 mentality - with ONLY 10 files listed in the most recently used list - does not make it right, relevant or worth bothering with.

I am quite sure that you will agree that looking like a bunch of "me too" retards, is actually the worst thing you can do to down grade the image of competative modern software.
Comment 14 Stefan Knorr (astron) 2013-11-12 08:14:41 UTC
(Removing UX-advise from CC to avoid spamming it.)

MrBean: For 4.2, the limit had already been raised to 25 files. Thus this bug was fixed already. This bug will not be retroactively fixed in 4.1 or earlier.

25 seems like a pretty sensible limit to me. It's not useful to make LibreOffice remember every file it has ever opened – LibreOffice is not supposed to become a full-fledged file manager.

Note that the 8 or 10 files limit was probably not there because hard drives were small, but because 7 +/- 2 items is somewhat of a magical number in terms of human memory and perception.

So, while the new limit is probably great in the new Start Center, actually I'd rather not see 25 items in the Recently-Opened-Documents menu. That's just imho, though.
Comment 15 Michael Stahl (CIB) 2013-11-12 10:39:56 UTC
re-setting priorities - can we please get some kind of permissions for these set up so that random reporters can't up their pet bugs and only QA/dev can change the priority?

this sort of misbehavior makes bugzilla priorities totally useless and developers will just ignore them.
Comment 16 QA Administrators 2013-11-12 13:34:31 UTC
@MrBean - this is final warning about disregarding our policies. Next one will be a 24 hour ban from our bug tracker
Comment 17 Robinson Tryon (qubit) 2013-11-12 15:09:05 UTC
(In reply to comment #15)
> re-setting priorities - can we please get some kind of permissions for these
> set up so that random reporters can't up their pet bugs and only QA/dev can
> change the priority?

I believe this will be much easier once we have Bugzilla migrated to a separate instance. (ETA: Hopefully by the end of November)

> this sort of misbehavior makes bugzilla priorities totally useless and
> developers will just ignore them.

QA hears you, loud and clear. I'll see what I can do to expedite the process.
Comment 18 removed_user_0001 2013-11-12 15:32:40 UTC
Your certainly entitled to your collecctive opionions and the suppression of the ideas that you don't like.

But we do live in a free world and people should be encouraged to put forward their best ideas, without those who love to shove their opinions and adgendas down everyones throats.

The year is 2013 - people use Terrorbite drives, if the idea of producing the software is to get people to use it - then they should be encouraged to use it in the most capable method possible.

This is why on systems with Terrorbite drives, or multiple Terrorbite drives, or even multiples of Terrorbite drives - if the software is to be used professionally and in wide spread domestic acceptance, then it must be made to show a most recently used files list, in groups of 100's or multiples of 100's.

Of course a backward or even a retarded perspective, is to keep on shoving people into that rather incompetent method of only accessing the last 10 used files via the software.

The world has long since left the Windoze 95 copycat menu system behind - at least hardware wise.

There is no pride in being in a technological backwater - no matter how comforting this is to the unimaginative.
Comment 19 removed_user_0001 2013-11-12 15:37:35 UTC
(In reply to comment #16)
> @MrBean - this is final warning about disregarding our policies. Next one
> will be a 24 hour ban from our bug tracker

Will this include stopping the endless "It only suits me to have a 10 most recently used files list - so what suits me should enable me to apply it to everyone else - especially all those who don't want it." type messages?

If so you have better make the ban 48 hours.

I hate my inbox being filled with shit.

No offence you understand - just the self obsessed never seem to get the big picture, thus their opinions are generally worthless.
Comment 20 removed_user_0001 2013-11-12 15:45:14 UTC
(In reply to comment #15)
> re-setting priorities - can we please get some kind of permissions for these
> set up so that random reporters can't up their pet bugs and only QA/dev can
> change the priority?
> 
> this sort of misbehavior makes bugzilla priorities totally useless and
> developers will just ignore them.


But Bugzilla is totally worthless.

Look at all the opinionated people who lack the faculties to even pass a basic comprehension test.

Then they run around shouting down all the people who won't roll over and take thier worthless opinions about themselves, as the unquestionable word of a god.

I have heard people say that the reason they all stay away from Bugzilla and Libreoffice, is because it's more akin to a circle jerk of conformity to the lowest common denominator, than it is to making first rate software.

That is just a compilation of others opinions mind you.

I think Libreoffice and the people inhabiting the depths of Bugzilla are simply super.

Super duper.
Comment 21 removed_user_0001 2013-11-12 15:51:12 UTC
(In reply to comment #17)
> (In reply to comment #15)
> > re-setting priorities - can we please get some kind of permissions for these
> > set up so that random reporters can't up their pet bugs and only QA/dev can
> > change the priority?
> 
> I believe this will be much easier once we have Bugzilla migrated to a
> separate instance. (ETA: Hopefully by the end of November)
> 
> > this sort of misbehavior makes bugzilla priorities totally useless and
> > developers will just ignore them.
> 
> QA hears you, loud and clear. I'll see what I can do to expedite the process.




Tell me has the "community" of Bugzilla been in rapid decline recently?

Perhaps you should try to make more people do what you say, when you say it and if they don't - you should implement your super user powers, of deleting their posts, censoring what messages they leave, banning them for assorted periods - including indefinitely for not seeing everything your way.

And while your trotting off to get your super user censoring powers, don't forget to polish your jack boots, we must keep the "community minded image" congruent.
Comment 22 V Stuart Foote 2013-11-12 15:59:10 UTC
Please move substantive discussion of Start Menu enhancements to bug 61174, the start menu item count has already been increased to 25 from 10 items as part of the StartCenter work incorporated in master branch. IT was one of the items in FDO#61174.

@MrBean, your points have been made and are not being discounted. BZ is a bit murky, but it functions after a fashion. The issue of the --10 item Start Menu is closed-- please let it be at that and move on to more constructive contributions.

Regards, Stuart

*** This bug has been marked as a duplicate of bug 61174 ***
Comment 23 removed_user_0001 2013-11-12 16:01:34 UTC
Google:

Bugzilla alternatives

123,000 results.

bugzilla assholes

127,000 results.

Wow - great job guys.... I am sure I could find a heap more really bad reviews.



Gettting super user powers will really improve this outlook.

How long before the people in Bugzilla and the project it's self end up drowning in the results of their own self importance?

Tsk, Tsk, Tsk......

Too bad.

So sad.
Comment 24 removed_user_0001 2013-11-12 16:07:07 UTC
(In reply to comment #22)
> Please move substantive discussion of Start Menu enhancements to bug 61174,
> the start menu item count has already been increased to 25 from 10 items as
> part of the StartCenter work incorporated in master branch. IT was one of
> the items in FDO#61174.
> 
> @MrBean, your points have been made and are not being discounted. BZ is a
> bit murky, but it functions after a fashion. The issue of the --10 item
> Start Menu is closed-- please let it be at that and move on to more
> constructive contributions.
> 
> Regards, Stuart
> 
> *** This bug has been marked as a duplicate of bug 61174 ***



You have failed to grasp the situation.

25 files in the MRU is not blocks of 100 files in the MRU.

Perhaps your should go to a good concentration camp, to fix the impairment of reading and not understanding - and then serving up a crumb in lieu of a fully addressing the situation.

We need to have a Most Recently Used file list, in the 100 files range and additional blocks of 100 files.....


People use Terrorbite drives for a damned good reason.

They have hundreds, thousands and tens of thousands of files....

Not 30 or 40 of them.

Get with the times.
Comment 25 QA Administrators 2013-11-12 16:33:29 UTC
Just going to make it a permanent ban. Apologies all for the noise
Comment 26 Michael Stahl (CIB) 2013-11-13 10:45:40 UTC
(In reply to comment #25)
> Just going to make it a permanent ban. Apologies all for the noise

thank you very much.