Bug Hunting Session
Bug 71468 - Cannot delete custom styles
Summary: Cannot delete custom styles
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-11 08:24 UTC by Markus Michels
Modified: 2015-05-30 02:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Michels 2013-11-11 08:24:49 UTC
First (minor) bug indicating that LO 4xy formatting is very broken.

Custom styles cannot be deleted.

Steps to reproduce:
Open impress, create new document
Add a shape (e.g. rectangle) to page
Open styles menu (hit F11)
Select rectangle
Click in styles menu "new style from selection"
Name it "watchamacallit"
Change the style settings (e.g. other background i.e. area color)
Apply default style to created shape
Right click in styles menu on newly created style "watchamacallit"
Select "delete"

Nothing happens. So once created styles will reside forever in the document. Expected behavior would be that this style simple disappears.
Comment 1 Jean-Baptiste Faure 2013-11-11 10:58:11 UTC
I do not reproduce with LO 4.1.4.0.0+ under Ubuntu 13.10 x86-64.
If I try to delete the style while it is used in the doc, I get a warning message saying that I ask to delete a style in use.
If I try to delete the style while it is not in use, then the style is deleted.

Please, could you verify if your encounter the same behavior with a clean new user profile: https://wiki.documentfoundation.org/Faq/General/110

Best regards. JBF
Comment 2 Markus Michels 2013-11-11 16:19:01 UTC
I tried it using LO 4.1.3 on Ubuntu x64 with a clean profile (i.e. I deleted folder .config/libreoffice beforehand).

Problem still exists.

Thanks for your help,


Markus
Comment 3 Dominique Boutry 2013-11-21 15:35:16 UTC
Hi

The "steps to reproduce" lead to a used style (you can check it before attempting to delete it : select "applied Styles" in the drop-down list at the bottom of the stylist window, and it appears).
It makes sense to me that one can't delete a style while it is used in the current doc (JBF pointed that too). Revert the forms using this style to "Default" style, and you will be able to delete the style (it won't reside forever in the document).
Comment 4 Markus Michels 2013-11-21 17:42:55 UTC
Well, it is expected that I cannot delete a style in use. But if I assign back default to my object (hence my personal style does not appear in the used styles list anymore) then I still cannot delete my personal style. This is the bug...
Comment 5 Dominique Boutry 2013-11-22 07:21:10 UTC
OK ! So "not reproduced" with LibO 4.1.2.3 on Win7...
Comment 6 Markus Michels 2013-11-22 09:14:33 UTC
So I tested this bug on three different systems, always with LO 4.1.3.2

Linux (Ubuntu 64 Bit): bug exists (i.e. cannot delete custom style even if not assigned)

Mac OSX: bug exists (like in linux)

Windows 7 64 Bit: bug does NOT exist (i.e. I can delete unassigned style, if style is assigned I get a warning that it will be reverted to default if I choose to delete)

Hope it helps...
Comment 7 daniel 2013-11-25 12:52:49 UTC
I can confirm the issue in LO 4.1.3.2 in the Calc component (OpenSuse 64 bit). I can create a new cell style and use it, but can then neither modify nor delete it. Clicking the corresponding context menu items triggers no action at all.
This is even true if the style is currently unused (i.e. not in the Applied Styles list).
Comment 8 Markus Michels 2013-11-29 12:23:18 UTC
Seems to be fixed in LO 4.2.0 Beta 1 Linux x64
Comment 9 sophie 2013-12-04 13:30:04 UTC
Confirmed also using Ubuntu 13.10 and Version: 4.1.3.2
Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a. I can reproduce in Calc and Impress, I didn't get the message that the style I try to delete is in use . Mark the issue as confirmed - Sophie
Comment 10 Jean-Baptiste Faure 2013-12-04 21:25:41 UTC
Changed the component to LibreOffice because the bug is present in several components, not only in Impress.

Best regards. JBF
Comment 11 João Paulo 2014-02-13 01:11:26 UTC
I can confirm this bug on LibreOffice 4.1.5.2 running on Windows XP 32 bits.

Components affected: Calc, Draw, Impress and Writer.

Should the platform be changed to All, as Linux (All) and Windows XP are affected?

If needed, I can test on Windows Vista and 7, both 64 bits.
Comment 12 Joel Madero 2015-05-02 15:43:11 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 13 Jean-Baptiste Faure 2015-05-04 05:04:34 UTC
Not reproducible with LibreOffice 4.4.4.0.0+ built at home under Ubuntu 15.04 x86-64. tested with Impress and calc modules.

Closing as WorksForMe. Please, feel free to reopen if you disagree.

Best regards. JBF
Comment 14 Markus Michels 2015-05-30 02:44:58 UTC
Also works for me

LO 4.4.3-2
Arch Linux x64