Bug 71532 - EDITING: Ctrl+; insert current date/time although cell and sheet is locked.
Summary: EDITING: Ctrl+; insert current date/time although cell and sheet is locked.
Status: CLOSED DUPLICATE of bug 107240
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 123895 129840 (view as bug list)
Depends on:
Blocks: Cell-Sheet-Protection
  Show dependency treegraph
 
Reported: 2013-11-12 11:54 UTC by Paweł Sawicki
Modified: 2020-01-13 22:26 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paweł Sawicki 2013-11-12 11:54:31 UTC
Hi,

Ctrl+; insert current date/time although cell and sheet is locked.
 


              
Operating System: Windows 8
Version: 4.1.3.2 release
Comment 1 Cor Nouws 2013-11-12 12:16:45 UTC
Hi Pawel,

(In reply to comment #0)

> Ctrl+; insert current date/time although cell and sheet is locked.


You mean frozen, or read only?
Not for me in 4.1.3.2 on Ubuntu any way.
Comment 2 sophie 2013-11-12 12:28:30 UTC
Confirmed, steps to reproduce:
- select all the cells and under Format>Cells unprotect all the cells
- select A1:B2 and under Format>Cells check Protected
- under Tools > Protect document, select Sheet
- enter Ctrl+; while the cursor is on a protected cell, the date is enterred even with the alert pop-up message displayed. 
Version: 4.1.3.2
Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a Ubuntu 13.10 Gnome.
Set to New, change plateform to all - Sophie
Comment 3 Paweł Sawicki 2013-11-12 12:46:27 UTC
Hi,
Exacly:

"
- select all the cells and under Format>Cells unprotect all the cells
- select A1:B2 and under Format>Cells check Protected
- under Tools > Protect document, select Sheet
- enter Ctrl+; while the cursor is on a protected cell, the date is enterred
even with the alert pop-up message displayed. "
Comment 4 QA Administrators 2015-04-19 03:20:55 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2015-06-17 09:43:54 UTC
Had to change the keyboard shortcut for it to work on my keyboard, but still reproduced.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 80ec99db4325a439a8a3f1d420d0a80f8bf9c439
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-16_00:00:20
Locale: fi-FI (fi_FI)
Comment 6 QA Administrators 2016-09-20 10:01:39 UTC Comment hidden (obsolete)
Comment 7 Daniel 2018-03-13 07:24:39 UTC
Bug still present on LO 6.0.2.1 x64 Windows10, with the same behaviour (i.e. the alert being displayed, but the current time gets inserted anyway).
Comment 8 raal 2019-03-06 15:04:37 UTC
*** Bug 123895 has been marked as a duplicate of this bug. ***
Comment 9 Oliver Brinzing 2020-01-07 16:57:35 UTC
*** Bug 129840 has been marked as a duplicate of this bug. ***
Comment 10 Eike Rathke 2020-01-13 22:25:59 UTC
Fixed since 6.1.4

*** This bug has been marked as a duplicate of bug 107240 ***