Download it now!
Bug 71622 - SVG file inserted as picture is not compressed
Summary: SVG file inserted as picture is not compressed
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha1
Hardware: Other Windows (All)
: medium critical
Assignee: Andras Timar
URL:
Whiteboard: target:4.3.0 target:4.2.3 target:5.2....
Keywords: regression
: 50730 76938 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-11-14 19:22 UTC by ape
Modified: 2016-10-25 19:11 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Size SVG in ODT files (4.2 vs 4.1) (20.10 KB, image/png)
2013-11-14 19:22 UTC, ape
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ape 2013-11-14 19:22:49 UTC
Created attachment 89235 [details]
Size SVG in ODT files (4.2 vs 4.1)

OS: Windows NT-5.1;2
LibODev 4.2.0.0.alpha1 (Build ID: c2b9ad37f8a8de9c7dbdd76c86aecf6388107056)
--
If you created the ODT (ODG, ODP) file and made the paste of the SVG file as picture then SVG is not compressed. The result is a significant increase in the weight of the files.
This is a regression LibODev 4.2.0 compared to LibreOffice 4.1 and earlier.
Comment 1 Commit Notification 2014-03-12 13:55:25 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=360c7e573f0ce4b6a892bb7f7e51b9267bed5a6d

fdo#71622 compress svg files in ODF



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 2 Commit Notification 2014-03-12 15:34:22 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cab3cac0d77651718051c88a068f8e3966dbb4e8&h=libreoffice-4-2

fdo#71622 compress svg files in ODF


It will be available in LibreOffice 4.2.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Andras Timar 2014-04-24 19:43:03 UTC
*** Bug 76938 has been marked as a duplicate of this bug. ***
Comment 4 Jorendc 2014-07-24 19:36:28 UTC
*** Bug 50730 has been marked as a duplicate of this bug. ***
Comment 5 Commit Notification 2015-12-08 01:04:24 UTC
Thorsten Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ad0edc184792f3aa3f72e8d4ec8b76c3d1bf8479

Related: tdf#71622 compress more gfx in odf streams

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2015-12-08 13:34:33 UTC
Thorsten Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=26f62c80aa3684301e29dd17f9efba1bcd68264d&h=libreoffice-5-1

Related: tdf#71622 compress more gfx in odf streams

It will be available in 5.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2016-01-13 20:40:42 UTC
Thorsten Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cb72051d70a844077363d52a1a54d083136cde03&h=libreoffice-5-0

Related: tdf#71622 compress more gfx in odf streams

It will be available in 5.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.