Download it now!
Bug 71625 - Endless autosave loop if the document is not linked to a file
Summary: Endless autosave loop if the document is not linked to a file
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: All All
: high major
Assignee: Maxim Monastirsky
URL:
Whiteboard: BSA target:4.4.0 target:4.3.2 target:...
Keywords:
: 73015 78168 78812 79374 80454 92711 (view as bug list)
Depends on:
Blocks: AutoSave-AutoRecovery-Backup mab4.2
  Show dependency treegraph
 
Reported: 2013-11-14 21:55 UTC by 43884928
Modified: 2015-07-13 22:10 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description 43884928 2013-11-14 21:55:18 UTC
Problem description: 
when selecting a cell (?), after a time of working, the program always register the file(one time per second).
No way to do anything, and the file is not recoverable !
Steps to reproduce:
1. ....
2. ....
3. ....

Current behavior:

Expected behavior:

              
Operating System: Windows 7
Version: 4.1.2.3 release
Last worked in: 4.1.2.2 rc
Comment 1 ign_christian 2013-11-15 09:40:20 UTC
Could you please explain in detail how to reproduce the issue? Otherwise it's hard to triage & analyze..
Comment 2 Urmas 2013-11-15 11:08:17 UTC

*** This bug has been marked as a duplicate of bug 46635 ***
Comment 3 Arnaud Versini 2014-04-26 14:18:46 UTC
This one is not a duplicate, this bug is due to the new autosave option. Disabling it and Calc will never make this loop.
Comment 4 Arnaud Versini 2014-04-26 14:26:30 UTC
Steps to reproduce this bug verry fast :
Set autosave option
Create a document (Calc, Writer...)
Modify it without saving
Wait
LibreOffice will loop and create a lot of save files
Comment 5 Arnaud Versini 2014-04-26 14:38:20 UTC
Not infinite loop on master but still buggy, few files every time
Comment 6 Luuk 2014-04-27 15:48:51 UTC
see https://bugs.freedesktop.org/show_bug.cgi?id=46635
for more details.

Basically it happens if the user is using the menu at the time of autosave
The result is a loop, and a lot of docs ...
Comment 7 Arnaud Versini 2014-05-17 09:12:44 UTC
*** Bug 78812 has been marked as a duplicate of this bug. ***
Comment 8 Jean-Baptiste Faure 2014-06-10 05:06:24 UTC
*** Bug 79374 has been marked as a duplicate of this bug. ***
Comment 9 Yousuf Philips (jay) (retired) 2014-06-24 11:08:33 UTC
*** Bug 73015 has been marked as a duplicate of this bug. ***
Comment 10 Yousuf Philips (jay) (retired) 2014-06-24 11:08:43 UTC
*** Bug 78168 has been marked as a duplicate of this bug. ***
Comment 11 Yousuf Philips (jay) (retired) 2014-06-24 11:09:22 UTC
*** Bug 80454 has been marked as a duplicate of this bug. ***
Comment 12 Commit Notification 2014-08-10 12:58:32 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5b9509115bd4adc5ef2618f0d9436cda1c0d9fbe

fdo#71625 Don't loop autosave if userautosave fails



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2014-08-11 06:26:35 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9799a623161f43a0ca0c7a4806416ce466b558a6&h=libreoffice-4-3

fdo#71625 Don't loop autosave if userautosave fails


It will be available in LibreOffice 4.3.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2014-09-15 14:45:42 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4ecfac2e86492dda389d16ab4a9690445201f469&h=libreoffice-4-2

fdo#71625 Don't loop autosave if userautosave fails


It will be available in LibreOffice 4.2.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 JHosier 2015-05-22 09:36:58 UTC
Dear Libreoffice developers
I am and have been a libreoffice supporter and user ever since openoffice was young. I am also usually a calm and friendly guy but this bug has made me very annoyed and frustrated to say the least.
A variation of this bug was first listed in bug 46635 back in Feb 2012.
It has been closed as a duplicate of this bug.
However, I can confirm that this bug has still not yet been fixed.
I am using Windows 7 and the latest version of Libreoffice 4.4.3 and the bug still persists.

The basic problem which has been repeated numerous times by others is simply that when libreoffice writer has "save autorecovery information every x minutes" and when "automatically save the document too" ticked and then the user does not name a new document and leaves it "untitled" then the autosave function eventually after some time goes into an endless loop of trying to save. This makes the application unusable.

Can this please be look at as a matter of urgency?
Please ask if further information is necessary.

Jon
Comment 16 V Stuart Foote 2015-05-22 12:35:01 UTC
(In reply to JHosier from comment #15)

> However, I can confirm that this bug has still not yet been fixed.
> I am using Windows 7 and the latest version of Libreoffice 4.4.3 and the bug
> still persists.
> 
> The basic problem which has been repeated numerous times by others is simply
> that when libreoffice writer has "save autorecovery information every x
> minutes" and when "automatically save the document too" ticked and then the
> user does not name a new document and leaves it "untitled" then the autosave
> function eventually after some time goes into an endless loop of trying to
> save. This makes the application unusable.
> 

Can not confirm.

On Windows 7 sp1 64-bit, en-US with
Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Locale: en_US

This behaves correctly, and for an untitled new document the temporary "untitled_0.odt" autorecovery backup is written to the designated backup folder at the selected interval when changes are made to the document.

Would need more definite STR, but please check these:

1. please verify your Tools -> Options -> Backups in your profile is pointing to a valid and writable location, preferable local
2. check that location for read only files (that your account is unable to delete) of the default "untitled_#.od[fgpst] form
Comment 17 V Stuart Foote 2015-05-22 12:39:35 UTC
(In reply to V Stuart Foote from comment #16)
s/Tools -> Options -> Backups/Tools -> Options -> Paths: Backups/
Comment 18 Carlos Rodriguez 2015-05-24 10:42:15 UTC
Also, can not confirm on:

Versión: 4.4.3.2
Id. de compilación: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Configuración regional: es_ES

Debian 8.

Works as supposed creating "untitled_0.odt" fine as a backup.
Comment 19 V Stuart Foote 2015-05-24 14:10:08 UTC
Back to Resolved Fixed. 

@JHosier -- please open a new issue with complete STR including Paths settings in your user profile, and details of the filesystem supporting your OS.
Comment 20 m.a.riosv 2015-07-13 22:10:05 UTC
*** Bug 92711 has been marked as a duplicate of this bug. ***