Bug 71645 - footnote numbers in cross-references
Summary: footnote numbers in cross-references
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: László Németh
QA Contact:
URL:
Whiteboard: target:4.2.0
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-15 12:52 UTC by László Németh
Modified: 2015-07-26 18:19 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Insert -> Cross reference UI (30.47 KB, image/png)
2013-11-15 13:04 UTC, László Németh
Details
LibreOffice bookmark export in a PDF Viewer (32.87 KB, image/png)
2013-11-15 13:05 UTC, László Németh
Details
test document (7.89 KB, application/vnd.oasis.opendocument.text)
2013-11-15 13:06 UTC, László Németh
Details
UI fix (30.62 KB, image/png)
2013-11-15 13:07 UTC, László Németh
Details
PDF export fix (33.00 KB, image/png)
2013-11-15 13:07 UTC, László Németh
Details
Test document 2 (11.93 KB, application/vnd.oasis.opendocument.text)
2013-11-20 07:03 UTC, László Németh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description László Németh 2013-11-15 12:52:27 UTC
Table of contents removes footnote numbers in its cross references, but not PDF bookmarks and inserting cross reference UI.

Example (heading with footnote numbers):

1. Correct heading with superscript footnote number: 

Heading¹

2. Correct cross reference in TOC:

Heading

3. Bad cross reference in PDF bookmarks and Insert->Cross reference preview:

Heading1

See attached screenshots.
Comment 1 László Németh 2013-11-15 13:04:02 UTC
Created attachment 89264 [details]
Insert -> Cross reference UI
Comment 2 László Németh 2013-11-15 13:05:39 UTC
Created attachment 89265 [details]
LibreOffice bookmark export in a PDF Viewer
Comment 3 László Németh 2013-11-15 13:06:39 UTC
Created attachment 89266 [details]
test document
Comment 4 László Németh 2013-11-15 13:07:19 UTC
Created attachment 89267 [details]
UI fix
Comment 5 László Németh 2013-11-15 13:07:47 UTC
Created attachment 89268 [details]
PDF export fix
Comment 6 László Németh 2013-11-20 07:03:26 UTC
Created attachment 89512 [details]
Test document 2

The solution has been extended for Fields » Document » Chapter cross-references, too (eg. cross-references in headers), see this test document.
Comment 7 Commit Notification 2013-11-20 07:15:09 UTC
Laszlo Nemeth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d665e058246631c8a838c3a731bdd0c56be27903

fdo#71645 remove footnote numbers in cross-references



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Gerry 2015-07-26 18:19:51 UTC
Hi László, is it possible that there was/is a regression with regard to "footnote numbers in cross-references"? I encounter the same problem on Ubuntu with Version: 4.4.2.2, which was fixed by your commit in comment 7.

I cross-checked with LO 5.0rc3 on Windows and it seems to be okay there.

Was there a regression in the 4.4.2 line that had been fixed in later 4.4.x versions?