Bug Hunting Session
Bug 71731 - Start Center: Mouse-hover effect on green sidebar is incorrect, it should be semi-transparent (lightweight button)
Summary: Start Center: Mouse-hover effect on green sidebar is incorrect, it should be ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: Other All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Start-Center
  Show dependency treegraph
 
Reported: 2013-11-18 09:44 UTC by Emir Sarı (away)
Modified: 2017-11-10 15:11 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Preferred transparent background (18.34 KB, image/png)
2013-11-18 09:44 UTC, Emir Sarı (away)
Details
Current non-native look (50.30 KB, image/png)
2013-11-18 09:45 UTC, Emir Sarı (away)
Details
screenshot in LibO 5.0.x (54.58 KB, image/png)
2015-11-01 07:47 UTC, tommy27
Details
2015-11-01 nightly w breeze (46.46 KB, image/png)
2015-11-01 12:09 UTC, steve -_-
Details
how it looks for me (27.87 KB, image/png)
2015-11-01 19:08 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emir Sarı (away) 2013-11-18 09:44:46 UTC
Created attachment 89395 [details]
Preferred transparent background

Hello,

First of all, thanks to everyone who have contributed to new Start Center.

For the new design, sidebar buttons looks a bit non-native, the grey on-hover background does not look very good. For the possible solution, current 4.1 transparent background would be a better possible solution, because with green background all other options would look bad I think. 

Also the font size could be a little smaller, they are not in ratio with the recent documents filenames, one side looks much bigger and nonproportional. 

Thanks everyone in advance!
Best regards,
Comment 1 Emir Sarı (away) 2013-11-18 09:45:48 UTC
Created attachment 89396 [details]
Current non-native look
Comment 2 Adolfo Jayme 2013-11-19 03:26:33 UTC
Confirmed on Windows as well. The buttons should have a semi-transparent highlight on mouse hover (MS calls this “lightweight buttons” in MSDN), like the buttons in a toolbar.
Comment 3 Emir Sarı (away) 2013-11-19 05:14:41 UTC
I don't know if we need to open another bug for this, but all frames should have borders, at least very light matte borders, to make it easier for the eyes... Astron's mock-up had those...
Comment 4 Stefan Knorr (astron) 2014-02-03 20:14:46 UTC
Re comment 3, right, my mockups had this. But since VCL does not have the capabilities of the average web browser, there was a bit of an implementation problem (according to Kendy).

So, the best option I see is to turn the green level down (to make it window background-grey), so we can use completely native light-weight buttons.
Comment 5 kloud 2014-06-21 05:28:19 UTC
I liked the former starting screen better. I think the LibreOffice banner looked professional. The buttons would still fit left / below, recent documents right / below. I'm not sure about the menu bar either.

Borders are not required.

What's that random triangle logo good for?
Comment 6 Adolfo Jayme 2014-06-22 02:25:27 UTC
(In reply to comment #5)

I hardly see how relevant is your comment in this bug report. Let's not start an off-topic discussion here, please. We won't just revert to the previous code.

And, just FYI: the "random graphic" is our branding motif.
Comment 7 Jan Holesovsky 2014-06-22 11:18:12 UTC
Emir, all: I am afraid that if we tried harder to combine the native buttons with the green, we would have even worse trouble than this - the semi-transparent native button would turn green-ish, which would be problem for another group of users.  Not to mention that from the technical point of view, it would be a start-center-only hack, which is not the preferred solution...

So I hope it is bearable in the current state for you - I am not really eager to do more changes there, until we have a complete update of the look :-)
Comment 8 kloud 2014-06-26 12:58:23 UTC
(In reply to comment #6)

It does belong here, since former start centers used white and light-grey backgrounds. The new structure is ok.

Shouldn't a brand be recognized? The motif hardly appeared before, except in about screens.
Comment 9 V Stuart Foote 2014-06-26 13:44:24 UTC
(In reply to comment #8)
> Shouldn't a brand be recognized? The motif hardly appeared before, except in
> about screens.

Please see https://wiki.documentfoundation.org/Design/Motif and other Design team materials.

Otherwise, enough said as this is not the venue for such issues.
Comment 10 Adolfo Jayme 2014-12-19 16:07:58 UTC
(In reply to Jan Holesovsky from comment #7
> [...] Not to mention that from the technical point of
> view, it would be a start-center-only hack, which is not the preferred
> solution...

Why would it be a StartCenter-only hack? I thought just adding the WB_FLATBUTTON bit would fix this.
Comment 11 retired 2014-12-20 08:27:18 UTC
Re-opening until we hear more dev feedback on adolfo's suggestion.

The buttons do look rather ugly. If that is expected for other platforms, it dev sticks out as odd on OS X. Transparency would solve this. If this is changed for all buttons, why not if it then fits with OS X. We'd have to discuss which other areas are effect by a potential change.

I lack the tech details but if what Adolfo suggests is feasable it would imo be a desirable change.
Comment 12 V Stuart Foote 2014-12-20 13:11:41 UTC
To UX-advise and NEEDINFO as agreed
Comment 13 V Stuart Foote 2014-12-28 18:34:57 UTC
Nothing to do with the Sidebar meta, clearly belongs only on Start Center related issue. I set it incorrectly back in June 2014, adjusting.
Comment 14 tommy27 2015-11-01 07:47:14 UTC
since LibO 5.0.x the Start Center left sidebar is not green anymore and is now light grey.

is the current mouse-hover effect still annoying to you?
if not, we should close this bug report
Comment 15 tommy27 2015-11-01 07:47:54 UTC
Created attachment 120152 [details]
screenshot in LibO 5.0.x
Comment 16 steve -_- 2015-11-01 12:09:01 UTC
Attaching 2015-11-01 nightly w breeze screenshot.

Fine for me. Setting to WORKSFORME. Now that the background is grey and the hoover effect is a lightgrey it even has a "semi-transparent" effect although that may not be, what is actually happening.

Emir, if you disagree, please re-open.
Comment 17 steve -_- 2015-11-01 12:09:40 UTC
Created attachment 120159 [details]
2015-11-01 nightly w breeze
Comment 18 Adolfo Jayme 2015-11-01 13:44:11 UTC
Steve, that’s an optical illusion.
Comment 19 steve -_- 2015-11-01 13:57:21 UTC
Adolfo, I know and was trying to say just that with my earlier statement.

The question is: what is currently missing? We want real transparency? And if so, who is going to implement it? Kendy said, he'd rather not spend more time on this (comment 7).
Comment 20 tommy27 2015-11-01 17:59:05 UTC
anyway even if it's not a real transparency it look like it is because of the new grey background... so much better than before with the green background
Comment 21 Yousuf Philips (jay) (retired) 2015-11-01 19:08:56 UTC
Created attachment 120169 [details]
how it looks for me

The issue is definitely not as bad as it was when the pane was green and it looks fine unless the button comes over the motif. I would however close as WORKSFORME unless someone steps up to resolve the transparency issue that is only left.
Comment 22 Adolfo Jayme 2015-11-02 20:29:08 UTC
I don’t understand the rush of closing issues that don’t have an owner currently. I thought you knew that LibreOffice collaborators work on enhancements in their free time, as they please.
Comment 23 Robinson Tryon (qubit) 2016-08-25 05:38:52 UTC Comment hidden (obsolete)
Comment 24 Heiko Tietze 2017-11-10 15:11:57 UTC
With the gray background things have improved. While the start center is still not native, we shouldn't put more time and effort into it.