Bug 71737 - ODF import: illustration index template hyperlink is lost
Summary: ODF import: illustration index template hyperlink is lost
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: BSA odf target:6.1.0 target:6.0.0.1 t...
Keywords:
: 100268 105624 112315 (view as bug list)
Depends on:
Blocks: TableofContents-Indexes Hyperlink
  Show dependency treegraph
 
Reported: 2013-11-18 12:33 UTC by Luiz Angelo Daros de Luca
Modified: 2017-12-27 07:01 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Odt with an illustration index and two figures. Hyperlink is present in the result index but not in its original settings. (783.55 KB, application/vnd.oasis.opendocument.text)
2013-11-18 12:33 UTC, Luiz Angelo Daros de Luca
Details
Test result file (hyperlinks lost) (9.83 KB, application/vnd.oasis.opendocument.text)
2016-07-27 19:15 UTC, Johnny_M
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luiz Angelo Daros de Luca 2013-11-18 12:33:04 UTC
Created attachment 89402 [details]
Odt with an illustration index and two figures. Hyperlink is present in the result index but not in its original settings.

The illustration index hyperlinks is saved document.
The default index settings is:
LS E T # LE

But after reloading the file, I got:

E T #

1. Add an illustration index
2. Add two illustration with captions
3. Update the index (the hyperlinks are working)
4. Reload the file (hyperlinks are still working but lost in index settings. Just edit it to check)
5. Update the index (hyperlinks are lost)

I'll attach an example doc at the step 4. that I listed before.
Operating System: Ubuntu
Version: 4.1.2.3 release
Comment 1 Thomas van der Meulen 2013-12-07 08:27:31 UTC
Thank you for your bug report, I can reproduce this bug running 
Version: 4.2.0.0.beta2
Build ID: 1a27be92e320f97c20d581a69ef1c8b99ea9885d
OS: Mac osx 10.9.

I can confirm that the hyperlinks get lost, but I don't understand what you mean with "LS E T # LE" after I saved the file and reopend they were still there
Comment 2 Luiz Angelo Daros de Luca 2013-12-08 04:51:27 UTC
LS LE are the index fields, at least what libre office shows me. Might be link start and link end.
Comment 3 Luiz Angelo Daros de Luca 2015-04-02 03:08:05 UTC
Still on 4.4.2.2
Comment 4 tommy27 2016-04-16 07:22:52 UTC Comment hidden (obsolete)
Comment 5 Luiz Angelo Daros de Luca 2016-05-01 22:51:18 UTC
It still happens on 5.1.2.2 ubuntu 16.06
Comment 6 Buovjaga 2016-06-11 14:03:46 UTC
*** Bug 100268 has been marked as a duplicate of this bug. ***
Comment 7 Johnny_M 2016-07-27 19:15:45 UTC
Created attachment 126439 [details]
Test result file (hyperlinks lost)

I can confirm this issue. The Illustration Index loses its hyperlinks after the file gets re-opened and the index updated.

Test steps:
1. Start LO by opening a new Writer document
2. Draw some figure in Writer (or add an external picture, etc.) and add a capture to it, of type Drawing or Illustration
3. Insert an Illustration Index, of the respective category (Drawing, Illustration or even Table if that was added on step 2)
4. Save the created file as ODT, close LO and re-open the same file
5. Update the Illustration Index (either using "Update Index..." in its context menu or going to Tools -> Update -> Update All

Expected results:
1. New document opens
2. Caption gets added
3. Illustration Index gets added correctly - hyperlinks can be followed by Ctrl + left click
4. File gets opened correclty - hyperlinks are still there in the Illustration Index
5. Hyperlinks are still there in the Illustration Index

Actual results:
5. Hyperlinks are gone from the Illustration Index, although the latter updates its pages correctly


Linux Mint 17.1, 64-bit
Version: 5.1.4.2
Build ID: 1:5.1.4-0ubuntu1~trusty1
CPU Threads: 2; OS Version: Linux 3.13; UI Render: default; 
Locale: de-DE (en_GB.UTF-8)
Comment 8 dev guy 2017-03-24 14:35:33 UTC
This bug is still existent in version 2.5.2.1 (Tested on OS: Debian)

It is very annoying that you have to edit all indexes every time you open the document !!
Comment 9 dev guy 2017-03-24 14:40:37 UTC
This bug is still existent:

Version 5.2.5.1 
Build ID: 1:5.2.5-2
(Tested on OS: Debian)

It is very annoying that you have to edit all indexes every time you open the document !!



(Had a wrong version number in last comment, but couldn't edit. My apologies)
Comment 10 Commit Notification 2017-12-08 13:07:32 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=523da0bfba2546552b4181e0268f41bc38a1903f

tdf#71737: save allows links in illustration index, but load doesn't

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Michael Stahl 2017-12-08 17:26:13 UTC
note: this is not a ODF 1.2 feature, proposal to add it to ODF 1.3 at https://issues.oasis-open.org/browse/OFFICE-3941
Comment 12 Commit Notification 2017-12-08 17:38:26 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a26c4448e6e5ffcd285cc691bfc4eb6c7edf76bc

tdf#71737 xmloff: ODF 1.2 doesn't allow hyperlinks in ...

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2017-12-08 19:49:47 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f987cc2910ae90229ae7f76ed1dc9325b57b5cb6&h=libreoffice-6-0

tdf#71737: save allows links in illustration index, but load doesn't

It will be available in 6.0.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2017-12-08 20:23:17 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c5b7e99758553d8d4f1a149bcc3d0b2d5835d312&h=libreoffice-6-0

tdf#71737 xmloff: ODF 1.2 doesn't allow hyperlinks in ...

It will be available in 6.0.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2017-12-11 14:36:35 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=267ef9428dd3713746f405a8a650defede3a4005&h=libreoffice-5-4

tdf#71737: save allows links in illustration index, but load doesn't

It will be available in 5.4.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2017-12-13 08:10:11 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6ca6d6ac912588a8f62d7e6b668ebec333752ebc

Related: tdf#71737: allows links in more indexes

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2017-12-13 08:25:57 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=934ae5cd6fc2c676429c14834b929707fec9faa1&h=libreoffice-5-4

tdf#71737 xmloff: ODF 1.2 doesn't allow hyperlinks in ...

It will be available in 5.4.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2017-12-13 21:19:34 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f6c08dca7d950e583cfc4454a74ed9806eda0609

Related: tdf#71737 xmloff: adapt XMLSectionExport

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2017-12-13 21:47:24 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8d0e6ad024f3154115bc39f9db4cec3a6afc59c4

Related: tdf#71737 xmloff: import of user-defined hyperlink was missing

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Johnny_M 2017-12-26 22:15:03 UTC
*** Bug 105624 has been marked as a duplicate of this bug. ***
Comment 21 Xisco Faulí 2017-12-27 07:01:58 UTC
*** Bug 112315 has been marked as a duplicate of this bug. ***