Bug 71788 - FILESAVE: DOCX export : File corruption: XML tag mismatch error after Roundtrip
Summary: FILESAVE: DOCX export : File corruption: XML tag mismatch error after Roundtrip
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: pallavi.jadhav
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-19 13:40 UTC by pallavi.jadhav
Modified: 2015-08-20 13:15 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
For attached document, in header2.xml the 'w:tc' start tag does not match the end tag of 'w:hdr' (215.12 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-11-19 13:43 UTC, pallavi.jadhav
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pallavi.jadhav 2013-11-19 13:40:43 UTC

    
Comment 1 pallavi.jadhav 2013-11-19 13:43:02 UTC
Created attachment 89465 [details]
For attached document, in header2.xml the 'w:tc' start tag does not match the end tag of 'w:hdr'
Comment 2 pallavi.jadhav 2013-11-19 13:49:43 UTC
Steps to Reproduce:-
1] open attache document in LibreOffice 4.2
2] Select save_as option
3] After save_as, open file in MS Office
4] File gets corrupted

Current beahviour:-
Import:
1] Footer is missing

Export:
1] In header2.xml,
   <w:tbl>
       <w:tblPr> </w:tblPr>
       <w:tblGrid> </w:tblGrid>
   is getting repeated inside <w:tr> which is not correct and causing corruption.
2] Also the footer.xml is missing

Expected behaviour:-
1] File should not get corrupted after Roundtrip in LibreOffice
2] Footer information should be saved
Comment 3 Jorendc 2013-11-20 07:00:17 UTC
Thanks for reporting :-).

Not only footer.xml is missing, also endnotes.xml, footnotes.xml and webSettings.xml

Not sure that's also bad or not :).

Marking as NEW. Tested using Mac OSX 10.9 with LibreOffice Version: 4.2.0.0.alpha1+ Build ID: 9c45345a680f7444df251f9403c7d56572380f21
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2013-11-18_12:43:03

Kind regards,
Joren
Comment 4 pallavi.jadhav 2013-11-20 08:22:35 UTC
Hi Joren,

Thanks for testing the bug.

For missing endnotes.xml and footnotes.xml, LibreOffice does not write back these files if those are empty. If you check endnotes.xml and footnotes.xml, you can observe these files are empty. Hence LibreOffice is not writing them back while exporting the document.

And surely there is a problem with webSettings.xml. 

Right now working on corruption part.

Regards,
Pallavi Jadhav
Comment 5 steve -_- 2015-04-16 07:06:42 UTC
@Pallavi: just a ping. Are you still working on this or should we free this bug?
Comment 6 Xisco Faulí 2015-08-20 13:15:36 UTC
I can no longer reproduce the corruption issue with

Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: es-ES (es_ES)

and Office 2010

on Windows 7 (64-bit)

Thus, I close it as RESOLVED WORKSFORME

Regarding the footer loss, it's already addressed in bug 81426