Download it now!
Bug 71883 - StartCenter UI - Missing item "Customize" from the Tools menu of the StartCenter
Summary: StartCenter UI - Missing item "Customize" from the Tools menu of the StartCenter
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha1
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:4.3.0 target:4.2.0.2 Confirmed...
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-11-21 16:27 UTC by pierre-yves samyn
Modified: 2014-01-13 09:40 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2013-11-21 16:27:56 UTC
Hello

Congratulations to have "lighten" Start Center menus: remove items Edit, View, Window is fine.

In contrast, "Macros" and "Customize" items are useful (and used)  to  changes at LibreOffice level (vs "module)

For example, to create and assign macros to application events (start, close, new document, etc.)

Regards
Pierre-Yves
Comment 1 Jean-Baptiste Faure 2013-11-25 20:39:06 UTC
Correction of summary that make easier to find all bug reports against StartCenter: "Start Center" -> StartCenter
Comment 2 Jean-Baptiste Faure 2013-11-25 21:53:50 UTC
I agree with this proposition of enhancement.

Best regards. JBF
Comment 4 pierre-yves samyn 2013-12-14 10:09:23 UTC
Hello

(In reply to comment #3)
> “Macros” were readded by Kendy:
> http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-4-
> 2&id=b33986252aeb2ef6105231169e4d78e7940a0522

Verified on windows 7/64 & Version: 4.2.0.0.beta2+
Build ID: 4031765b004dded31f04c54f9a055b7a3d0053f2
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2013-12-14_01:35:27

Thank you :)

We also need "Customize"...

Regards
Pierre-Yves
Comment 5 retired 2013-12-14 22:52:29 UTC
adjusting title since macros are there.
Comment 6 retired 2013-12-18 09:44:12 UTC
cc: kendy.

if this is wanted should be pretty easy to fix.
Comment 7 retired 2013-12-18 09:54:56 UTC
Confirmed on OS X 10.9, LO Version: 4.3.0.0.alpha0+
Build ID: 4c539fac018dfd44cd8db52161a8cb930c627da7
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2013-12-18_01:54:50
Comment 8 Commit Notification 2014-01-09 10:01:42 UTC
Zolnai Tamas committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c6775a8f2c595de29b9f92f0d1059f9d9282bc12

fdo#71883 Startcenter: Re-introduce the 'Tools' -> 'Customize...' menu



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2014-01-09 13:25:13 UTC
Zolnai Tamas committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b24351e5e3565bbd2b8b724d83f4b4c1e0b9f8dc&h=libreoffice-4-2

fdo#71883 Startcenter: Re-introduce the 'Tools' -> 'Customize...' menu


It will be available in LibreOffice 4.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 pierre-yves samyn 2014-01-11 12:06:50 UTC
Hello

Thank you for the patch.

Verified on windows 7/64 with Version: 4.3.0.0.alpha0+
Build ID: ae8e579515fff84cbef1ccc2da78fa769fb079ec
TinderBox: Win-x86@39, Branch:master, Time: 2014-01-10_11:16:31

FYI a crash occurs with tools customize events macro.  
I opened bug 73498 for this.

Regards
Pierre-Yves
Comment 11 Commit Notification 2014-01-13 09:40:04 UTC
Zolnai Tamas committed a patch related to this issue.
It has been pushed to "libreoffice-4-2-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8fda9ebaa5a577c2f08b824426a3ad05046ae61f&h=libreoffice-4-2-0

fdo#71883 Startcenter: Re-introduce the 'Tools' -> 'Customize...' menu


It will be available already in LibreOffice 4.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.