Bug 71892 - paste table in footnote crashes
Summary: paste table in footnote crashes
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: Other Linux (All)
: high major
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:4.3.0 target:4.2.0.1 target:4.1.5
Keywords: bibisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2013-11-21 22:26 UTC by Terrence Enger
Modified: 2015-12-17 07:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
console + bt with master sources (8.00 KB, text/plain)
2013-11-22 06:19 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Terrence Enger 2013-11-21 22:26:30 UTC
This report comes from my attempt to reproduce bug 71749; it may even be the same bug appearing in a different context.

STR:
(1) Start in an empty Writer document.
(2) Type <ctrl>-<F12>.  Program presents dialog "Insert Table".
(3) Click <Insert>.  The Writer document has an empty 
    2-by-2 table.
(4) Type <ctrl>-A <ctrl>-C.  The program highlights the entire 
    content of the document.
(5) Take menu option Insert > "Footnote/Endnote...".  Program 
    presents dialog "Insert Footnote/Endnote".
(6) Click <OK>.  The program inserts "1" at the bottom of the 
    page and puts the caret immediately thereafter.
(7) Type <ctrl>-V.  Program aborts.  Experimentation in gdb 
    shows that the last exception thrown is from 
    framework::XCUBasedAcceleratorCongiguration::getCommandB
yKeyEvent, 
    framework/source/accelerators/acceleratorconfiguration.cxx:667.

This is from my debug build of master commit 3d7d662, fetched 
around 2013-11-19 22:00 UTC.  

For comparison, LibreOffice delivered with debian-wheezy (3.5.4.2, build id 350m1 (Build:2)), does not crash, but there is no table evident in the footnote, the content of each cell being pasted in as a separate line.  That is not a really good result, but I am applying "regression" keyword anyway.

I shall attach full backtrace when my machine with LibreOffice has contact with the Internet.

Please beware of typos in this report.  I am typing on a small screen.
Comment 1 Terrence Enger 2013-11-21 22:38:57 UTC
I am leaving this bug UNCO.  It would be good to hear about platforms.  Perhaps the severity should be increased.
Comment 2 Tim Lloyd 2013-11-21 23:55:00 UTC
Fedora 20/LO4.1.3.2

Slightly different behaviour. After pasting the text, writer locks up and CPU usage is around 99.8%.I let it sit there for 5 mins and then had to manually "force quit".
Comment 3 Terrence Enger 2013-11-22 04:28:03 UTC
According to bibisect, the first bad commit is f98bc0b, source-hash ce97851, 2012-02-06.  If I am reading the output correctly, the last good commit is 4d2e7c1, source-hash 43c7830, 2011-12-12.
Comment 4 Julien Nabet 2013-11-22 06:19:11 UTC
Created attachment 89620 [details]
console + bt with master sources

On pc Debian x86-64 with master sources updated yesterday, I reproduced the crash.
Comment 5 Michael Stahl (CIB) 2013-12-05 22:35:09 UTC
similar crash can happen since 3.6; problem is the RSID update
that assumes the same number of nodes have been pasted
as were copied before, which is not the case when pasting
table in footnote.

fixed on master
Comment 6 Commit Notification 2013-12-05 22:35:27 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4580094d2d9d5b952c4526ee23204f75a5bb2f1b

fdo#71892: sw: fix crash when pasting table in footnote



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2013-12-05 22:53:31 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2171fff4c1a57ede8f9693d7c0d95c1171a49a70&h=libreoffice-4-2

fdo#71892: sw: fix crash when pasting table in footnote


It will be available in LibreOffice 4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2013-12-06 09:07:57 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=640e8abbff03f7f242c0c0b9d73ffd2eda3c4e35&h=libreoffice-4-1

fdo#71892: sw: fix crash when pasting table in footnote


It will be available in LibreOffice 4.1.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Terrence Enger 2013-12-10 13:51:13 UTC
The crash is no longer evident in a debug build of master commit
b092637, fetched 2013-12-06, built and running on debian-wheezy.

Thank you, Michael.
Comment 10 Robinson Tryon (qubit) 2015-12-17 07:33:36 UTC Comment hidden (obsolete)