Bug Hunting Session
Bug 71916 - Impress: Outline text: Text still visible after cutting
Summary: Impress: Outline text: Text still visible after cutting
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Cut-Copy
  Show dependency treegraph
 
Reported: 2013-11-22 12:10 UTC by Stefan
Modified: 2017-11-05 21:28 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan 2013-11-22 12:10:24 UTC
I am having plenty of problems with the "Outline text" box in Impress (the autolayout box featuring "Click to add text" on a new slide), including Copy, Cut & Paste, Undo, and Cursor Position, which can suddenly appear off the expected location between two letters. Most of it is difficult to reproduce, except the following issue:

Text does not disappear immediately on Edit -> Cut (Cmd-X)

I am on MacOSX 10.7 and have tried a variety of releases since 4.0.0, the latest being 4.1.3.2.

How to reproduce:

(1) Open new Impress Presentation
(2) Insert -> Slide
(3) Click on "Click to add text" and type "Text"
(4) Mark the word "Text"
(5) Click Edit -> Cut (Cmd-X)

Result: The cursor jumps to the start of "Text", but the word "Text" is still visible.

(6) On additional keyboard input or mouse click at a location different from the word "Text", the word "Text" finally disappears.

Expected behavior: The word "Text" should disappear immediately after Cut.
Comment 1 retired 2013-11-22 15:32:36 UTC
Stefan, thanks a lot for this report.

Confirming in 4.1.3.2 OS X 10.9 and
LO Version: 4.3.0.0.alpha0+
Build ID: 73342dbb82ba074d01962359dac50fb2aa36cbeb
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2013-11-22_07:09:14

Any text that is cut (cmd + x) should disappear immediately.
Comment 2 QA Administrators 2015-04-19 03:22:09 UTC Comment hidden (obsolete)
Comment 3 steve -_- 2015-06-18 15:13:05 UTC
OS X 10.10.3
Version: 5.1.0.0.alpha1+
Build ID: fb6dd2a73074b9695bd8ddf7ba40f1819b03024e
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2015-06-17_23:34:12
Locale: de-DE (de.UTF-8)

1. new impress presentation
2. menubar slide > new page/slide (menu has changed for LO 5)
3. type "text" where "Click to add text" is found
4. mark the word "text"
5. Click Edit -> Cut (Cmd-X)

Result: The cursor jumps to the start of "Text", but the word "Text" is still visible.

Still happening.
Comment 4 QA Administrators 2016-09-20 10:10:16 UTC Comment hidden (obsolete)
Comment 5 eisa01 2017-11-05 21:28:39 UTC
This works for me, if I cut the text disappear

Version: 6.0.0.0.alpha1+
Build ID: 7e03c4eed72452fdfb87341214a21956c08ba969
CPU threads: 2; OS: Mac OS X 10.12.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2017-10-25_23:45:02
Locale: en-US (en_US.UTF-8); Calc: group