Bug 72055 - EDITING: Use a sensible color picker for drawings
Summary: EDITING: Use a sensible color picker for drawings
Status: RESOLVED DUPLICATE of bug 46840
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-26 22:53 UTC by daniel.ssq89
Modified: 2014-05-15 19:46 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshots showing the currently available color pickers in LibreOffice (54.40 KB, image/png)
2013-11-26 22:53 UTC, daniel.ssq89
Details

Note You need to log in before you can comment on or make changes to this bug.
Description daniel.ssq89 2013-11-26 22:53:44 UTC
Created attachment 89874 [details]
screenshots showing the currently available color pickers in LibreOffice

Why does the LibreOffice Draw (and also drawing tools in Write, Impress etc.) not use Writer's text color/highlight/paragraph background colour selector? (see attachment)

To name a few disadvantages of Draw's colour picker:

1. Colour names take up space. The names themselves are not useful for drawing -- the colours themselves are important.

2. The colours are laid out sequentially. I am limited to 20, maybe 30 colours per screen in the drop-down selection. This makes it very difficult to know what colours are available in the current palette, and to compare colours.


LibreOffice Draw should use the same colour picker as in Write. 

In my opinion the drop-down-and-scroll colour picker is a horrible idea and should be eradicated from the entire code base.
Comment 1 Regina Henschel 2013-11-27 20:21:42 UTC
You get a "colors only" color picker by View > Toolbars > Color Bar in Draw and Impress. Click on the color to color a marked object, or drag and drop the color onto a not marked object, or drag and drop a color onto a gradient handle. [There seems to be a bug in LibreOffice, try ApacheOffice to see, how it is intended.]
Comment 2 daniel.ssq89 2013-11-27 21:59:26 UTC
(In reply to comment #1)
> You get a "colors only" color picker by View > Toolbars > Color Bar in Draw
> and Impress. Click on the color to color a marked object, or drag and drop
> the color onto a not marked object, or drag and drop a color onto a gradient
> handle. [There seems to be a bug in LibreOffice, try ApacheOffice to see,
> how it is intended.]

That's not the point. It doesn't matter that an alternative way of choosing colours exists -- the drop down menu is just bad usability for the task of picking colours. Why make the user scroll for colours when he/she should not even have to? Note: the same argument applies in the Area dialog box (the one that lets you manipulate fill colours, shadow, transparency, gradients etc.).
Comment 3 Joel Madero 2013-12-22 16:16:26 UTC
Requesting UX advice here.
Comment 4 Adolfo Jayme 2013-12-22 16:53:27 UTC
Agreed with the reporter.

(Note that Design has proposed replacements for the color picker — see https://wiki.documentfoundation.org/Design/Whiteboards/Color_Picker — but for now, removing the old color dropdown and replacing it with current’s Writer picker should fix this bug.)
Comment 5 Tin Man 2013-12-27 12:56:36 UTC
The reason why that color picker is used is because the grid-based picker works for solid colors only (i.e. doesn't work for patterns, gradients, etc.).

As an interim solution, would it be possible to use the grid-based picker when "Color" is selected and the list-based picker for gradients, hatchings, and bitmaps?

BTW, the grid-based picker should always be used for the outline.
Comment 6 Stefan Knorr (astron) 2014-03-13 15:35:45 UTC

*** This bug has been marked as a duplicate of bug 58334 ***
Comment 7 Stefan Knorr (astron) 2014-03-13 15:39:23 UTC
Sorry ... didn't read description closely enough. Reopening. Adding 58334 as See Also instead.
Comment 8 Maxim Monastirsky 2014-05-15 19:46:57 UTC

*** This bug has been marked as a duplicate of bug 46840 ***