Download it now!
Bug 72278 - EDITING: Wizard use in Calc changes format
Summary: EDITING: Wizard use in Calc changes format
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: Other Linux (All)
: medium normal
Assignee: Eike Rathke
URL:
Whiteboard: BSA target:4.3.0 target:4.2.0.1 targe...
Keywords: regression
: 72603 (view as bug list)
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-12-03 19:38 UTC by Julien Nabet
Modified: 2014-01-29 04:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Nabet 2013-12-03 19:38:05 UTC
Problem description: 
On pc Debian x86-64 with master sources updated today, I noticed that if I
use wizard (with any function) on Calc for a cell, the format of cell is:
- font Times New Roman
- size 6.8
(instead of Arial/10)
If I directly put the formula without using wizard, no problem.

Steps to reproduce:
1. Open a brand new file on Calc
2. Select Cell A1 (notice default format font Arial size 10)
3. Click button "Function Wizard"
4. Select any function then "Next"
5. Click Cancel

Current behavior:
Font has changed to "Times New Roman" and size 6.8

Expected behavior:
No format change
              
Operating System: Debian
Version: 4.2.0.0.alpha0+ Master
Comment 1 Eike Rathke 2013-12-04 16:28:58 UTC
I'll try to take a stab at this.
Comment 2 Eike Rathke 2013-12-04 16:59:49 UTC
Seems to be a regression of the fix for bug 69971, also in 4-1-4
Comment 3 Eike Rathke 2013-12-04 21:54:08 UTC
Also looks like the cause of bug 71667.
Comment 4 Eike Rathke 2013-12-05 01:09:50 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dfd1a47a38dac743f9ed0f1e9507714bac027d35

resolved fdo#71667 and fdo#72278, fdo#69971 follow-up fix



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Eike Rathke 2013-12-05 01:17:28 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4bea81272d502c044febc419a16c86bbdadf5513&h=libreoffice-4-2

resolved fdo#71667 and fdo#72278, fdo#69971 follow-up fix


It will be available in LibreOffice 4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Eike Rathke 2013-12-05 01:40:10 UTC
Pending review
for 4-1 at https://gerrit.libreoffice.org/6935
for 4-1-4 at https://gerrit.libreoffice.org/6936
Comment 7 Eike Rathke 2013-12-05 11:05:37 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=22ff85716967e573ec3bfdb8c9b17cab7b30d8a4&h=libreoffice-4-1

resolved fdo#71667 and fdo#72278, fdo#69971 follow-up fix


It will be available in LibreOffice 4.1.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Eike Rathke 2013-12-06 12:11:01 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-1-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ff927df4929022656668e4e98511c198134247cc&h=libreoffice-4-1-4

resolved fdo#71667 and fdo#72278, fdo#69971 follow-up fix


It will be available already in LibreOffice 4.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Kohei Yoshida 2014-01-29 04:05:01 UTC
*** Bug 72603 has been marked as a duplicate of this bug. ***