Bug 72320 - EDITING: Image disappears after rotation
Summary: EDITING: Image disappears after rotation
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: filter:emf
Depends on:
Blocks: EMF-WMF Draw-Images
  Show dependency treegraph
 
Reported: 2013-12-04 18:35 UTC by Luigi Boccia
Modified: 2017-08-29 10:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example (56.96 KB, application/vnd.oasis.opendocument.graphics)
2013-12-04 18:35 UTC, Luigi Boccia
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luigi Boccia 2013-12-04 18:35:57 UTC
Created attachment 90276 [details]
Example

Problem description:
Image disappears after rotation 

Steps to reproduce:
1. Activate rotation of the example image
2. Rotate 90 deg
3. The image is gone!



              
Operating System: Windows 8
Version: 4.1.2.3 release
Comment 1 m.a.riosv 2013-12-04 22:05:39 UTC
Hi Luigi, thanks for reporting.

The graphic in your file looks transparent, but rotation happens.
Inserting a graphic from a file and rotating works fine for me.
Win7x64Ultimate
Version: 4.1.4.1 Build ID: 414ce1317b94ce49e6044b84baf237918e9a659
Comment 2 Luigi Boccia 2013-12-05 10:12:29 UTC
Hello,
 the image was pasted from Power Point. It is not trasparent. It gets trasparent after rotation. That is an error which should not happen.

If you copy and paste any image from Power Point you have similar issues.
Comment 3 m.a.riosv 2013-12-05 21:01:19 UTC
Sorry, I can't help, I have not pp.

Please try using other graphics format in Menu/Edit/Paste-special [Shift+Ctrl+V]
Comment 4 Luigi Boccia 2013-12-06 11:18:22 UTC
I've checked with Power Point.
The original image is a pdf screenshot (therefore a bitmap). However the same error happens also when I try to paste polygons etc from pp.

When I try to paste this images in a bitmap format nothing happens in LO.
When I try to paste as metafile I see the image pasted correctly but I get the rotation error. It disappears only if I convert the image in LO in bitmap. However, the image quality decreases sensibly.
Comment 5 tommy27 2014-02-23 08:38:33 UTC
reproducible under Win7x64 with releases 4.1.5, 4.2.0 and 4.3master
Comment 6 Joel Madero 2015-05-02 15:43:03 UTC Comment hidden (obsolete)
Comment 7 Luigi Boccia 2015-05-03 13:18:06 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2016-09-20 09:36:58 UTC Comment hidden (obsolete)
Comment 9 Luigi Boccia 2016-09-20 09:43:46 UTC
Confirmed with 5.2
Comment 10 Telesto 2016-12-23 09:42:09 UTC
Confirmed with:
Version: 5.4.0.0.alpha0+
Build ID: 9cfb2f2f03b5ec086487fd483298466db0b09010
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-20_23:58:02
Locale: nl-NL (nl_NL); Calc: CL

The image seems to be: EMF+
Comment 11 Timur 2017-08-29 10:35:56 UTC
Looks OK in 6.0+. I guess it's new EMF+ so I set to Fixed.
https://cgit.freedesktop.org/libreoffice/core/commit/?id=ebc11ae0b132eefd3b1b1a837a8d0ad3ba73b460