Download it now!
Bug 72438 - LibreLogo: icons in Logo toolbar replaced by text only
Summary: LibreLogo: icons in Logo toolbar replaced by text only
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: LibreLogo
  Show dependency treegraph
 
Reported: 2013-12-07 15:47 UTC by Gilvan Vilarim
Modified: 2018-12-10 16:16 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Writer screen with wrong Logo toolbar with tooltips as buttons (101.57 KB, image/png)
2013-12-07 15:47 UTC, Gilvan Vilarim
Details
Bug in Logo toolbar (65.02 KB, image/png)
2015-06-05 19:03 UTC, Gilvan Vilarim
Details
two documents - second without Icons (143.50 KB, image/jpeg)
2016-02-08 10:56 UTC, Thomas Krumbein
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gilvan Vilarim 2013-12-07 15:47:00 UTC
Created attachment 90414 [details]
Writer screen with wrong Logo toolbar with tooltips as buttons

1 - create a new document in Writer

2 - show the Logo bar: View -> Toolbars -> Logo

3 - Many times, when the Logobar is shown, the button pictures become the tooltip texts, and the toolbar gets very wide. If you close it and view it again, the toolbar is refreshed and buttons become ok. But if you create new documents, the Logo bar will use tooltips as pictures again.

It seems that the code trys to load the pictures into an array of buttons, but some bug makes it loads the tooltips as the buttons pictures.

See image attached (in portuguese, but see the tooltips inside the buttons)
Comment 1 pierre-yves samyn 2014-01-05 08:52:08 UTC
Hello

I confirm on windows 7/64 with:
Version: 4.1.4.2
Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72
Version: 4.2.0.1
Build ID: 7bf567613a536ded11709b952950c9e8f7181a4a

Steps to reproduce
1. File> New> Text document
2. View> Toolbar> Logo (if not aldready displayed)
3. Undock the toolbar (not happens if the toolbar is docked)
4. File> New> Text document, new document opens

Expected result: same Logo toolbar
Actual result: uses the "text only" parameter (no icons)

I change Importance to "normal": no loss of data, workaround exists (close-reopen).
Feel free to change if you do not share my point of view.

Regards
Pierre-Yves
Comment 2 Gilvan Vilarim 2014-05-12 19:26:52 UTC
Hi. This bus persists in version 4.2.4. Tested on Windows.

The bug takes place when the toolbar is floating, specially when you create new documents and the current document shows the floating Logo toolbar.

Best regards.
Comment 3 Gilvan Vilarim 2014-05-23 19:25:03 UTC
The bug persists on Version 4.3.0 beta1.

Best regards,
Gilvan.
Comment 4 Gilvan Vilarim 2015-03-03 13:35:58 UTC
Hello. The bug persists in version 4.4. 

It is really an annoying bug, because the toolbar becomes so wide that it cannot be moved on screen.

This bug takes place only when the toolbar is floating.

It seems that some kind of array of buttons is loading the tooltips to the wrong attribute. Is may not be so hard to fix :)

Best regards,
Gilvan.
Comment 5 Yousuf Philips (jay) (retired) 2015-03-03 16:43:25 UTC
Hi Gilvan,

Sorry but i couldnt reproduce it on Linux or Windows with a new document no matter how many times i tried. :(

Maybe try resetting your profile to see if that makes a difference. < http://ask.libreoffice.org/en/question/903/where-are-the-libreoffice-data-profile-files/ >.
Comment 6 pierre-yves samyn 2015-03-03 18:29:58 UTC
Hi 

(In reply to Jay Philips from comment #5)
> Sorry but i couldnt reproduce it on Linux or Windows with a new document no
> matter how many times i tried. :(
> 
> Maybe try resetting your profile to see if that makes a difference. <
> http://ask.libreoffice.org/en/question/903/where-are-the-libreoffice-data-
> profile-files/ >.

I *always* reproduce with the indicated steps in comment 1 (respect step 3)

Of course, also with a new profile :)

Windows 7/64 & Version: 4.4.1.1
Build ID: b5ac74bf8683a92078a2bc8aff97d4b436af63cb
Locale: fr_FR

Regards
Pierre-Yves
Comment 7 Yousuf Philips (jay) (retired) 2015-03-04 00:11:01 UTC
Followed the steps but couldnt reproduce it. Can i get a screencast Pierre-Yves?
Comment 8 Gilvan Vilarim 2015-03-04 13:41:06 UTC
I can always reproduce this in Windows 7 64 bit when the bar is "undocked" in initial screen.

In Writer:

1 - Go to File -> New -> Text Document

2 - Show the Logo bar: View -> Toolbars -> Logo

3 - Undock the Logo toobar (leave it floating on screen)

4 - Go to File -> New -> Text Document

5 - The new document will show Logo toolbar but the button pictures become the tooltip texts, and the toolbar gets very wide. This will happen with every new document if the toolbar is undocked.

If the Logo toolbar starts docked at any side of the screen, the bug does not take place.

Unfortunately I cannot test in a Linux machine...

Tested on LO 4.3.6.2 but it is a bug in version 4.4 too.

Best regards,
Gilvan.
Comment 9 pierre-yves samyn 2015-03-04 17:08:07 UTC
(In reply to Jay Philips from comment #7)
> Followed the steps but couldnt reproduce it. Can i get a screencast
> Pierre-Yves?

http://youtu.be/Fvmp9_dOnxw

Regards
Pierre-Yves
Comment 10 Yousuf Philips (jay) (retired) 2015-03-04 21:37:59 UTC
Thanks for the feedback Gilvan and Pierre-Yves. I can confirm it on Linux on master.
Comment 11 Gilvan Vilarim 2015-06-05 19:03:36 UTC
Created attachment 116316 [details]
Bug in Logo toolbar
Comment 12 Gilvan Vilarim 2015-06-05 19:05:23 UTC
Hi. This bug persists in Logo toolbar in LibreOffice 5.0 Beta1. is is annoying for users, especially children.

Maybe we could talk to Andras Timar?

Best regards,
Gilvan.
Comment 13 Thomas Krumbein 2016-02-08 10:55:28 UTC
Bug is still present in all 5.x versions on Windows.

Only the first created document will show Icons in the toolbar - all later created new documents will have only Helptext instead of Icons.
See picture attached (secondDok_LibreLogo.jpg)
Comment 14 Thomas Krumbein 2016-02-08 10:56:34 UTC
Created attachment 122434 [details]
two documents - second without Icons
Comment 15 Gilvan Vilarim 2016-04-29 19:52:38 UTC
Confirmed: The bug persists in version 5.1. 

Best regards,
Gilvan.
Comment 16 Julien Nabet 2016-11-27 20:36:40 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 17 QA Administrators 2017-11-30 06:25:37 UTC Comment hidden (obsolete)
Comment 18 Gilvan Vilarim 2017-12-01 14:19:49 UTC
Hi. This bus persists in version 5.3.7.2 (x64). Tested on Windows.

The bug takes place when the toolbar is floating, specially when you create new documents and the current document shows the floating Logo toolbar.

Best regards.
Comment 19 QA Administrators 2018-12-03 03:58:41 UTC Comment hidden (obsolete)
Comment 20 Gilvan Vilarim 2018-12-08 13:32:03 UTC
Hello. It seems that the problem is solved! Tested with version 6.0.7.3 (x64) on Windows 10.

Does anyone could test on Linux ?

Best regards,
Gilvan.
Comment 21 Xavier Van Wijmeersch 2018-12-09 11:13:39 UTC
Its working on linux

Version: 6.0.6.2
Build ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: group
Comment 22 László Németh 2018-12-10 16:16:19 UTC
I'm closing the issue, according to your feedback. Thanks!