Download it now!
Bug 72451 - LODev 4.3.0alpha+ cannot start Fatal error on Windows & Linux, Startcenter context fails to supply service StartModule of type Xcontroller
Summary: LODev 4.3.0alpha+ cannot start Fatal error on Windows & Linux, Startcenter co...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.3.0 target:4.2.0.1
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-07 19:58 UTC by V Stuart Foote
Modified: 2013-12-10 04:27 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
fatal error in StartCenter UI on Windows (15.00 KB, image/png)
2013-12-08 16:57 UTC, V Stuart Foote
Details
fatal error in StartCenter UI on Linux (149.25 KB, image/png)
2013-12-08 17:57 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2013-12-07 19:58:08 UTC
on Windows 7 sp1, 64-bit

TB-39 -- 2013-12-07 00:52:22 -- is erroring on launch
Build Data
tinderbox: buildname: Win-x86_39
tinderbox: print: &nbsp; <a href=´http://cgit.freedesktop.org/libreoffice/core/log/?id=bd976e5b070ec68a4f842190db4d0c1ea0e93428´>core</a>
tinderbox: starttime: 1386377542
tinderbox: status: success

On /A admin install to C:/LODev430_20131207, at launch receiving error dialog popup:

LibreOfficeDev 4.3 - Fatal Error
The application can not be started.
component context fails to supply service
com.sun.star.frame.StartModule of type
com.sun.star.frame.XController:
file:///C:/LODev430_20131207/program/../share/config/soffice.cfg/sfx/ui/startcenter.ui


The prior TB-39 posting -- 2013-12-06 02:06:23 -- runs without issue
Build Data
tinderbox: buildname: Win-x86_39
tinderbox: print: &nbsp; <a href=´http://cgit.freedesktop.org/libreoffice/core/log/?id=bd976e5b070ec68a4f842190db4d0c1ea0e93428´>core</a>
tinderbox: starttime: 1386295583
tinderbox: status: success

Performed separate download and install onto Windows XP sp3 with same error resulting.
Comment 1 V Stuart Foote 2013-12-07 20:14:26 UTC
issue is also present on
TB-42 -- 2013-12-07 03:23:44
Comment 2 V Stuart Foote 2013-12-07 20:45:16 UTC
(In reply to comment #0)

oops, copied in the wrong build sting from the TB log... 

The prior TB-39 posting -- 2013-12-06 02:06:23
Build Data

tinderbox: buildname: Win-x86_39
tinderbox: fulllog: http://tinderbox.libreoffice.org/cgi-bin/gunzip.cgi?tree=MASTER&full-log=1386307801.17744
tinderbox: print: &nbsp; <a href=´http://cgit.freedesktop.org/libreoffice/core/log/?id=5e01904de993caa3d497a8f6c82a846336e70eef´>core</a>
tinderbox: starttime: 1386295583
Comment 3 V Stuart Foote 2013-12-08 16:57:39 UTC
Created attachment 90469 [details]
fatal error in StartCenter UI on Windows

No improvement in today's 2013-12-08 02:58:23 TB-39 build

tinderbox: print: &nbsp; <a href=´http://cgit.freedesktop.org/libreoffice/core/log/?id=c6fe5c6f371328cb6cf61d68f016a04f8b635a48´>core</a>

Something committed between the 6th & 7th is causing issues at least on Windows builds

http://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=5e01904de993caa3d497a8f6c82a846336e70eef..bd976e5b070ec68a4f842190db4d0c1ea0e93428&ofs=50
Comment 4 V Stuart Foote 2013-12-08 17:55:52 UTC
Just verified that the issue is also present on Linux installs.
TB-46 -- 2013-12-07 23:53:32
8248a32f499f4c4eaf6b7dbd7acead3370fdde54


Testing Fedora core 19 as guest on VMWare workstation on Windows 7 sp1.
3.11.8-200.fc19.x86_64 #1 SMP Wed Nov 13 16:29:59 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Also, on both Windows and Linux other modules partially start, but if they do toolbars are incomplete.
Comment 5 V Stuart Foote 2013-12-08 17:57:26 UTC
Created attachment 90471 [details]
fatal error in StartCenter UI on Linux
Comment 6 V Stuart Foote 2013-12-09 18:11:41 UTC
Administrative /A installs of 4.3.0.0alpha  master for Windows and Linux starting with 7 December have an install root directory of UIconfig. 

Additionally the share/config/soffice.cfg directory for builds from 7 Dec forward is not being fully populated (only simpress related xml).

Receiving the noted Fatal error when execution is unable to find startcenter.ui configuration on the share/config/soffice.cfg/sfx/ui path. 

So something has gone amiss in refactoring for UI configurations/translations.

Is this from https://gerrit.libreoffice.org/6915 , commited the 6th?
Comment 7 Commit Notification 2013-12-09 19:28:02 UTC
Matuš Kukan committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5015f04db460806a8247e97d9f1fe77f1501b255

fdo#72451: installer: Make filelists work again.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2013-12-09 19:30:25 UTC
Matuš Kukan committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c0ccf1914092931645d8f94f189b0328837b02f5&h=libreoffice-4-2

fdo#72451: installer: Make filelists work again.


It will be available in LibreOffice 4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Matúš Kukan 2013-12-09 19:32:04 UTC
> Is this from https://gerrit.libreoffice.org/6915 , commited the 6th?

Yes, it is.
Great work, thanks!

Sorry, for this, hopefully fixed, and all works as expected now.
Comment 10 V Stuart Foote 2013-12-10 04:27:14 UTC
Verified fixed on Windows 7 sp1, 64-bit

Version: 4.3.0.0.alpha0+
Build ID: 031738970b6635505e91065cca511f4378969cb1
TinderBox: Win-x86@39, Branch:master, Time: 2013-12-10_00:56:14

Thanks! Back to other issues...