Bug Hunting Session
Bug 72459 - VIEWING: chart:include-hidden-cells attribute appears to be ignored when references are external
Summary: VIEWING: chart:include-hidden-cells attribute appears to be ignored when refe...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA odf
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-08 00:47 UTC by Owen Genat (retired)
Modified: 2016-10-31 12:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Two ODS with charts showing references to hidden cell data (local and external). (49.74 KB, application/zip)
2013-12-08 00:47 UTC, Owen Genat (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Genat (retired) 2013-12-08 00:47:49 UTC
Created attachment 90437 [details]
Two ODS with charts showing references to hidden cell data (local and external).

Problem description: 
There appears to be a difference in how values in hidden cells are included in a chart, depending on whether the reference (data) is local or external. This may not be a bug but rather an artifact of either the ODF specification or the manner in which the ODF specification is implemented in LO. I am report this as a bug to at least get this matter clarified. ODF v1.2, Part 1, 20.25 states:

> The chart:include-hidden-cells attribute specifies whether data points in hidden cells are
> plotted in a chart. The default is to plot data points in hidden cells.
> This attribute can be used within styles that are applied to a <chart:plot-area> element.
> The defined values for the chart:include-hidden-cells attribute are:
> ● false: data points in hidden cells are not plotted in a chart.
> ● true: data points in hidden cells are plotted in a chart.

The first thing to note is "the default is to plot data points in hidden cells" because it would seem that this is not what LO implements, at least from what is contained in this report. 

The attached pair of example spreadsheets were created under Ubuntu 10.04 x86_64 using v4.1.3.2 Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a and are fairly self-explanatory:

- hidden_cells_local.ods: three sheets (complete, column, row) showing how data is suppressed from appearing in a chart if either a column or row is hidden.
- hidden_cells_external.ods: one sheet with three charts referencing the data ranges (one sheet per chart) in the first file.

The local file suppresses display of data as expected. The external file displays all data in each chart regardless of the state of cell hiding. The code in hidden_cells_external.ods/Object\ 2/content.xml (the chart referencing the column sheet) reveals:

> <style:style style:name="ch4" style:family="chart">
>    <style:chart-properties chart:include-hidden-cells="false" ... >
> </style:style>
> ...
> <chart:plot-area chart:style-name="ch4" table:cell-range-address="'file:///home/oweng/doc/hidden_cells_local.ods'#column.A1:'file:///home/oweng/doc/hidden_cells_local.ods'#column.C6" ... >

The only significant difference between the above and that for hidden_cells_local.ods/Object\ 3/content.xml (the bar chart in the column sheet) appears to be the table:cell-range-address:

> <style:style style:name="ch3" style:family="chart">
>    <style:chart-properties chart:include-hidden-cells="false" ... >
> </style:style>
> ...
> <chart:plot-area chart:style-name="ch3" table:cell-range-address="column.A1:column.C6" ... >

By way of further testing I have opened both attached sheets under the same operating system using:

- v3.3.0.4 OOO330m19 Build: 6
- v3.4.6.2 OOO340m1 Build: 602
- v3.5.7.2 Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b
- v3.6.7.2 Build ID: e183d5b
- v4.0.6.2 Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24

In all cases the display of hidden cell data is suppressed from appearing in the corresponding chart in the local file and revealed in the external file. If this is a problem, it would appear to be Inherited From OOo, so I have set the version as such.

Steps to reproduce:
1. Open hidden_cells_external.ods (attached).
2. Respond "Yes" when asked to update external references.
3. Note second and third chart (column/row in title) display all data i.e., identical display to first chart.

Current behavior:
References to external data in a chart appear to ignore the value of the chart:include-hidden-cells attribute.

Expected behavior:
The value of the chart:include-hidden-cells attribute is taken into consideration, even when references are external.
              
Operating System: Ubuntu
Version: Inherited From OOo
Comment 1 Robinson Tryon (qubit) 2013-12-20 12:27:18 UTC
moggi - Could you provide insight into whether this is a bug (or at least an implementation detail we might seek to change) ?

Thanks
Comment 2 Markus Mohrhard 2013-12-20 15:25:27 UTC
(In reply to comment #1)
> moggi - Could you provide insight into whether this is a bug (or at least an
> implementation detail we might seek to change) ?
> 
> Thanks

It is an implementation detail. For external files we loose the information which cells are hidden and fixing that is not trivial. I'm actually unsure if it would be desired because this would have some consequences outside of charts that would introduce regressions.
Comment 3 Owen Genat (retired) 2013-12-21 13:49:09 UTC
(In reply to comment #2)
> It is an implementation detail. For external files we loose the information
> which cells are hidden and fixing that is not trivial. I'm actually unsure
> if it would be desired because this would have some consequences outside of
> charts that would introduce regressions.

Thanks for the clarification. I suspected the information might be getting lost. I mainly wanted to get some clarity on this issue, particularly in relation to the ODF spec.

Perhaps ODF v1.3 may need to have this section amended to more clearly indicate that only local references are covered? I can't find a corresponding OASIS issue so I will raise this matter on the OASIS office-comment mailing list.
Comment 4 Robinson Tryon (qubit) 2013-12-21 18:39:31 UTC
(In reply to comment #3)
> 
> Perhaps ODF v1.3 may need to have this section amended to more clearly
> indicate that only local references are covered? I can't find a
> corresponding OASIS issue so I will raise this matter on the OASIS
> office-comment mailing list.

Sounds like this is not a "non-issue," so I'll toss it into 'NEW' for now.
Comment 5 Owen Genat (retired) 2014-01-08 01:22:20 UTC
OASIS (JIRA) issue link added to See Also list.
Comment 6 Markus Mohrhard 2014-01-08 08:27:47 UTC
(In reply to comment #5)
> OASIS (JIRA) issue link added to See Also list.

I never said that it is limited to local references. I actually know that it is not but we don't support it for external ones and I don't see us support it in the near future.

You can write much on a piece of paper but efficient implementations require sometimes to make compromises and not implementing that for external references is one.
Comment 7 Owen Genat (retired) 2014-01-09 04:45:21 UTC
(In reply to comment #6)
> I never said that it is limited to local references. I actually know that it
> is not but we don't support it for external ones and I don't see us support
> it in the near future.

I did not mean to imply you had indicated anything to me about how it is implemented. The words (in the OASIS email list message) are purely my own, so I apologise if they are inaccurate.

> You can write much on a piece of paper but efficient implementations require
> sometimes to make compromises and not implementing that for external
> references is one.

Understood. From my perspective I am not trying to push this bug (or the OASIS issue) to get a fix but more to allow all parties a chance to comment so that the matter can be documented. The only comment so far in the OASIS issue indicates it is possible no existing ODF implementation caters for external references to hidden cells, possibly for the reasons indicated here. 

I am perfectly happy for this report to be RESOLVED (should it be set to WONTFIX?) as I think the reasons for the current implementation have been fairly clearly stated. Thanks Markus.
Comment 8 Robinson Tryon (qubit) 2014-02-03 19:08:05 UTC
(In reply to comment #7)
> 
> I am perfectly happy for this report to be RESOLVED (should it be set to
> WONTFIX?) as I think the reasons for the current implementation have been
> fairly clearly stated. Thanks Markus.

Moggi - I'll leave resolution of this bug up to you. If you think that it's something worth keeping open but low on our radar, or if you think we should RESOLVE it right now, either one sounds fine to me.

Thanks
Comment 9 Robinson Tryon (qubit) 2014-05-08 14:06:40 UTC
We can re-open this discussion in the future if we see users bumping up against this issue as a limitation.

For now, changing status to 'RESOLVED WONTFIX'.
Comment 10 Robinson Tryon (qubit) 2015-12-18 10:45:12 UTC Comment hidden (obsolete)
Comment 11 Xisco Faulí 2016-09-19 16:47:59 UTC Comment hidden (obsolete)