Bug 72567 - FILEOPEN: Impress does not import text gradient from .PPTX
Summary: FILEOPEN: Impress does not import text gradient from .PPTX
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: filter:pptx
: 37310 (view as bug list)
Depends on:
Blocks: PPTX
  Show dependency treegraph
 
Reported: 2013-12-10 14:33 UTC by Marcos Souza
Modified: 2018-10-31 15:17 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
pptx test file (821.61 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2013-12-10 14:33 UTC, Marcos Souza
Details
Image from PowerPoint 2013 importing the file (491.27 KB, image/png)
2013-12-10 14:36 UTC, Marcos Souza
Details
Image of LibreOffice 4.3 importing this file (239.69 KB, image/png)
2013-12-10 14:45 UTC, Marcos Souza
Details
PPTX test file 2 (887.83 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2014-01-13 15:27 UTC, Geoffrey
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcos Souza 2013-12-10 14:33:07 UTC
Created attachment 90582 [details]
pptx test file

Problem description: 

Steps to reproduce:
1. .... Open the attached file
2. ....
3. ....

Current behavior: First title don't have the yellow gradient, just a white text

Expected behavior: First title with yellow gradient

              
Operating System: Linux (Other)
Version: 4.3.0.0.alpha0+ Master
Comment 1 Marcos Souza 2013-12-10 14:36:32 UTC
Created attachment 90583 [details]
Image from PowerPoint 2013 importing the file
Comment 2 Marcos Souza 2013-12-10 14:45:30 UTC
Created attachment 90585 [details]
Image of LibreOffice 4.3 importing this file
Comment 3 Joel Madero 2013-12-21 02:25:28 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version: 4.3.0.0.alpha0+Build ID: daa57a101a20e0b37db7090796ad002b8d192b9b
 Date:   Sun Dec 15 23:07:57 2013 +0100
Platform: Ubuntu Linux 13.04

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
As I've been able to confirm this problem I am marking as:

New (confirmed)
Major - data loss or at least import problem that looks like data loss for our end users
High - quite a common feature, slideshows generated in any newer release of MSO with a gradient for text is going to see this issue.


+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 4 Joel Madero 2013-12-21 02:26:27 UTC
Updating version - at least presentsince 4.1.3.2
Comment 5 Marcos Souza 2014-01-13 14:25:03 UTC
Hi guys,

I'm interested in working in this bug.

I know we need to understand how OOXML handles this, but there is some documents and code pointers where we can touch this?
Comment 6 Geoffrey 2014-01-13 15:23:56 UTC
(In reply to comment #5)
> Hi guys,
> 
> I'm interested in working in this bug.
> 
> I know we need to understand how OOXML handles this, but there is some
> documents and code pointers where we can touch this?

Hi, you might find this useful: http://www.osb-alliance.de/fileadmin/Working_Groups/OfficeInteroperability/Project1/suse-ooxml-tender-use-case-5.1-report.pdf

Or this:
http://www.officeopenxml.com/prSlide-background.php
http://officeopenxml.com/drwSp-PattFill.php
http://www.officeopenxml.com/prSlideMaster.php

I also uploaded another pptx test file with transparent background, which is still not detected by LibreOffice.
Comment 7 Geoffrey 2014-01-13 15:27:10 UTC
Created attachment 91955 [details]
PPTX test file 2
Comment 8 tommy27 2014-06-19 10:49:24 UTC
(In reply to comment #4)
> Updating version - at least presentsince 4.1.3.2

same issue in OOo 3.3.0, LibO 3.3.0 and following releases including 4.2.4.2 and 4.4.0.0.alpha0+ Build ID: 488f31200094d7237d45545ab227014831a1f8e6
TinderBox: Win-x86@39, Branch:master, Time: 2014-06-15_05:02:39

so version is "inherited from OOo"
Comment 9 QA Administrators 2016-11-08 10:27:43 UTC Comment hidden (obsolete)
Comment 10 Yan Pas 2016-11-08 16:41:02 UTC
LO 5.2.3.2 Linux Mint 18 64bit, still reproducible

The color has become yellow instead of white. Some progress is seen
Comment 11 QA Administrators 2017-11-09 07:43:58 UTC Comment hidden (obsolete)
Comment 12 Yan Pas 2017-11-09 08:34:14 UTC
Lo 5.3.7 still exists
Comment 13 Buovjaga 2017-12-22 14:16:42 UTC
*** Bug 37310 has been marked as a duplicate of this bug. ***
Comment 14 Buovjaga 2017-12-22 14:17:16 UTC
Perhaps dependent on bug 91238?
Comment 15 Lars Jødal 2018-10-31 15:17:55 UTC
Still present in LO 6.1.2.1: attachment 90582 [details] opens with yellow text, but no gradient in colour.