Bug 72682 - External Data dialog not really resizable
Summary: External Data dialog not really resizable
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.0.beta2
Hardware: x86-64 (AMD64) Linux (All)
: low normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.3.0 target:4.2.0.2 target:4.1.6
Keywords:
: 73928 (view as bug list)
Depends on:
Blocks: Calc-External-Datalink
  Show dependency treegraph
 
Reported: 2013-12-13 15:40 UTC by Jean-Baptiste Faure
Modified: 2017-08-28 19:15 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
dialog "Link to external data" resized (19.15 KB, image/png)
2013-12-13 15:40 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2013-12-13 15:40:38 UTC
Created attachment 90728 [details]
dialog "Link to external data" resized

The dialog to link to external data is not really resizable. Only the window is resizable but the text field to type the url is not when it is the most important.

Steps to reproduce:
1/ open a new spreadsheet
2/ menu Insert > Link to external data
3/ try to resize the dialog window.

In version 4.1.x we have the same problem, but the window is more wide with an URL field larger making the problem less visible.

Best regards. JBF
Comment 1 sophie 2013-12-18 16:52:35 UTC
Confirmed with Version: 4.2.0.0.beta2
Build ID: 1a27be92e320f97c20d581a69ef1c8b99ea9885d
The field containing the link doesn't expand when you resize the dialog.
Set to New - Sophie
Comment 2 Adolfo Jayme 2013-12-20 11:13:26 UTC
This dialog should not be resizable at all -- perhaps just a little bigger by default, but not manually resizable. Caolán, would you like to have a look at this? :-)
Comment 3 Commit Notification 2013-12-20 12:43:02 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=674aeac88ffa1840f2d6a7f33656193aaebc9a0c

Resolves: fdo#72682 text field doesn't horizontally expand



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2013-12-20 12:44:17 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c1e0e4364b9ca3e437e118cde91183271357f3c5&h=libreoffice-4-2

Resolves: fdo#72682 text field doesn't horizontally expand


It will be available in LibreOffice 4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Caolán McNamara 2013-12-20 12:46:16 UTC
FWIW to fiddle with these things, fire up glade and load the .ui and click on the widgets that you want to expand and set the expand horizontal/vertical stuff in the "common" tab in glade. Go up the hierarchy to get the parents to expand and so on until it looks right in glade.
Comment 6 Caolán McNamara 2014-01-22 13:38:37 UTC
*** Bug 73928 has been marked as a duplicate of this bug. ***
Comment 7 Commit Notification 2014-01-26 17:47:44 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=24245120e7d6f4ed2efa33df589daa7d1ea4e1f5&h=libreoffice-4-1

Resolves: fdo#72682 text field doesn't horizontally expand


It will be available in LibreOffice 4.1.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.