Bug 72702 - LibreOffice Calc freezes when latin characters mixed with Non-Latin
Summary: LibreOffice Calc freezes when latin characters mixed with Non-Latin
Status: RESOLVED DUPLICATE of bug 72470
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
4.2.0.2 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-14 11:15 UTC by jmxhyz
Modified: 2014-02-06 10:15 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test described bug (9.09 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-12-14 12:24 UTC, Luuk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jmxhyz 2013-12-14 11:15:13 UTC
LibreOffice Calc freezes when latin characters mixed with Non-Latin

Steps to reproduce:

1. Start calc and rename the sheet as "sheet1";
2. open the BASIC IDE. Copy the code into IDE and press F5 to run it;
3. Note: calc will freeze. Before running then code, save your work.

REM  *****  BASIC  *****
Sub test
	dim sheet as object	
  	sheet=ThisComponent.Sheets.getByName("sheet1")
 
	dim rang(1,2)
	rang(0,0) =  "한국어"  & "latin"  'mixed Non latin
	rang(0,1) = "Latin characters"
	rang(0,2) =  2
	rang(1,0) =  "한국어"  & "0"  'mixed Number
	rang(1,1) = "Latin characters"
	rang(1,2) =  2
	Sheet.getCellRangeByName("A1:C2").setDataArray(rang)
End Sub
Comment 1 Luuk 2013-12-14 12:24:33 UTC
Created attachment 90769 [details]
test described bug

tested this on Windows7, and it's working ok  (see attachment)
Version: 4.1.3.2
Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a
Comment 2 jmxhyz 2013-12-15 03:47:38 UTC
Yes, working ok in version 4.1
But,freezes in 4.2.0.0 beta2.
Comment 3 jmxhyz 2013-12-15 04:02:48 UTC
(In reply to comment #2)
> Yes, working ok in version 4.1
> But,freezes in 4.2.0.0 beta2.

Version: 4.2.0.0.beta2
Build ID: 1a27be92e320f97c20d581a69ef1c8b99ea9885d
OS: xubuntu 13.10
kernel: 3.11.0-14-generic x86_64 GNU/Linux
Comment 4 jmxhyz 2014-01-17 13:09:33 UTC
Still freezing in linux.

Version: 4.2.0.2
Build ID: 601a398b803303d1a40a3299729531824fe0db56

uname: Linux 3.11.0-15-generic #23-Ubuntu SMP Mon Dec 9 18:17:04 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Description: Ubuntu 13.10
Comment 5 Kevin Suo 2014-02-06 09:55:56 UTC
I believe this is the same cause as Bug 72470, as Kohei Yoshida pointed out in comment #12 of that bug.

So I mark this as duplicate. Feel free to set it back if someone think it's different.

*** This bug has been marked as a duplicate of bug 72470 ***