Download it now!
Bug 72786 - FILEOPEN: I/O error when trying to open DOCX file
Summary: FILEOPEN: I/O error when trying to open DOCX file
Status: RESOLVED DUPLICATE of bug 68211
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: BSA Confirmed:4.2.0.1:Ubuntu
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-17 12:22 UTC by Henrik
Modified: 2014-01-11 19:41 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Test document (1.22 MB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-12-17 12:22 UTC, Henrik
Details
Strace log (628.04 KB, application/x-bzip)
2013-12-17 12:23 UTC, Henrik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Henrik 2013-12-17 12:22:07 UTC
Created attachment 90874 [details]
Test document

When trying to open the attached DOCX file, the following error is given: 

General error
General input/output error.

I'm running Linux Mint 16 x86 and I've tried with both version 4.1.3.2 and 4.2beta2.


              
Operating System: Ubuntu
Version: 4.1.3.2 release
Comment 1 Henrik 2013-12-17 12:23:58 UTC
Created attachment 90875 [details]
Strace log
Comment 2 Robinson Tryon (qubit) 2013-12-19 11:04:19 UTC
CONFIRMED on LO 4.2.0.1 + Ubuntu 12.04.3

(In reply to comment #0)
> When trying to open the attached DOCX file, the following error is given: 
> 
> General error
> General input/output error.

Henrik - How was this DOCX file created? Does the file open successfully in MS-Word? (and if so, what version?)

Thanks!
Comment 3 Henrik 2013-12-19 22:19:51 UTC
It was created by MS-Word 2010 and it opens perfectly in both MS-Word 2010 and MS Word for Macintosh 2011.
Comment 4 Miklos Vajna 2014-01-11 19:24:06 UTC
I'll take care of this.
Comment 5 Miklos Vajna 2014-01-11 19:26:09 UTC
The document opens fine on master, but not on -4-2. Bibisect points out the 6e6d0ef0b8fd5b89aeb292700cca3096a03681bf..c302a773d4cabca7f7bc5871be6c2003b05fafa3 range, I guess this got fixed with http://cgit.freedesktop.org/libreoffice/core/commit/?id=bee397a1e35fbc2717c56a8bd4a631ccfc185b6b, so this is a duplicate of bug 68211.
Comment 6 Miklos Vajna 2014-01-11 19:41:28 UTC
-4-2 backport:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8a6c210f4b3ebec87575911a58facbe0f87e2c5d&h=libreoffice-4-2

It will be available in LibreOffice 4.2.1.

*** This bug has been marked as a duplicate of bug 68211 ***