Bug Hunting Session
Bug 73008 - Other: Math: Untranslated Quickhelp in left pane
Summary: Other: Math: Untranslated Quickhelp in left pane
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
4.2.0.1 rc
Hardware: Other All
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: BSA target:4.3.0 target:4.2.0.2
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-24 07:01 UTC by Thomas Hackert
Modified: 2013-12-28 20:15 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Hackert 2013-12-24 07:01:10 UTC
Problem description: 

Steps to reproduce:
1. Start LO
2. Click on "Math Formular" (in German: "Neue Formel")
3. Hold the mouse pointer on one of the symbols of the left pane (for example the topleft symbol with the plus and the square)

Current behavior:
Though I am using the parallel installed Germanophone help- as well as langpack for the UI, the Quickhelp shows "+ Sign" instead of "+-Zeichen" ... :( This applies to all visible symbols ... :(

Expected behavior:
The Quickhelp should be localized.

LO: Version: 4.2.0.1 Build ID: 
7bf567613a536ded11709b952950c9e8f7181a4a (parallel installed, with Germanophone lang- as well as helppack)
OS: Debian Testing AMD64 (but I got a confirmation on the international l10n ml, that Martin has this problem as well ... :( )
Sorry for the inconvenience
Thomas.
Operating System: All
Version: 4.2.0.1 rc
Comment 1 Markus Mohrhard 2013-12-24 10:16:12 UTC
This feature has been added in the 4.2 release cycle and is therefore not yet translated.
Comment 2 Stanislav Horacek 2013-12-25 19:21:53 UTC
The same for Czech localization - marking as new.
I think this is really a bug, because the docked window with elements was added already in 4.1 and all related translations are available in .po files.
Comment 3 Commit Notification 2013-12-28 20:14:15 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7405c5a38546b026def5172dfade8e1c1e64d250

fdo#73008 enable localization of tooltips in Math Elements Dock



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2013-12-28 20:15:36 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=241eef7ca9b863ceb1f7f457a4bb2931b5d37f17&h=libreoffice-4-2

fdo#73008 enable localization of tooltips in Math Elements Dock


It will be available in LibreOffice 4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.