Bug Hunting Session
Bug 73131 - SLIDESHOW: Bad letter by better fly in for right to legt arabic text
Summary: SLIDESHOW: Bad letter by better fly in for right to legt arabic text
Status: RESOLVED DUPLICATE of bug 55361
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-30 00:39 UTC by irancplusplus
Modified: 2018-11-05 14:36 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
a file run it to see how bad is letter by letter fly in for Arabic (16.57 KB, application/vnd.oasis.opendocument.presentation)
2013-12-30 00:39 UTC, irancplusplus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description irancplusplus 2013-12-30 00:39:59 UTC
Created attachment 91309 [details]
a file run it to see how bad is letter by letter fly in for Arabic

Problem description: 
Letter by letter text animation is designed for English for Arabic,Urdu, Persian and other similar languages it works badly.


Steps to reproduce:
see the attachment.
Operating System: Ubuntu
Version: 4.1.4.2 release
Comment 1 retired 2013-12-31 10:43:32 UTC
Hi, from your description it is not obvious to me, what to look for. I open your test document see arabic writing and now what?

Please post a screenshot indicating clearly what glitch to look for. Also include exact repro steps.
Comment 2 retired 2013-12-31 10:44:28 UTC
Is this bug still valid / reproducible with the latest pre-release 4.2.0.1: http://www.libreoffice.org/download/pre-releases/
Comment 3 irancplusplus 2013-12-31 19:46:46 UTC
(In reply to comment #1)
> Hi, from your description it is not obvious to me, what to look for. I open
> your test document see arabic writing and now what?
> 
> Please post a screenshot indicating clearly what glitch to look for. Also
> include exact repro steps.

The problem is left to right design. When a new character enters it 
goes to left side while the end of text is right.
And all written text is moving when new characters appear. Compare by replacing the text with and English one.
These are obvious.
Comment 4 QA Administrators 2014-07-08 17:29:25 UTC Comment hidden (obsolete)
Comment 5 irancplusplus 2014-07-08 21:44:49 UTC
fly in letter by letter is designed for left to right text. Still no solved.
Comment 6 Buovjaga 2014-11-02 14:46:07 UTC
Confirmed, let's set this as an enhancement.

Win 7 64-bit Version: 4.4.0.0.alpha1+
Build ID: b167d1127e1579468a74c4414e7f4f33d9d24122
TinderBox: Win-x86@51-TDF, Branch:MASTER, Time: 2014-11-02_03:04:44
Comment 7 Mark Hung 2018-11-05 14:36:18 UTC

*** This bug has been marked as a duplicate of bug 55361 ***