Bug Hunting Session
Bug 73137 - UI: undo name for 'Covariance' is different
Summary: UI: undo name for 'Covariance' is different
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.3.0 target:4.2.0.2
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-30 07:32 UTC by YOSHINO Yoshihito
Modified: 2013-12-30 17:48 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description YOSHINO Yoshihito 2013-12-30 07:32:30 UTC
1) Follow Data -> Statistics -> Covariance...
2) Set 'Results to' to somewhere
3) Click OK
4) Edit menu displays "Undo: Correlation Ctrl+Z", not "Undo: Covariance Ctrl+Z"

String STR_COVARIANCE_UNDO_NAME appears to be unused.
Comment 1 sophie 2013-12-30 08:14:42 UTC
Confirmed with Version: 4.2.0.1
Build ID: 7bf567613a536ded11709b952950c9e8f7181a4a - same for Redo - set to New - Sophie
Comment 2 Commit Notification 2013-12-30 10:39:03 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b104133abe2a377f1397cce3fa6e1bc7d85d4020

Resolves: fdo#73137 undo name for 'Covariance' is different



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Julien Nabet 2013-12-30 11:05:40 UTC
For 4.2, https://gerrit.libreoffice.org/7232
Comment 4 Commit Notification 2013-12-30 16:41:31 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=82704f66b723cf8e3aafdb92cb74e5ec9cf9c636&h=libreoffice-4-2

Resolves: fdo#73137 undo name for 'Covariance' is different


It will be available in LibreOffice 4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Julien Nabet 2013-12-30 17:48:52 UTC
Since it seems there's no CHI_SQUARED in 4.1, I put it as FIXED.
Don't hesitate to reopen this tracker if I'm wrong.