Bug Hunting Session
Bug 73138 - UI: undo name for Random Number Generator with 'Chi Squared' is different
Summary: UI: undo name for Random Number Generator with 'Chi Squared' is different
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.1 rc
Hardware: Other All
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: target:4.3.0 target:4.2.0.2
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-30 07:43 UTC by YOSHINO Yoshihito
Modified: 2013-12-30 16:43 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description YOSHINO Yoshihito 2013-12-30 07:43:27 UTC
1) Follow Edit -> Fill -> Random Number...
2) Set 'Distribution' to 'Chi Squared'
3) Click OK
4) Edit menu displays "Undo: Random (Geometric) Ctrl+Z", not "Undo: Random (Chi Squared) Ctrl+Z"

String STR_DISTRIBUTION_CHI_SQUARED appears wrong.
Comment 1 sophie 2013-12-30 08:11:36 UTC
Confirmed with Version: 4.2.0.1
Build ID: 7bf567613a536ded11709b952950c9e8f7181a4a - string is also wrong for Redo - Set to New - Sophie
Comment 2 Commit Notification 2013-12-30 09:55:18 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0b236154c3a664739761c22670729915116c1c74

Resolves: fdo#73138 undo name for 'Chi Squared' is different



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Julien Nabet 2013-12-30 09:59:01 UTC
For 4.2, https://gerrit.libreoffice.org/7231
Comment 4 Commit Notification 2013-12-30 16:41:18 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3bd52d8db21ca6a6e2b9d3edf533eebde55e7325&h=libreoffice-4-2

Resolves: fdo#73138 undo name for 'Chi Squared' is different


It will be available in LibreOffice 4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Julien Nabet 2013-12-30 16:43:22 UTC
Since it seems there's no CHI_SQUARED in 4.1, I put it as FIXED.
Don't hesitate to reopen this tracker if I'm wrong.