Bug 73160 - EDITING: Buttons disappear when dialog "Insert Index/Table" is narrow
Summary: EDITING: Buttons disappear when dialog "Insert Index/Table" is narrow
Status: RESOLVED DUPLICATE of bug 89608
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
4.2.0.1 rc
Hardware: Other Linux (All)
: low trivial
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-30 17:56 UTC by Jose Gómez
Modified: 2015-04-08 22:46 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshots of the dialog with buttons missing (122.43 KB, application/zip)
2013-12-30 17:56 UTC, Jose Gómez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jose Gómez 2013-12-30 17:56:59 UTC
Created attachment 91340 [details]
Screenshots of the dialog with buttons missing

Problem description: 

In the Entries tab of the "Insert Index/Table" dialog, if the screen resolution is low, the dialog is shown with a narrow resolution. If the buttons for adding items to the entries don't fit, they are not shown altogether. As a reference, the two attached screenshots show the issue with the original dialog, and the same dialog once scaled so that the right side is wider.

Steps to reproduce:
1. Set a low screen resolution (1024x768 in my case)
2. Create a new document and insert a Table of Contents
3. Go to the Entries tab. The Chapter No, etc. buttons are not shown.
4. Scale the dialog in order to make it wider. The buttons will be visible now.

Current behavior:
The Chapter No, etc. buttons are not shown when the dialog is narrow.

Expected behavior:
The Chapter No, etc. buttons should be shown, either with a scroll bar, narrower buttons, or a dynamic layout.
Operating System: Ubuntu
Version: 4.2.0.1 rc
Comment 1 Adolfo Jayme Barrientos 2013-12-31 04:28:47 UTC
This dialog should be completely rearranged — its layout sucks. CCing ux-advise for suggestions to improve it/a new Glade file.
Comment 2 mahfiaz 2015-04-08 22:46:12 UTC
Although this is a valid request, there is some ongoing work with this dialog. So to avoid clutter I'll mark this as a duplicate.

*** This bug has been marked as a duplicate of bug 89608 ***
Comment 3 mahfiaz 2015-04-08 22:46:48 UTC
Also thanks, Jose, for taking the time to report this bug.