Bug 73411 - FORMATTING: Format of paragraphs with bullets is lost, when clear direct formatting and save the file.
Summary: FORMATTING: Format of paragraphs with bullets is lost, when clear direct form...
Status: RESOLVED DUPLICATE of bug 47471
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-08 21:06 UTC by Robert Großkopf
Modified: 2019-01-03 08:43 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Examplefile for resetting direct fomatting. (13.19 KB, application/vnd.oasis.opendocument.text)
2014-01-08 21:06 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2014-01-08 21:06:33 UTC
Created attachment 91707 [details]
Examplefile for resetting direct fomatting.

Open the attached document:
1. Press Ctrl+A to select all content.
2. Press Ctrl+M to reset direct formatting.
3. Save the document.
4. Close the document and reopen it.
All "Text"-formatted paragraphs will be changed to "Default" paragraphs, when there has been added Bullets (Shift+F12) or Numbering (F12).

It is the same behavior in all LO-Versions from LO 3.3.0beta1 up to LO 4.2.0rc2
Comment 1 Jochen 2014-01-09 07:08:55 UTC Comment hidden (obsolete)
Comment 2 Jochen 2014-01-09 07:18:59 UTC
Hi Robert,

I don´t understand, what do You mean with "All "Text"-formatted paragraphs will be changed to "Default" paragraphs, when there has been added Bullets (Shift+F12) or Numbering (F12)."

E.g. what are the single steps? Or: what happen when You do what? What do You expect respectively wich behavior is correct respectively wrong?
Comment 3 Robert Großkopf 2014-01-09 10:58:21 UTC
Hi Jochen,

I have changed the type of the attachment. The default is "text", now it's application/vnd.oasis.opendocument.text - which shows a Writer-document.

Following steps:

Write some text in Writer.
Set a format to this text, for example "Text" (not: "Default Style")
Add a bullet or numbering to the paragraph. Shows now a text with bullet, formatted as "Text".
Select the content and reset direct formatting.
Seems there has been nothing reset (because you haven't formated anything in a direct way, only with the styles of the paragraph).
Close this document and reopen. The paragraph is now formatted as "Default Style".
Comment 4 Jochen 2014-01-09 11:19:35 UTC
I can confirm the bug
LO 4.1.3
OS Windows 7 prof (64 bit)
Comment 5 Ulrich Moser 2014-01-14 20:44:20 UTC
I can confirm this bug in Version: 4.1.4.2 Build-ID: 410m0(Build:2) on Ubuntu 12.04.03 LTS 64 bit, Kernel Version 3.8.0-35
Comment 6 Maxim Britov 2015-01-21 21:46:45 UTC
Confirm on 4.3.5.2 and 4.4.0.1
Comment 7 QA Administrators 2016-02-21 08:38:05 UTC Comment hidden (obsolete)
Comment 8 Robert Großkopf 2016-02-21 09:23:56 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2017-03-06 16:09:34 UTC Comment hidden (obsolete)
Comment 10 Robert Großkopf 2017-03-08 19:21:42 UTC Comment hidden (obsolete)
Comment 11 QA Administrators 2018-03-09 03:46:30 UTC Comment hidden (obsolete)
Comment 12 Robert Großkopf 2018-03-09 07:31:24 UTC
Bug still exists with LO 6.0.2.1, OpenSUSE 42.3 Leap, 64bit rpm Linux.
Comment 13 Justin L 2018-12-24 13:19:41 UTC
This is probably a duplicate of bug 47471, and attachment 133726 [details] from bug 108248 is also helpful here.
Comment 14 Timur 2019-01-03 08:43:38 UTC
Looks fixed with master~2019-01-03_00.08.33_LibreOfficeDev_6.3.0.0.alpha0_Win_x86.
I'll mark as a duplicate.

*** This bug has been marked as a duplicate of bug 47471 ***