Bug 73629 - FILEOPEN: paragraph contextual spacing issue (with numbered list..) in .doc and docx
Summary: FILEOPEN: paragraph contextual spacing issue (with numbered list..) in .doc a...
Status: RESOLVED DUPLICATE of bug 75221
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:doc, filter:docx, regression
Depends on:
Blocks: DOC
  Show dependency treegraph
 
Reported: 2014-01-14 20:41 UTC by Krunoslav Šebetić
Modified: 2017-09-04 19:59 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
Here's the doc file with numbered list which LO 4.0.6.2 is not opening right (32.00 KB, application/msword)
2014-01-14 20:41 UTC, Krunoslav Šebetić
Details
Comparison between the document representation in MS Word 2007 and LibreOffice Writer 4.2.0.2 (157.74 KB, image/png)
2014-01-19 16:08 UTC, Alexandr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Krunoslav Šebetić 2014-01-14 20:41:07 UTC
Created attachment 92090 [details]
Here's the doc file with numbered list which LO 4.0.6.2 is not opening right

Have trouble with openning doc file in LibreOffice 4.0.6 on Debian Wheezy. 

Doc file contains only ordered list and if opened with LO, paragraph spacings are not right. There is more space withn same paragraph then between two bollets.

Between two parahraphs there is no spacing at all, but withn the same paragraph spacing is double (or at least 1.5).

Can't check for 4.1.4 nor 4.2 at the moment.

Doc file attached.
Comment 1 retired 2014-01-15 11:29:10 UTC
WORKSFORME NoRepro:4.2.0.2:OSX

Is this bug still valid / reproducible with the latest pre-release 4.2.0.2: http://www.libreoffice.org/download/pre-releases/
Comment 2 Krunoslav Šebetić 2014-01-15 23:11:11 UTC
I'm not able to download new release right now. Maybe later this week, sory.
Comment 3 Alexandr 2014-01-19 16:08:03 UTC
Created attachment 92402 [details]
Comparison between the document representation in MS Word 2007 and LibreOffice Writer 4.2.0.2

I reproduce the bug with LibreOffice Writer 4.1.4.2 from Debian Wheezy backports, 4.2.0.1 on Debian Jessie, 4.2.0.2 on Windows 7 and  4.3.0.0.alpha0+ (Build ID: 602c87b4259d118e5db6d8a990c4695103f916dd
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-01-18_00:02:21 

I attach a screen-shot that demonstrates the problem.

The bug is not reproducible in LibreOffice 3.5.4.2 from Debian Wheezy.
Comment 4 Krunoslav Šebetić 2014-01-19 16:27:54 UTC
And I've just tested it with LibreOffice 4.2 (pre-release) on Wheezy - document is not showing correctly.
Comment 5 Dominique Boutry 2014-01-29 15:23:50 UTC
As far as I see :

WORD :
- use of the component style "Listparagraph"
- but many use of direct formating in the text
- I tried to get rid of the direct formatting (select then CTRL-Q then CTRL-blank)

The .doc initial document opened within Lib0 4.2.0.3 rc on Win7 :
- use of the component style "Listparagraph"
- still many use of direct formating in the text : I confirm the observed result

Without any direct formating anywhere (initial .doc with a CTRL-M in LibO, and reworked .doc), the only difference is the presence/absence of numbering (no conclusion because Word is known buggy on lists).

LibO is fully OK on the initial doc (the lay-out is coherent with the paragraph settings) :
- select all,
- Format/Paragraph/Indent&Spacing/LineSpacing : set to "simple" : all become OK

My conclusion is : WORD's weak area, that LibO has trouble to follow...
Comment 6 Alexandr 2014-01-30 06:40:29 UTC
Comment on attachment 92090 [details]
Here's the doc file with numbered list which LO 4.0.6.2 is not opening right

Fixing MIME type.
Comment 7 tommy27 2014-02-23 08:19:59 UTC
In reply to comment #0)
> Have trouble with openning doc file in LibreOffice 4.0.6 on Debian Wheezy. 
> 
> Doc file contains only ordered list and if opened with LO, paragraph
> spacings are not right. There is more space withn same paragraph then
> between two bollets.
> 
> Between two parahraphs there is no spacing at all, but withn the same
> paragraph spacing is double (or at least 1.5).

tested under Win7x64bit

paragraph spacing issues reproducible since 3.6.0.4 and persist in 4.2.0.4 and 4.3.0.0alpha. works fine with 3.5.7.2, hence regression

reworded summary notes
added Writer expert to CC list
Comment 8 Michael Stahl (allotropia) 2014-07-02 21:08:55 UTC
bibisect range
bd6310886dc4351a8ac3ed3ee9a4f65d2a0e005c..9e6b086c62b4144058eb52ca40b562ff61e26a68

regression from:

commit 605bc21f7941d598f98203928b034add416c9c65
Author:     Miklos Vajna <vmiklos@suse.cz>
AuthorDate: Tue Mar 13 15:01:24 2012 +0100

    ww8: implement sprmPFContextualSpacing
Comment 9 Björn Michaelsen 2014-10-16 14:59:00 UTC Comment hidden (obsolete)
Comment 10 Xisco Faulí 2015-08-21 10:49:50 UTC
Problem still present in

Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: es-ES (es_ES)

on Windows 7 (64-bit)
Comment 11 Robinson Tryon (qubit) 2015-12-14 05:06:38 UTC Comment hidden (obsolete)
Comment 12 Timur 2016-08-17 12:17:38 UTC
Same as https://bugs.documentfoundation.org/show_bug.cgi?id=74888#c3 which is for DOCX.
Comment 13 Cor Nouws 2016-09-06 08:40:21 UTC
*** Bug 74888 has been marked as a duplicate of this bug. ***
Comment 14 Elliotte Rusty Harold 2016-09-18 03:40:16 UTC
Problem still present in 5.2.1
Comment 15 Xisco Faulí 2016-09-26 09:26:14 UTC
Adding Cc: to Miklos Vajna
Comment 16 Elliotte Rusty Harold 2017-06-10 13:13:53 UTC
still present in 5.2.2.2
Comment 17 Justin L 2017-09-04 19:59:48 UTC
fixed in LO 5.3 for bug 75221 by author Mike Kaganski in commit ba18832ceeda21f047a664b71a4333a54737e6c8
tdf#75221: make margin collapsing implementation conform OASIS proposal

*** This bug has been marked as a duplicate of bug 75221 ***