Download it now!
Bug 73970 - Area dialog, Color tab, CMYK selection, Magenta (M) / Yellow (Y) labels are switched
Summary: Area dialog, Color tab, CMYK selection, Magenta (M) / Yellow (Y) labels are s...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.6.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: target:4.3.0 target:4.1.5 target:4.2.1
Keywords:
: 74043 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-01-23 11:40 UTC by Owen Genat (retired)
Modified: 2014-01-29 22:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshots of Area dialog, Color tab, CMYK selection, showing M and Y values under v4142. (82.27 KB, application/zip)
2014-01-23 11:40 UTC, Owen Genat (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Genat (retired) 2014-01-23 11:40:47 UTC
Created attachment 92656 [details]
Screenshots of Area dialog, Color tab, CMYK selection, showing M and Y values under v4142.

Problem description: The labels ("M" and "Y") are in the wrong order (against the opposite fields) on the Area dialog under the Color tab for CMYK selection. Refer attached screenshots taken from v4.1.4.2 Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72. Same problem in v4.0.6.2 Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24 as well. Field labels are correct in v3.6.7.2 Build ID: e183d5b. Same behaviour in Draw, Calc, Impress, and Writer, for this dialog.

Steps to reproduce:
1. Start Draw (empty document).
2. Insert a rectangle (via the Rectangle tool) on the Drawing toolbar. 
3. Right-click on rectangle > Area...
4. Select Colours tab.
5. Change colour pull-down to CMYK.

Current behavior: The fields beneath the CMYK selection are labelled "C", "Y", "M", and "K".

Expected behavior: The fields beneath the CMYK selection should be labelled "C", "M", "Y", and "K" (this is how the fields behave).
Comment 1 Julien Nabet 2014-01-23 20:34:28 UTC
On pc Debian x86-64 with master sources updated today, I can reproduce this.
Comment 2 Julien Nabet 2014-01-23 20:35:10 UTC
I put fdo#72146, see they might be related.
Comment 3 Commit Notification 2014-01-23 20:58:20 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=123a10ea2eca9cd2781e812aef05d2ba175bca51

Resolves: fdo#73970 CMYK labels are switched



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Julien Nabet 2014-01-23 21:07:00 UTC
I cherry-picked the fix for the other branches and submitted for review:
for 4.2 branch: https://gerrit.libreoffice.org/7621
for 4.1 branch: https://gerrit.libreoffice.org/7622
Comment 5 Owen Genat (retired) 2014-01-24 10:00:37 UTC
(In reply to comment #2)
> I put fdo#72146, see they might be related.

Yes, I saw that bug while looking to see if this issue had already been reported. I don't think it is related though and likely to be a colour profile enhancement bug. Setting an application / monitor to use a CMYK profile really does produce some strange on-screen colour-shifts. I will provide an update to that bug showing screenshots for clarity.

Thanks for the prompt fix Julien.
Comment 6 Commit Notification 2014-01-24 16:02:24 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1750192300d81c6ebc78e3265e2f01104b4a9f59&h=libreoffice-4-1

Resolves: fdo#73970 CMYK labels are switched


It will be available in LibreOffice 4.1.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2014-01-24 16:03:45 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fa2c6433860e6b7deab8af8c2a8700f27cbbb01b&h=libreoffice-4-2

Resolves: fdo#73970 CMYK labels are switched


It will be available in LibreOffice 4.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Julien Nabet 2014-01-25 13:16:27 UTC
*** Bug 74043 has been marked as a duplicate of this bug. ***
Comment 9 Julien Nabet 2014-01-29 21:37:51 UTC
The fix is now spread in several branches so we can consider this as fixed.
Comment 10 Commit Notification 2014-01-29 22:08:42 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-1-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=730093ceb3a23ebc7618ba0564eff38eab3f2e87&h=libreoffice-4-1-5

Resolves: fdo#73970 CMYK labels are switched


It will be available already in LibreOffice 4.1.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.