Bug 74042 - Hyperlink dialog shows selected cell contents as !!br0ken!!
Summary: Hyperlink dialog shows selected cell contents as !!br0ken!!
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha1
Hardware: All All
: medium normal
Assignee: Maxim Monastirsky
URL:
Whiteboard: target:4.3.0 target:4.2.1
Keywords: regression
: 75801 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-01-25 08:10 UTC by Dave Barton
Modified: 2014-03-10 08:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Capture of hyperlink dialog showing error. (18.46 KB, image/png)
2014-01-25 08:10 UTC, Dave Barton
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Barton 2014-01-25 08:10:34 UTC
Created attachment 92760 [details]
Capture of hyperlink dialog showing error.

Regression: Calc 4.2.0.3rc
When adding a hyperlink to a cell's selected//highlighted content, that content should be displayed in the hyperlink dialog's "Text" field. In rc3 it displays !!br0ken!!
Comment 1 Cor Nouws 2014-01-25 11:06:41 UTC
Hi Dave,

thanks for the report.
might well be related to bug 73235 ?

Was it OK in 420 beta 1 or 2 or rc 1 or 2 that you know?

Cheers,
Cor
Comment 2 Dave Barton 2014-01-25 14:24:34 UTC
Hi Cor,

I can't say if it was in beta 1 or 2, because other commitments didn't allow me time for testing. The issue was there in both rc1 & 2, but I held off reporting until rc3, thinking that I could not be the only one to have seen this.

The cause may be similar to bug 7325, but the fix for that has not resolved this issue.

Regards
Dave
Comment 4 Maxim Monastirsky 2014-01-27 18:02:41 UTC
https://gerrit.libreoffice.org/7698/
Comment 5 Commit Notification 2014-01-28 15:29:53 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=05f87e422b2f51ccf87bd0e7cba86e12a404199e

fdo#74042 Don't attempt to copy more than a string has to offer



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2014-01-28 15:31:11 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7bd346b63be249e3ab2695a8f1e767baf0ba8861&h=libreoffice-4-2

fdo#74042 Don't attempt to copy more than a string has to offer


It will be available in LibreOffice 4.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Eike Rathke 2014-01-28 15:33:52 UTC
With an earlier report the fix might had been included in 4-2-0 ...
Comment 8 Commit Notification 2014-01-28 16:03:31 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0b3c6203f87f72684ad018963674a10e1c6f7c36

give MSVC a hint to not break the build, fdo#74042 related



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2014-01-28 16:04:55 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cac1123cb9d847da7a04384320f34fa03e3e21ff&h=libreoffice-4-2

give MSVC a hint to not break the build, fdo#74042 related


It will be available in LibreOffice 4.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Jean-Baptiste Faure 2014-03-08 22:27:44 UTC
*** Bug 75801 has been marked as a duplicate of this bug. ***