Bug 74104 - CRASH: Impress crashes when searching & replace reaches the end of presentation
Summary: CRASH: Impress crashes when searching & replace reaches the end of presentation
Status: RESOLVED DUPLICATE of bug 73904
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.0.3 rc
Hardware: All All
: highest critical
Assignee: Andrzej Hunt
URL:
Whiteboard: target:4.2.1
Keywords: bibisectRequest, regression
: 74762 (view as bug list)
Depends on:
Blocks: mab4.2
  Show dependency treegraph
 
Reported: 2014-01-27 05:30 UTC by Jean-Baptiste Faure
Modified: 2015-12-17 07:35 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
test document which crashes LO 4.2 (82.19 KB, application/vnd.oasis.opendocument.presentation)
2014-01-27 05:30 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2014-01-27 05:30:12 UTC
Created attachment 92832 [details]
test document which crashes LO 4.2

Steps to reproduce:
1/ open the test document in Impress version 4.2.0.3
2/ select and copy the typographic quote at the end of the texte in "L'apostrophe"
3/ move the cursor somewhere in the text
4/ ctrl+H
5/ type ' (single quote) in the search field and ctrl+V in the replace field
6/ hit search button , the hit replace button
7/ hit replace button until the end of the file

==> crash when search & replace comes at the end

Crash has been reproduced on MS-Windows and Ubuntu (French QA mailing-list)
It seems that some other special characters trigger the crash.

Best regards. JBF
Comment 1 Joel Madero 2014-01-27 06:07:44 UTC
It's much worse than reported here:

Open file
Ctrl + h
search for the letter a
replace with es

do replace over and over until it reaches the end, results in a crash

Ubuntu 13.10 Version 4.2.0.3

No crash with 4.1.3.2


Thorsten - you want this one?
Comment 2 Jean-Baptiste Faure 2014-01-27 07:46:45 UTC
Importance should be highest if it is a MAB.
Comment 3 Jean-Baptiste Faure 2014-01-27 11:24:17 UTC
Maybe this bug and bug 73904 have the same root cause. Both describe a crash when the end of the file is reached.

Best regards. JBF
Comment 4 Pierre C 2014-01-29 20:47:41 UTC
confirmed with latest 4.2.0.4 under Seven x64
Comment 5 tmacalp 2014-01-30 15:35:56 UTC
(In reply to comment #3)
> Maybe this bug and bug 73904 have the same root cause. Both describe a crash
> when the end of the file is reached.
> 
> Best regards. JBF

As comment 4 mentioned, this still affects 4.2.0.4, which is now an official release...

It does indeed look like this bug is related to bug 73904.  Also, it appears that both bugs affect both Draw and Impress.

To sum up, Using Find, Find & Replace, or Spell check in either Draw or Impress will cause LO to crash when it searches again from the beginning of the document.
Comment 6 Joel Madero 2014-01-30 15:43:27 UTC
Yeah - a bibisect would be nice on this one. Adding whiteboard status. This is why 4.2.0 is for people who want cutting edge vs. completely stable ;) For those people definitely stick with 4.1 series a bit longer
Comment 7 Michael Stahl (CIB) 2014-01-30 16:37:30 UTC
regression according to comment #2
Comment 8 Caolán McNamara 2014-02-04 20:23:31 UTC

*** This bug has been marked as a duplicate of bug 73904 ***
Comment 9 Commit Notification 2014-02-04 20:23:58 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4b9c6542f7107be7536f239ca061fd363395b3d4&h=libreoffice-4-2

fdo#74104 fdo#73904 backport Message dialog creation from message strings


It will be available in LibreOffice 4.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Jacques Guilleron 2014-02-10 09:02:42 UTC
*** Bug 74762 has been marked as a duplicate of this bug. ***
Comment 11 Robinson Tryon (qubit) 2015-12-17 07:35:19 UTC
Migrating Whiteboard tags to Keywords: (bibisectrequest)
[NinjaEdit]