Bug Hunting Session
Bug 74286 - EDITING: cannot flip image from the gallery
Summary: EDITING: cannot flip image from the gallery
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-31 16:58 UTC by murakamiriyugi
Modified: 2016-09-25 16:37 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description murakamiriyugi 2014-01-31 16:58:57 UTC
Problem description: The counterclockwise-flowing four arrows in 
the gallery can normally be flipped to clockwise-flowing arrows 
in Libreoffice writer 4.1.4. Now, this cannot be done except for 
some other images in the gallery. Upon checking the original files
corresponding to these gallery images, I found out that those that
can be flipped are svg images while those that cannot be flipped
are png images; I did not check all images though.



Steps to reproduce:
1. Open gallery, select the counterclockwise-flowing four arrows and insert it in writer.
2. Select the inserted image. 
3. Click the left had side of the rectangular guide and while 
holding your mouse, drag the guide to the right until it passes
through the right hand side of the rectangular guide.
4. The resulting image is the same image. No flipping happens.

Current behavior: 
Flipping an image in the gallery does not flip it.

Expected behavior:
Flipping an image should flip it.
Operating System: Ubuntu
Version: 4.1.5.1 rc
Comment 1 Jean-Baptiste Faure 2014-02-02 08:47:40 UTC
I already observed this problem for Impress, thank you for the bug report.
I can confirm that flipping does not work for images copied from the gallery.
But in my tests, the flipped image is empty and if I use the same command again the original image reappears.

Tested with LO 4.2.1.0.0+ on Ubuntu 13.10 x86-64, in Writer, Impress and Calc.
Not all gallery's images are affected. For example for A22-CircleArrow flip works as expected for me.

Changed component to LibreOffice because this bug affects several modules.

Best regards. JBF
Comment 2 murakamiriyugi 2014-02-02 12:26:43 UTC
A similar problem happens in Draw (Libreoffice 4.2.0 in Ubuntu 12.04 64 bit).
Flipping some images from the Gallery makes them invisible. This does not
however, happen to all images in the gallery. It appears that the problem 
only happens to png images (and not to svg images). The image composed of four 
counterclockwise-flowing arrows for instance, are png images.

[Just wondering, why some images in the Libreoffice gallery are png and
others are svg. Check for instance, the section for arrows].
Comment 3 Joel Madero 2015-05-02 15:41:02 UTC Comment hidden (obsolete)
Comment 4 Jean-Baptiste Faure 2015-05-17 15:54:36 UTC
I do not know how to reproduce the problem by following original steps to reproduce. That said there is 2 buttons flip horizontally and flip vertically.
For counterclockwise-flowing four arrows in the gallery, the flip horizontally does not work as expected while the flip vertically does work as expected.

Tested with LO 5.0.0.0.alpha1+ built at home under Ubuntu 15.04 x86-64.

Best regards. JBF
Comment 5 QA Administrators 2016-09-20 09:41:32 UTC Comment hidden (obsolete)
Comment 6 Jean-Baptiste Faure 2016-09-25 16:37:36 UTC
Flipping works as expected when using the menu Format > Flip, even for the counterclockwise-flowing four arrows from the gallery.

Not reproducible anymore in LO 5.2.3.0+ and current master, both built at home under Ubuntu 16.04 x86-64.

Closing as WorksForMe. Please, feel free to reopen if you disagree.

Best regards. JBF